Your Moodle version

Blocks: Exabis Student Review

Maintained by Picture of andreas riepl andreas riepl
The main focus of this block is a verbose periodical review of students by a teacher-team. The basic idea of this module is that trainers can team-assess students - the assessment can be done on a 1-10 scale with the cagetories teamplayer, responsibility, self-reliance.
Moodle 2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6, 2.7

In case exabis competencies block is also installed, additional assessment-categories can be made available from there. Students can access their review from their competency-profile (being part of exabis competencies) otherwise it can only be printed out by the trainer that started the assessement.

A new feature of the block is that it can be used to "rate" projects as well.


Screenshot #0
Screenshot #1
Screenshot #2


Picture of andreas riepl
andreas riepl (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Anthony Borrow
    Fri, Mar 1, 2013, 11:53 AM
    FYI, during the plugin review In Moodle 2.4 I noticed the following: The block exastud does not define the standard capability block/exastud:addinstance Peace - Anthony
  • Anthony Borrow
    Fri, Mar 1, 2013, 12:53 PM
    One more thing I discovered, "This block still uses an old-style config_global.html file. It must be updated by a developer to use a settings.php file" please make that fix so the block is 2.x compatible. Peace - Anthony
  • Anthony Borrow
    Tue, Mar 12, 2013, 1:06 PM
    fyi - the recommended (but not required) repository name would be moodle-block_exastud
  • Anthony Borrow
    Tue, Mar 12, 2013, 1:13 PM
    I've gone ahead and approved the plugin. When you have a moment, it would be helpful to provide a tracker url to the Useful links section. Even if there is no dependency, we can still create a set of plugins that are best installed together (for example exaport). Peace - Anthony
  • Anthony Borrow
    Tue, Mar 12, 2013, 1:47 PM
    Andreas - Thanks for cleaning up the README.txt. I see that you added the addinstance capability. The copyright holder still seems to be a bunch of initial and is not really clear but I will leave that up to you. It does not appear that there are any settings so it looks like your removed the config_global.html file which is fine. One small thing I noticed while installing and poking around was:

    Invalid get_string() identifier: 'commentshouldnotbeempty' or component 'block_exaport'. Perhaps you are missing $string['commentshouldnotbeempty'] = ''; in /m24/blocks/exaport/lang/en/block_exaport.php?

    The code you have in the picture_upload_form.php file is:

    get_string("commentshouldnotbeempty", "block_exaport")

    I'm not sure what the reference to block_exaport is - is that a separate block? If so, it is not listed as a dependency in the version.php. Otherwise, the string is missing in the lang file. In any case, this is a smaller issues and not likely to hold up approving the block. If the block does have dependencies then we should probably create a set.

    Peace - Anthony
  • Picture of German Valero
    Sun, May 19, 2013, 3:39 AM
    Hi Andreas,
    I was translating the Exabis Student Review plugin in AMOS and I noticed a strange-looking English language string:

    2.5 [errorstarttimebeforeendtime,block_exastud]
    Period {$a->description} has its starttime before its endtime!

    Maybe I am wrong, but the start_time must always be before the end_time, and the error is just the opposite.

    Or could it be that this plugin checks from (let's say, today=start_time) to a given moment in the past (end_time) ?

    Could you please check this, as I am not a native English speaker.

    Thanks in advance for your help.
  • Picture of Criza Vilo
    Tue, Jul 9, 2013, 2:30 PM
    Hi How add a new assesment categories?
  • Carol walking in the Howgills
    Mon, Feb 10, 2014, 7:24 PM
    Hi Andreas
    I wanted to try this block out on my test server (moodle 2.5.3) but it locked up my site on install (stuck at "site is being upgraded". When I removed the files and waited, the site recovered after a few minutes and showed the block as installed but with files missing from disk. I was able to replace the files and get to settings for the block, when I got the message: "Exabis Competencies This block still uses an old-style config_global.html file. It must be updated by a developer to use a settings.php file."
  • Anthony Borrow
    Wed, Jan 21, 2015, 8:01 AM
    Andreas - I do not believe this is working in Postgres. I would recommend folks proceed with caution. Perhaps it would be good to declare the maturity in the version.php and address the Warning The plugin does not declare its component in version.php. This declaration will be required for Moodle 3.0. When testing in Postgres I received the following: Table "block_exastudclassteachers". I would recommend thorough testing on a test server before deployment. Peace - Anthony
  • Picture of Sawan Dhanotiya
    Thu, May 21, 2015, 7:46 PM
    Hi ,
    I have Installed Exabis Student Review Latest version and it is successfully installed, now I am going to Class Configuration it is getting Error at the configuration of the periods.
    My current Moodle version is 2.8+.
  • Picture of andreas riepl
    Fri, May 22, 2015, 1:55 AM
    hello, the administrator has to configure the periods first because the assessments are archived after a period so assessments can be made again, hope this helps, regards, andreas
  • Picture of Trey Perez
    Fri, Jul 3, 2015, 1:01 AM
    Hello! I am needing to be able to have the ability to edit teacher comments, but it appears that only the teacher that left comments is able to do that. Is this correct, or is there a way around that? Thanks!
  • Picture of andreas riepl
    Mon, Jul 6, 2015, 7:36 PM
    Hello, this is correct, this is a one-way assessment-system, however, if used with exabis eportfolio, commenting back and forth is possible,
    regards Andreas
Please login to post comments