Blocks: oohoo - Pop up Dictionary - Block

block_dictionary
Maintained by Picture of Patrick Thibaudeau Patrick Thibaudeau, Picture of Nicolas Bretin Nicolas Bretin
OOHOO Pop-up Dictionary is a Moodle package that gives the students the possibility to double click on any word within a Moodle HTML resource and retrieve its definition from an online dictionary chosen by the teacher. Note that the plugin is separated into two downloads: filter and block.
145 sites
48 downloads
4 fans
Moodle 2.0, 2.1, 2.2, 2.3, 2.4

OOHOO Pop-up Dictionary is a Moodle package that gives the students the possibility to double click on any word within a Moodle HTML resource and retrieve its definition from an online dictionary chosen by the teacher.


Note that this block requires that the oohoo pop-up dictionary filter be installed in order to function.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

Picture of Patrick Thibaudeau
Patrick Thibaudeau (Lead maintainer)
Picture of Nicolas Bretin
Nicolas Bretin: Programmer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Carlos Beleza
    Sun, 7 Jul 2013, 10:09 PM
    Hi
    It works. I forgot adding the dictionary in "Add block" menu.
    Thank you for making this useful block and filter.
  • Picture of Susanna Wesson
    Tue, 3 Sep 2013, 5:01 AM
    Hi,
    Does anybody have any experience using the Pop-up dictionary with Hot Potatoes exercises in Moodle? If so, could you let me know? We have tried to use them simultaneously without success.
    Thank you for your help.
  • Picture of Gordon Bateson
    Mon, 27 Jan 2014, 11:09 AM
    Susanna, the HotPot module should work with the dictionary plugin now, so please upgrade your HotPot module and try again. Gordon
  • Picture of Gordon Bateson
    Mon, 27 Jan 2014, 11:11 AM
    Patrick and Nicolas,
    thanks for all your hard work on the Dictionary block for Moodle.

    FYI, there is currently a typo on line 172 of the "block_dictionary.php" file:
    https://github.com/oohoo/moodle-block_dictionary/blob/master/block_dictionary.php

    The capability appears as "moodle/course:manageactivitiesmoodle/course:manageactivities" when it should be simply "moodle/course:manageactivities".

    With the correct capability, the block installs without a problem.
  • Picture of Patrick Thibaudeau
    Tue, 28 Jan 2014, 12:10 AM
    Thank you Gordon will make the changes
  • Picture of Gordon Bateson
    Tue, 28 Jan 2014, 9:37 AM
    Great, it's fixed now - merci beaucoup!
  • Picture of Susanna Wesson
    Sat, 8 Feb 2014, 11:41 PM
    Hi,
    The dictionary is a very useful tool for use with Hot Potatoes. I cannot, however, scroll the pop-up window in Firefox or resize and scroll in IE. Only Chrome will do both. Is this something I can fix myself by changing some settings?
  • Picture of Katja Krüger
    Wed, 28 May 2014, 3:37 PM
    Hi,
    I cannot select a dictonary ...
    I installed version Release 1.2.0 (Build: 2014040200) of oohoo - Pop up Dictionary - Block and Release 1.2.0 (Build: 2014040200) of oohoo - Popup Dictionary - Filter
    My installation is Moodle 2.6.1+
    Installation and Configuration went fine, I added a block to a course BUT then:
    Selected dictionary:
    No dictionary selected
    I click on 'Add a dictonary' -> blank page with error message, apache error log: Permission denied: access to /blocks/dictionary/add.php failed because search permissions are missing on a component of the path

    No permissions? I'm admin. I enroled myself into the course as teacher and found the permissions block/dictionary:addinstance and block/dictionary:myaddinstance and set it to true.

    The error is still there

    in the documentation it says that there should apear a link 'change dictonary' but I don't have this link ....
  • Picture of Katja Krüger
    Wed, 28 May 2014, 8:24 PM
    Found the reason! I forgot to check the permission settings for the folders, they were set to 700 ...
    Wie blöd!
  • Picture of neil Jewell
    Tue, 8 Jul 2014, 9:07 PM
    Cannot change dictionaries without purging all cache in the admin utility
  • Picture of Luke McKee
    Thu, 9 Apr 2015, 2:46 AM
    //if (!$blockobj->_self_test()) {
    // throw new plugin_defective_exception($component, 'Self test failed.');
    //}

    This block needs a self-test method to make moodle 2.8 happy FYI.
  • Picture of Santiago Moral Castillo
    Fri, 17 Apr 2015, 4:51 PM
    As Luke says, there is a problem. Every time I tried to upgrade to version 2.8, I get

    Default exception handler: Plugin "block_dictionary" is defective or outdated, can not continue, sorry. Debug: Self test failed.
    Error code: detectedbrokenplugin
    * line 824 of /lib/upgradelib.php: plugin_defective_exception thrown
    * line 422 of /lib/upgradelib.php: call to upgrade_plugins_blocks()
    * line 1626 of /lib/upgradelib.php: call to upgrade_plugins()
    * line 171 of /admin/cli/upgrade.php: call to upgrade_noncore()

    !!! Plugin "block_dictionary" is defective or outdated, can not continue, sorry. !!!
    !! Self test failed.
    Error code: detectedbrokenplugin !!
    !! Stack trace: * line 824 of /lib/upgradelib.php: plugin_defective_exception thrown
    * line 422 of /lib/upgradelib.php: call to upgrade_plugins_blocks()
    * line 1626 of /lib/upgradelib.php: call to upgrade_plugins()
    * line 171 of /admin/cli/upgrade.php: call to upgrade_noncore()
    !!
  • Picture of derek reddy
    Wed, 22 Apr 2015, 3:55 PM
    I get the outdated message block/dictionary on 2.7 also:
    Debug info: Missing version.php file.
    Error code: detectedbrokenplugin
    Stack trace:
    line 769 of \lib\upgradelib.php: plugin_defective_exception thrown
    line 422 of \lib\upgradelib.php: call to upgrade_plugins_blocks()
    line 1615 of \lib\upgradelib.php: call to upgrade_plugins()
    line 434 of \admin\index.php: call to upgrade_noncore()
  • Picture of Степан Юферов
    Mon, 21 Sep 2015, 11:38 PM
    It's a great plugin
  • Picture of Rekha C
    Mon, 11 Jan 2016, 1:47 AM
    Great plugin. When are you providing for 2.9 ? Works for 2.8, am upgrading to 2.9.
1 2
Please login to post comments