Your Moodle version

Blocks: oohoo - Pop up Dictionary - Block

block_dictionary
Maintained by Picture of Patrick Thibaudeau Patrick Thibaudeau, Picture of Nicolas Bretin Nicolas Bretin
OOHOO Pop-up Dictionary is a Moodle package that gives the students the possibility to double click on any word within a Moodle HTML resource and retrieve its definition from an online dictionary chosen by the teacher. Note that the plugin is separated into two downloads: filter and block.
Moodle 2.0, 2.1, 2.2, 2.3, 2.4

OOHOO Pop-up Dictionary is a Moodle package that gives the students the possibility to double click on any word within a Moodle HTML resource and retrieve its definition from an online dictionary chosen by the teacher.


Note that this block requires that the oohoo pop-up dictionary filter be installed in order to function.

Screenshots

Screenshot
Screenshot
Screenshot

Contributors

Picture of Patrick Thibaudeau
Patrick Thibaudeau (Lead maintainer)
Picture of Nicolas Bretin
Nicolas Bretin: Programmer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Mariana Curado Malta
    Wed, Mar 13, 2013, 6:14 AM
    Could not install Last version on 2.3.3.
    It gives me dependency problems.
    Can't get to work a previous version since it does not show up on filters in order to turn it on, as shown in the help pages.
    Can you solve the dependency problems for the last version to work? I would really like to use this block!
    Thank you!
  • Picture of Nicolas Bretin
    Mon, Mar 18, 2013, 11:09 PM
    Hi Mariana,

    The pop up dictionary block works with the Pop up dictionary filter.
    When you install the pop up dictionary you must install both block and filter. It is why there is a dependency.
    During the installation you should not have dependency problem if you install them simultaneously.

    Don't hesitate if you need more help,

    Nicolas
  • Picture of Aurelio Schiavone
    Tue, May 28, 2013, 9:09 PM
    Hi,
    does it work on version 2.5?
    We used it without problem on 2.4 and after upgrade we aren't able to make it works.

    Thanks!
  • Picture of Sergey Lake
    Tue, Jun 25, 2013, 3:00 PM
    Hi!

    I want to thank you for making such a nice block and filter. And now it finally works on Moodle 2.5!

    I just want to point out that in the Filter settings the user have 12 dictionary options. But the Block contains only 8 "if statements".
    We added additional strings for dictionary options 9-12. But it would be nice if these are added to the distributed version of the block.
    We added (somewhere near string 114):
    elseif ($CFG->filter_dictionary_uri9 == $usedictionary->dictionary)
    {
    $dictionaryname = $CFG->filter_dictionary_name9;
    }
    ...

    Thank you!
  • Picture of Carlos Beleza
    Sun, Jul 7, 2013, 9:46 PM
    Hi. Hello everybody.
    All instaled OK. But not working for me on moodle 2.5.
    Can anyone help me?

    Thanks in advance.
  • Picture of Carlos Beleza
    Sun, Jul 7, 2013, 10:09 PM
    Hi
    It works. I forgot adding the dictionary in "Add block" menu.
    Thank you for making this useful block and filter.
  • Picture of Susanna Wesson
    Tue, Sep 3, 2013, 5:01 AM
    Hi,
    Does anybody have any experience using the Pop-up dictionary with Hot Potatoes exercises in Moodle? If so, could you let me know? We have tried to use them simultaneously without success.
    Thank you for your help.
  • Picture of Gordon Bateson
    Mon, Jan 27, 2014, 11:09 AM
    Susanna, the HotPot module should work with the dictionary plugin now, so please upgrade your HotPot module and try again. Gordon
  • Picture of Gordon Bateson
    Mon, Jan 27, 2014, 11:11 AM
    Patrick and Nicolas,
    thanks for all your hard work on the Dictionary block for Moodle.

    FYI, there is currently a typo on line 172 of the "block_dictionary.php" file:
    https://github.com/oohoo/moodle-block_dictionary/blob/master/block_dictionary.php

    The capability appears as "moodle/course:manageactivitiesmoodle/course:manageactivities" when it should be simply "moodle/course:manageactivities".

    With the correct capability, the block installs without a problem.
  • Picture of Patrick Thibaudeau
    Tue, Jan 28, 2014, 12:10 AM
    Thank you Gordon will make the changes
  • Picture of Gordon Bateson
    Tue, Jan 28, 2014, 9:37 AM
    Great, it's fixed now - merci beaucoup!
  • Picture of Susanna Wesson
    Sat, Feb 8, 2014, 11:41 PM
    Hi,
    The dictionary is a very useful tool for use with Hot Potatoes. I cannot, however, scroll the pop-up window in Firefox or resize and scroll in IE. Only Chrome will do both. Is this something I can fix myself by changing some settings?
  • Picture of Katja Krüger
    Wed, May 28, 2014, 3:37 PM
    Hi,
    I cannot select a dictonary ...
    I installed version Release 1.2.0 (Build: 2014040200) of oohoo - Pop up Dictionary - Block and Release 1.2.0 (Build: 2014040200) of oohoo - Popup Dictionary - Filter
    My installation is Moodle 2.6.1+
    Installation and Configuration went fine, I added a block to a course BUT then:
    Selected dictionary:
    No dictionary selected
    I click on 'Add a dictonary' -> blank page with error message, apache error log: Permission denied: access to /blocks/dictionary/add.php failed because search permissions are missing on a component of the path

    No permissions? I'm admin. I enroled myself into the course as teacher and found the permissions block/dictionary:addinstance and block/dictionary:myaddinstance and set it to true.

    The error is still there

    in the documentation it says that there should apear a link 'change dictonary' but I don't have this link ....
  • Picture of Katja Krüger
    Wed, May 28, 2014, 8:24 PM
    Found the reason! I forgot to check the permission settings for the folders, they were set to 700 ...
    Wie blöd!
  • Picture of neil Jewell
    Tue, Jul 8, 2014, 9:07 PM
    Cannot change dictionaries without purging all cache in the admin utility
Please login to post comments