Select Moodle version:

Blocks: CSS theme tool

block_css_theme_tool
A block to aid theme designers in customising the current theme by providing an in page CSS editor GUI. Using this block the user can select to add a rule, click on the part of the page they want to style and then use the friendly GUI to add styles to the item that was clicked on.
Maintained by: Sam@moodle Sam Hemelryk
for Moodle
2.2
The CSS theme tool is a block that is designed to make CSS creation and editing for Moodle both easy and accessible. It aims to provide a point and click interface with WYSIWYG controls for adding CSS rules and provides a user friendly interface for creating CSS that is suitable for everything from creating simple modifications to creating entire themes. As well as giving the user an easy means to create CSS it also allows the admin or a Moodle site to make immediate modifications to the installations CSS that will be visible by everyone using the site (not just those who can create CSS) and does this all without the need for editing any files within Moodle or even having to create or modify themes.

Features

  • A point and click CSS editor with buttons and manual CSS style entry.
  • Intelligent in page selector to make sure you are styling what you want.
  • Persistence over pages so you can create styles, save them, and browse to other pages to check the effects.
  • Ability to save and download the CSS you create.
  • Autosave feature so that you don't have to worry about losing your work (it saves as you go).

Requirements

  • Moodle 2+
  • A browser that supports the latest JS and CSS standards (Not tested in IE)
  • JavaScript enabled (this is a largely powered by JS)

Screenshots

screenshot
screenshot
screenshot
screenshot

Contributors

Sam@moodle
Sam Hemelryk (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Dave Emsley
    Tue, Mar 6, 2012, 3:06 AM
    I've tried to install this block on a Moodle 2.2.1+ build 20120202 but the notifications page tells me Moodle 2012020200 is required.

    Slightly confused about this, any suggestions, thoughts?

    Cheers

    Dave
  • kn
    Thu, Mar 22, 2012, 7:10 PM
    You must change the parameter: $plugin->requires = 2012020200.00; to a proper version: $plugin->requires = 2011120500; in file version.php of the plugin.
  • Bob Singletary
    Sat, Mar 31, 2012, 4:19 AM
    This looks like a nice tool. However, it would be desirable to not be required to change the $plugin param every time an update to Moodle is performed, or is that not an issue. Can we just ignore the notification without modifying $plugin?
  • Bob Singletary
    Sat, Mar 31, 2012, 4:22 AM
    OK, answered my own question as to whether notification can be ignored. Will not let the plugin installation proceed. Still back to my orig concern. Is a future release of this going to address the issue or will we always need to modify the $plugin->requires param?
  • Sam@moodle
    Tue, May 22, 2012, 11:43 AM
    Hello, I have fixed up the required version and have uploaded a new version now.
  • Picture of Marcelo CS
    Sat, Dec 28, 2013, 12:54 AM
    Hi ... This plugin works on version 2.6 of moodle? tnks
Please login to post comments