Select Moodle version:

Blocks: AJAX Calendar With Clock

block_calendar_month
AJAX Calendar With Clock - calendar_month (standard moodle block) replacement/extension
Maintained by: Picture of Vencislav Dzhambazov Vencislav Dzhambazov
for Moodle
2.1, 2.2

Screenshots

screenshot

Contributors

Picture of Vencislav Dzhambazov
Vencislav Dzhambazov (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Vencislav Dzhambazov
    Thu, Nov 24, 2011, 4:17 PM
    Hi Ian,

    I test plugin again, in Moodle 2.1.2, and found no problems in Notification

    You must REPLACE the original calendar_mont directory (backup in your local PC for example). If you rename original directory and add new one - this can certainly lead to that error.
  • Picture of Ian Williams
    Tue, Nov 29, 2011, 7:36 PM
    Thank you for the advice. This time I moved the original folder to a safe location on another server and replaced it with the download. All worked correctly and no requirement to run "notifications".
  • Picture of Kyle Smith
    Thu, Feb 2, 2012, 4:15 PM
    Tried installing on version 2.2 - and got error message as installed version is newer and cannot downgrade...
  • Picture of Brad Kutmas
    Fri, Feb 3, 2012, 10:48 PM
    Crashed moodle 2.2 site - white screen.
  • Picture of Brad Kutmas
    Fri, Feb 3, 2012, 10:49 PM
    I should've read the moodle version compatibility, my fault
  • Picture of rafa botello
    Wed, Feb 8, 2012, 11:37 PM
    don't work on moodle 2.2.1, error... white screen, it' should be fixed
  • Picture of sabrina nina
    Tue, Mar 6, 2012, 5:59 PM
    bonjour
    j'ai essayé le bloc mais il maffiche
    Le plugin « block/calendar » est défectueux ou incomptible. Impossible de continuer.

    Plus d'informations sur cette erreur
    Debug info: Missing main block class file.
    Stack trace:

    * line 620 of /lib/upgradelib.php: plugin_defective_exception thrown
    * line 267 of /lib/upgradelib.php: call to upgrade_plugins_blocks()
    * line 1425 of /lib/upgradelib.php: call to upgrade_plugins()
    * line 311 of /admin/index.php: call to upgrade_noncore()

  • Picture of sabrina nina
    Tue, Mar 6, 2012, 6:03 PM
    ma version est 2.0.3
  • Picture of Geoffrey Robinson
    Sat, Mar 17, 2012, 1:07 AM
    Hi

    Got this debug message when installing on 2.2..

    Fatal error: Call to undefined function calendar_session_vars() in /home/user/public_html/moodle/blocks/calendar_month/block_calendar_month_20.php on line 23

    So pity can't use it..

    Geoff
  • Picture of Mr. Marc
    Sat, Apr 14, 2012, 12:39 AM
    I got the same error in moodle 2.2 as above would love to use it also
    Got this debug message when installing on 2.2..

    Fatal error: Call to undefined function calendar_session_vars() in /home/user/public_html/moodle/blocks/calendar_month/block_calendar_month_20.php on line 23
  • Picture of christian iraola
    Sat, May 5, 2012, 11:56 AM
    White Screen for 2.2. Any update yet?
  • Picture of Alex DePena
    Wed, Jun 20, 2012, 6:33 AM
    To fix the error: Fatal error: Call to undefined function calendar_session_vars() in /home/user/public_html/moodle/blocks/calendar_month/block_calendar_month_20.php on line 23

    in the file block_calendar_month.php on line 3 change the 2.1 to 2.2 for Moodle 2.2
  • Picture of Ian Williams
    Tue, Jul 3, 2012, 8:55 PM
    I updated my moodle installation to version 2.3 today and after reporting that the site was unavailable due to it being updated for over an hour and a half, the update failed due to the fact that it could not update block/calendar_month. I replaced the block/calendar_month with the file which was downloaded in the moodle 2.3 zipped file, re-ran the update and it completed without any further problems. I have not had a chance to try the ajax calendar with clock version of calendar_month since completing the upgrade.
  • Picture of Vencislav Dzhambazov
    Fri, Jul 6, 2012, 10:35 PM
    New version available.
    Work fine with Moodle 2.1 and Moodle 2.2 (not tested on Moodle 2.3).
    Support for Moodle 2.0 dropped.
  • Picture of Michael Zehr
    Tue, Jun 4, 2013, 9:51 PM
    I added this to my 2.4 site as I was using it on a prior 2.2 site. It appears to work, although when I go to admin->notifications it complains about an older version, and then said it couldn't downgrade the version. Is there anything I should be concerned about on a 2.4 system?
1 2
Please login to post comments