Your Moodle version

Blocks: Azure Active Directory

block_azuread
Maintained by Picture of Girish Bablani Girish Bablani
This plug in allow authentication against Azure Active Directory or Office 365. Has to be used in conjunction with auth_azuread plugin.
453
17
1
Moodle 2.0, 2.1, 2.2, 2.3, 2.4, 2.5

Sets

This plugin is part of set Azure Active Directory.

Screenshots

Screenshot #0

Contributors

Picture of Girish Bablani
Girish Bablani (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • MD shot of me from his iphone4
    Thu, May 30, 2013, 5:14 PM
    Thanks Girish, this seems to have no problems installing on 2.5 here.

    Please consider adding URLs (bug tracker, code repository, documentation) as well as renaming/copying README file to .txt extension.
  • MD shot of me from his iphone4
    Tue, Jun 4, 2013, 11:25 AM
    The documentation is readable only via downloading, i'd recommend adding that as the description here. You can edit this plugin's description at block "Administration" > "Azure Active Directory" > "Edit this plugin" at the 'description' editor.
  • MD shot of me from his iphone4
    Thu, Mar 27, 2014, 10:01 PM
    Hi I downloaded and uploaded to my site and got during install :
    Warning: require_once(D:\home\site\wwwroot/auth/azuread/graph.php): failed to open stream: No such file or directory in D:\home\site\wwwroot\blocks\azuread\block_azuread.php on line 28 Fatal error: require_once(): Failed opening required 'D:\home\site\wwwroot/auth/azuread/graph.php' (include_path='D:\home\site\wwwroot/lib/zend;D:\home\site\wwwroot/lib/pear;.;C:\php\pear') in D:\home\site\wwwroot\blocks\azuread\block_azuread.php on line 28

    simple resolution is to add $plugin->dependencies auth_azread to the version.php here.
Please login to post comments