Accessibility

Blocks ::: block_accessibility
Maintained by Brickfield LogoBrickfield Education Labs
Provides options for changing text size and colour scheme. Settings can be saved to persist between sessions. Also integrates ATbar from Southampton University ECS.
Latest release:
2813 sites
843 downloads
75 fans
Moodle 2.2, 2.3, 2.4, 2.5, 2.6, 2.7, 2.8, 2.9

The block allows users to customise Moodle to their visual needs.  It supports changing of text sizes and colour schemes.  Customisations save to the user's session, allowing them to persist between pages, and can also be saved to the database allowing them to apply permanently.

The block also integrates ATBar from Southampton University ECS. This provides extra tools and customisation options, including dictionary lookup and Text-to-speech.  Visual customisations performed with ATBar don't currently persist, and can be used as well as or instead of the block's own customisations.

Please dont report bugs here

If you experience an error with the block, or would like to request a feature, please use the "Bug Tracker" link below.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4
Screenshot #5
Screenshot #6

Contributors

Brickfield Logo
Brickfield Education Labs (Lead maintainer)
Mark Johnson: Original maintainer
Hittesh Ahuja: Previous maintainer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Sat, Apr 13, 2019, 4:55 AM
    Hi. Is there any date for this block to be updated contemplating version 3.6 of Moodle?
  • Sun, Apr 21, 2019, 12:24 PM
    Hi. Firstly, this is a wonderful plugin. Is there a workaround to add French to the text to speech functionality?
  • Thu, Feb 27, 2020, 11:18 PM
    Hi Hittesh
    This is a great plugin, and still works on 3.6. We are really keen to see it continue to be developed. Can I have a conversation about how we can help see an update to this.
    I have sent a contact request.
    Ken
  • Fri, Feb 28, 2020, 5:11 AM
    In my opinion this plugin might or might not be useful anymore. Could be worthwhile to verify directly with the users whether such tools are even useful or used nowadays?

    It has been long years since the plugin was initially released and surely back then there was a need and common practice to have such tools improving the accessibility on the website. But since then the whole Web has changed, the websites, browsers, browsing devices, assistive technology and even the accessibility guidelines.

    Here is a quote from well accepted accessibility resource WebAIM describing it as a bad practice: "All browsers allow the sizing or scaling of the page content - why duplicate this browser functionality?" > https://webaim.org/articles/gonewild#options
  • Al
    Fri, May 15, 2020, 4:54 AM
    This plugin is really important as it helps students who are visually impaired to see moodle lessons. It has not been updated for some time. Can it be updated to allow more colour overlays to be set as you can only create 3 and we need 5 colours ways? During lockdown this is very important, I wonder if someone can update this plugin to allow up to 5 or 6 colours to pick from. The size is brilliant, I wonder if there could be a button to change the font as well, as some styles are seen as being easier to read than others. Finally, some web browsers read out the content of the page. I wonder if a button to read out the page would be possible? Thank you so much.
  • Al
    Fri, May 15, 2020, 5:07 AM
    I know you have a reader but moodle appears on our site in a I-frame so the when they click the button the reading functions do not appear.
  • Al
    Sat, Jun 6, 2020, 9:38 PM
    This plugin has been tested and works perfectly on Moodle 3.8. Without it, students with special needs would be unable to gain access to work. I cannot find another plugin similar in the moodle directory. This plugin definitely needs updating.
  • Mon, Jul 6, 2020, 7:59 PM
    What do you mean by "it's recommended to add its instance onto the Moodle homepage (/index.php)"?
    What do I have to do in index.php?
    If I have to change the file, when I update Moodle, the changes will be lost.
  • Al
    Tue, Jul 20, 2021, 4:30 AM
    Hi

    I have just installed the latest version and there is an error.
    When you click A- or A+ you get an error message.
    If says:

    Error changing size: undefined undefined

    Then the circular spinner just spins.

    Also, the block has spaces for 3 different overlays, is there any chance you can increase this, as we work with a lot of schools and to be honest we need about 6 different overlays to cover all schools.

    If you need a screenshot of the error messages, please let me know. I love this block. Thank you.
  • Me !
    Wed, Jul 21, 2021, 4:18 PM
    I've just upgraded to the new 1.39.01 (Build - 2021071301) (2021052400) release and have discovered a show-stopper bug which forced me to revert back to the earlier version. If the block is included on the site home page and the user is taken to that page after login, something triggers a redirect which causes the user to be sent to https://mysite.org/blocks/accessibility/userstyles.php?instance_id=7438 with the CSS code being shown to the user. Manually truncating the URL in the browser allows access to the home page, so this seems to be a faulty interaction with the login process. Reverting the plugin back to the previous release fixes the problem, so this bug seems to have been introduced with the 2021052400 release. I'm using Moodle 3.9.8.
  • Mon, Aug 2, 2021, 9:45 PM
    I'm having the same redirect issue in Moodle 3.11.1. This is big issue as I too have had to revert to the old version of the Block which is overlapped by the Nav drawer in the Boost theme. I hope you can fix this ASAP so we can continue to use this valuable tool.
  • Fra Parlant
    Sat, Sep 11, 2021, 6:15 PM
    Hi
    Which css variable should be used in custom labels for the font to be affected:
    neither color:var(--light) nor color:var(--white) nor color:white are transformed by AtBar into dark or black font when changing layout, although the background does change into yellow or blue.
    Thanks
  • Brickfield Logo
    Thu, Sep 23, 2021, 10:18 PM
    Hi Al, thanks for your feedback, hopefully the error message has been resolved by our recent version. On the subject of having more overlay options, I’ve added this as an issue on our github issue page here, to see what support it gets. https://github.com/brickfield/moodle-block_accessibility/issues/133
  • Brickfield Logo
    Thu, Sep 23, 2021, 10:22 PM
    Hi Francois, thanks for your feedback, on the issue of the CSS not being transformed, I’d recommend posting to the English general or themes plugins forum, https://moodle.org/mod/forum/view.php?id=44, to get CSS advice on those particular CSS variables and how they are dealt with.
  • Sat, Nov 6, 2021, 1:10 AM
    Hello! I'm trying to add a modification to the plugin that allows you to apply the visual changes also to the content of the "Interactive Book" (H5P module). I tried to replicate in "userstyle.php" to apply from the class ,h5p-iframe-wrapper". But I didn't succeed. Someone there who tried to customize the plugin, managed to make similar changes? Could you guide me? I appreciate it right now.
1 2 3 4 5 6 7
Please login to post comments