Your Moodle version

Authentication: Azure Active Directory

auth_azuread
Maintained by Picture of Girish Bablani Girish Bablani
Allows authentication against Azure Active Directory or Office 365. Useful for EDU customers of Office 365. Must be used with the block_azuread plugin
42
24

Sets

This plugin is part of set Azure Active Directory.

Screenshots

Screenshot #0

Contributors

Picture of Girish Bablani
Girish Bablani (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Girish Bablani
    Thu, May 30, 2013, 3:21 PM
    My bad - I assumed marking for 2.0 implied upwards compat. Fixed that and added URL for documentation. Also added bug tracking URL
  • MD shot of me from his iphone4
    Tue, Jun 4, 2013, 10:52 AM
    Thanks Girish,
    i've copied your urls from the release notes and added them to the 'useful links' section. If you have any urls, please add them to this section. The documentation is readable only via downloading, i'd recommend adding that as the description here when you edit the plugin entry.
  • Picture of Girish Bablani
    Fri, Aug 9, 2013, 3:47 PM
    I just updated a new version that checks for php_http being installed on the system. It also updates the way it gets federation metadata from Azure Active Directory
  • Picture of Alex Mela
    Fri, Jul 4, 2014, 5:33 AM
    Hello Girish, how are you? Thanks for your contribution.
    I was wondering if this authentication only works if you have your moodle hosted in Azure, or if it's working for any moodle installation.
    Thanks!
    Regards,
    Alex
  • Picture of Girish Bablani
    Fri, Jul 4, 2014, 6:01 AM
    This will work for any supported Moodle installation
    Thx
    Girish
  • Picture of Gopika Suma
    Thu, Jul 10, 2014, 7:38 PM
    Hi Girish,

    I am new to moodle and also windows azure.We need a feature for single sign on with office 365. When I searched I got this plugin. I got your ModuleSSO document. But I am getting stuck. The problem is in windows azure interface I am not able to get the integrated apps menu or the enable single signon or when we create the app the option of single sign on, read directory data.

    Any help would be great.

    Thanks and Regards
    Gopika
  • Picture of Anthony Connor
    Tue, May 26, 2015, 4:28 PM
    Hi Girish,

    I am interested in using your plugin on our site. Before I install it I was wondering if login against Azure AD is only available within the AzureAD block? We force users to login before they can see the frontpage so can this authentication method be used on the login page?

    Regards,
    Anthony
  • Picture of Girish Bablani
    Tue, May 26, 2015, 11:12 PM
    Anthony thanks for the mail. The code is written such that without modifications the sign-in into AzureAD is only initiated from the block code. However the AzureAD plugin does not require the block code. What you could do is grab the code that generates the loginURL as well as the settings from the block code and integrate that into your frontpage to have an integrated login experience

    Thx
    Girish
  • Picture of Dave Arnold
    Tue, Jun 23, 2015, 1:48 AM
    I got this installed on moodle 2.5.3+ and I can login through the link on the block; however, it does not sync any user data. The usernames that get created look like the user's object id. There's no firstname, lastname, or even email address. Is it suppose to sync these things and I'm just missing something? I could not find mapping settings like there are for the ldap plugin.
  • Picture of Dave Arnold
    Tue, Jun 23, 2015, 5:31 AM
    I also want to note that pecl_http version 1.7.6 is required. The latest version available won't work because they have dropped functions, which causes fatal errors. So even with the php_http check it will fail at http_get unless you have the older version. I would recommend the plugin be updated to use curl instead.
  • Picture of Dave Arnold
    Wed, Jun 24, 2015, 1:39 AM
    If anyone else has trouble with getting user data to sync, the root of my problem was permissions in AD Azure. You must provide the application with access to "Read Directory Data" I set it on both Application Permissions and Delegated Permissions before it started working.
  • Picture of sandy vallee
    Fri, Jun 10, 2016, 1:21 AM
    Girish Bablani how do you copy the block code? Do you need access to the PHP file? I have this plugin installed on 2.6 and it shows up on my homepage as a block but it says you are logged in with a non ausure account click here (sends you to the login page, where the azure block is not available.) Your post says you can copy the code, but I'm not sure where to get it from, what to copy. Also I was trying to figure out how to not use a login page and just authenticate on the front page where the block is, but I can't find where to disable the login page?
  • Picture of sandy vallee
    Thu, Jul 14, 2016, 10:58 PM
    Hi again. Ok so I'm really close I got the login URL and it seems to authentic and then it sends you to the Moodle profile page and you get stuck there. You can't fill out a profile and move on to see courses. Also I don't want it to get the user to create and account upon login. We want Moodle to get the data from Azure and create accounts in Moodle before users login for the first time. Is that possible with this plugin?

    Also I'm doing this on a testing server where we don't have SSL cert applied. It does throw an HTTPS error in between when transferring you over to Moodle after authenticating. Just wondering if this could be hindering the communication process between systems?
  • Picture of sandy vallee
    Thu, Aug 11, 2016, 1:43 AM
    Hi so as for my above comment it was a firewall issue that was stopping the first name last name to come through.
  • Picture of sandy vallee
    Thu, Aug 11, 2016, 1:48 AM
    Now only some accounts are coming through. (I'm on Moodle 2.6) Some staff accounts, some contacts in Azure and no student accounts unless they had a personal microsft account before hand and have an email address of firstname.lastname@oldscollegeca.onmicrosoft.com. but the student accounts like firstname.lastname@oldscollege.ca won't pull in for some reason. Anyone else have these problems of some accounts coming in and other not?
1 2
Please login to post comments