Atto: More background colours

atto_morebackcolors
Maintained by Picture of Nicolas Dunand Nicolas Dunand
This is intended to be a replacement for the core backcolor Atto plugin, allowing the Moodle administrator to freely define a set of colours that can be used by users.
679 sites
401 downloads
17 fans

This is intended to be a replacement for the core backcolor Atto plugin, allowing the Moodle administrator to freely define a set of colours that can be used by users.

It is based on the atto_morefontcolors plugin by Nicolas Dunand.

* Please note that this plugin is in the process of being transferred to Nicolas Dunand and the zip file download is out of date*

Screenshots

Screenshot #0

Contributors

Picture of Nicolas Dunand
Nicolas Dunand (Lead maintainer)
Picture of Michael Aherne
Michael Aherne: Original author
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of David Mudrák
    Mon, 10 Aug 2015, 11:07 PM

    Thanks Michael for sharing this plugin with the community. It seems that most of the coding style errors reported above are caused by the fact that you use tabs (instead of fours spaces) to indent the code. Please check the Moodle coding style guide for more details.

    I found no approval blockers during the usability testing and the code review, well done on that. You are cleared to land now, welcome to the Plugins directory!

  • Picture of Michael Aherne
    Mon, 10 Aug 2015, 11:51 PM
    Thanks, David! I thought I'd got rid of the whitespace errors - they were caused by a wonky IDE configuration - but I seem to have missed a couple of files. I'll get a fixed version uploaded tomorrow.
  • Picture of AL Rachels
    Tue, 5 Jan 2016, 2:15 AM
    Just noticed a slight error in the included READ.me file. It says to add 'morebackcolours' to the Atto toolbar settings, which will not work. Remove the 'u' in colors so that you have 'morebackcolors' and then it will work okay. Thanks for the plugin!
  • Picture of Michael Aherne
    Tue, 5 Jan 2016, 10:58 PM
    Thanks for pointing that out! I've fixed it in the master branch of the code and it'll be in the next release of the plugin.
Please login to post comments