Your Moodle version

Other: Kaltura Video Package

Maintained by Picture of Alon Portnoy Alon Portnoy, Picture of Mike Churchward Mike Churchward, Picture of Akinsaya Delamarre Akinsaya Delamarre, Picture of gonen r gonen r
Kaltura plug-ins for Moodle 2.1 - 2.x
5k
2

Kaltura's Video Package for Moodle 2.x makes it easy to add the robust capabilities of Kaltura's open
source online video platform to any Moodle site. The package was developed specifically for Moodle
and integrates with other features and modules, such as resources and activities, so that users can
upload and embed media easily.

The package adds the following features for all users:

* My Media: users’ personal media gallery, for uploading, viewing, managing, and sharing media

* Create screen recordings and use them in the Kaltura activities

* Integration as an external repository with the file picker accessible from the text editor: embed your media or media you have access to, anywhere you can author text

In addition, Teachers and Admins have the following features available:

* Video Resource activity: Easily add video content to your course as a specialized resource

* Video Presentation activity: Create a synchronized view of a Document and a Video

* Video Assignment activity: Allows students to submit videos as an assignment submission

* View engagement reports for videos used on your course

 

Version information:

Please take note of the version of Moodle you have and the version of the plug-in you are installing. The Download page states which version of Moodle the version of the plug-in is for.

Version information example: Kaltura release 3.0.96 (RL: 2.5.1.1)

3.0.96 is the version of the plug-in that Kaltura has release. It does not correspond to any Moodle version number and it should be referenced when contacting Kaltura support.

RL: 2.5.1.1 is our internal version. The first two points (2.5) correspond to the version of Moodle that it has been tested with (Moodle 2.5.x).

 

Contributors

Picture of Alon Portnoy
Alon Portnoy (Lead maintainer)
Picture of Akinsaya Delamarre
Akinsaya Delamarre
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Matthew Davidson
    Thu, Oct 9, 2014, 4:51 AM
    I'm pretty sure that in the filter, ~lines 165 to ~line 200, the $property[2] and $property[3] are used in reverse which causes width to be height and height to be width
  • Picture of Matthew Davidson
    Thu, Oct 9, 2014, 4:51 AM
    edit: $properties[2] and $properties[3]
  • Picture of Joseph Foss
    Sat, Nov 1, 2014, 6:50 AM
    @Johaness & @Mesut. Does the error you have encountered mean that Moodle 2.7 and kaltura CE 4 are no longer able to be deployed absolutely "on premise." as a free solution for a small small team?

    My group's internal moodle project has come to a halt if having a Kaltura KAF license is now required!
  • Picture of Daemon Hunt
    Tue, Nov 11, 2014, 6:31 AM
    I would like everyone to know that I finally fixed the bug of webcam recording not working properly in Moodle, with the latest version of Kaltura CE.

    The problem appeared to not be Kaltura at all, but the version of Red5 that comes pre-installed with the latest Kaltura CE packages.

    With this default install of Red5, multiple error messages come up within the Moodle-Kaltura plugin when selecting "webcam" as a source. Although webcam recording still appears to function after dismissing these 3 or 4 error messages, there was no way I could communicate this properly to our teachers and students and ended up commenting the function out of the Kaltura widget altogether until it was fixed. This has been a point of annoyance to me for going on 2 years as it is a function that our staff and students desired. Digging deeper I found that this was some sort of issue with modern versions of Flash containing a newer piece of code that is not properly accounted for in 'older' versions of red5.

    I had posted questions about this many times on this forum and gotten nowhere, so I am hoping anyone else with this issue will find my post.

    The fix? Simply install the latest RC version of Red5 into your Kaltura server, after removing the default one that comes with Kaltura CE:

    Red5 1.0.3 Release (5 August 2014) worked brilliantly for me and the errors are gone! I seriously had a few wines to celebrate my breakthrough. Now my students and teachers can use the webcam recording function once more without the confusing error messages scaring them off.

    https://github.com/Red5/red5-server
  • Picture of Jess Portnoy
    Wed, Nov 12, 2014, 1:16 AM
    @Daemon,
    Thank you very much for your report about Red5. I am now packaging version 1.0.3 and will test. Once done, it will be pushed to our stable version.
  • Picture of Daemon Hunt
    Wed, Nov 12, 2014, 4:23 PM
    Well that's just great Jess. I'm glad I've hopefully managed to help a lot of users out there.
    Now all we need to do is get the presentation and screen capture pieces working. Is there a roadmap to integrate KAF with CE?
  • Picture of Akinsaya Delamarre
    Thu, Nov 13, 2014, 12:29 AM
    Daemon great news! Glad to hear you've got it to work.
  • Picture of Jess Portnoy
    Fri, Nov 14, 2014, 2:56 AM
    Hi Daemon,

    Red5 1.0.3 is pushed to the official repo now.
    Did some tests, looks better indeed.

    As far as KAF and CE - I'm afraid this is not on the map.

    Thank and looking forward to more collaboration with you.
  • Picture of Andrew C
    Sun, Nov 16, 2014, 10:26 PM
    Hi Jess,

    By looking at the compatibility matrix

    http://knowledge.kaltura.com/kaltura-prem-and-applications-compatibility-matrix

    Will there be a CE edition of Iris? and will this work with version 4 Moodle plugin without the need for the paid KAF? (as in working without the On Prem Video Presentation Resource required document conversion). I'm trying to work out whether the future of Moodle integration is now on a paid for only basis only?

    Thanks,

    Andrew
  • Michael Mulvihill
    Wed, Nov 19, 2014, 12:58 AM
    Hello,
    I am a bit confused.

    I'm looking into replacing an in-house video solution with Kaltura CE.
    However, it would appear from the posts here that the Moodle integrations are not supported in Kaltura CE.

    Hmm does this mean that the description of this these plugins are inaccurate?
    'Kaltura's Video Package for Moodle 2.x makes it easy to add the robust capabilities of Kaltura's open
    source online video platform to any Moodle site.’

    Should it rather read?

    'Kaltura's Video Package for Moodle 2.x makes it easy to add the robust capabilities of Kaltura's Paid for using Kaltura's OnPrem solution video platform to any Moodle site.’

    I would be grateful for clarification of this, as it is a requirement of any solution that we put in place that
    - It tightly integrates with our VLE (Moodle 2.7)
    - It is easily maintainable

    Thanks in advance
  • Picture of Andrew C
    Mon, Dec 8, 2014, 5:17 PM
    Hi Michael,

    I can confirm that the Moodle integrations work well (none-paid) in versions like CE5 and the previous version of the Moodle plugin. I have it up and running with RED5 without any problem on a 2.6. I'm not sure whether this is the case for the future since I believe that the new plugin uses the paid for KAF.

    The best question to ask would be whether there are any plugin versions for Moodle that continue to support the non KAF CE? or whether this plugin will only be supporting the paid for solution?

    Thanks,

    Andrew
  • Picture of Ahmed Ibrahim
    Sun, Jan 11, 2015, 10:29 PM
    Hi
    Does this plugin works with moodle 2.8?
  • Picture of gonen r
    Sun, Jan 11, 2015, 10:53 PM
    It has not yet been verified to work with 2.8, but this is on our roadmap in the short-term, so stay tuned
  • My picture
    Thu, Feb 12, 2015, 9:31 PM
    Hello,
    I wonder if you could please help me with the following question:

    The University of Dundee has a Kaltura license. I am the administrator of a Moodle platform within the University and I am trying to connect Moodle with Kaltura.

    The central team has provided me with a
    partner id and the admin secret number. However, they don't know what the kaf_uri value is.

    Do I need to open an specific TCP/IP port for Kaltura?

    I have access to the KMC in Kaltura and I have created a root category called Moodle, as stated in the documentation.

    Please let me know any other additional steps.

    Thank you very much.
    Mari Cruz

  • Picture of Nfoudikue Ibrahim
    Fri, Feb 13, 2015, 3:52 AM
    Hello,
    I'm trying to install this plugin (2.8 or 2.7 V) to moodle 2.8.3. This is the error I have received "Invalid structure of the ZIP package". Can someone help me?
1 2 3 4 5 6 7 8 9 10 11
Please login to post comments