Other: WIRIS quizzes for Math & science

Maintained by Picture of WIRIS team SUPPORT WIRIS team SUPPORT
Extend the Question Bank with new question types for math and science. New Open answer questions automatically evaluated. Random parameters or graphics in your questions. Precise control on mathematical properties of the student answer to provide the best feedback.
598 downloads
16 fans
Moodle 2.2, 2.3, 2.4, 2.5, 2.6, 2.7, 2.8, 2.9, 3.0, 3.1

WIRIS quizzes is a set of question types for Moodle that enhances the questionnaire systems with functionalities related to mathematics and science.

WIRIS quizzes improves every existing question typeTrue/FalseMultiple choiceMatchingShort answerEssayEmbedded answers (Cloze)... To sum up, every question type you may come across. You can create sophisticated and random math questions with very little effort.

All mathematical items are generated in a single calculation section and they can be referenced from anywhere in the content, question wording, answer, feedback for the student, etc.

On the side of the student, he will be able to introduce his answers by using a WYSIWYG formula editor and, if the teacher so specifies, they will have access to a WIRIS cas session to make some calculations. The answer syntax check will prevent the students from unnecessary errors and misspellings.

WIRIS tools can be used for free up to a certain level of use per natural year. Please read license conditions and prices at WIRIS store.

For installation, follow the instructions described at wiris.com!

Sets

This plugin is part of set WIRIS math & science.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4
Screenshot #5
Screenshot #6
Screenshot #7
Screenshot #8

Contributors

Picture of WIRIS team SUPPORT
WIRIS team SUPPORT (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of WIRIS team SUPPORT
    Tue, 4 Nov 2014, 12:53 AM
    Hi Mari Cruz

    First of all, thanks for your feedback.

    There was a bug in 3.30 with the cron process. The bug is already fixed in our last version. Installing it solves the problem.

    We apologize for any inconvenience caused.

    Thanks,





  • My picture
    Fri, 7 Nov 2014, 8:57 PM
    Hola.
    he instalado 3.3.31 y el cron vuelve a funcionar, gracias
  • Picture of Helson C
    Mon, 6 Apr 2015, 10:18 PM
    Is a trial version?
  • Picture of Ramon Eixarch
    Fri, 10 Apr 2015, 9:19 PM
    Dear Helson,

    WIRIS tools are commercial tools. We offer them for FREE under certain conditons.
    Please check them at www.wiris.com/store/
  • Picture of Jordi Pujol-Ahulló
    Mon, 20 Apr 2015, 11:34 PM
    Hi all,

    I've just installed the editor plugin, the filter and the quizzes (last version from today zips from official website -not from moodle.org).

    I've found a couple of issues:

    1. There is a test from quizzes that does not pass (those last two related to "Extra tests", "mod_security1" and "mod_security2". I think it is only related to the mod_security module for the web server. Is it actually insecure to put all them in production if these 2 tests fail?

    2. There is a wrong link. From admin/settings.php?section=qtypesettingwq settings page, the link up to "WIRIS filter settings" is admin/settings.php?section=filtersettingwiris, but should be admin/settings.php?section=filtersettingfilterwiris

    Thanks in advance!

    I read something about cron. Which cron do we need to place running? I didn't found documentation about it.

    Thanks in advance!!!

    Jordi
  • Picture of WIRIS team SUPPORT
    Tue, 21 Apr 2015, 6:15 PM
    @Jordi

    Regarding to your questions:

    1.- There is no problem to put on production WIRIS quizzes if "mod_security" test fails. These tests checks that "<>" and "><" expressions can be sent by a get request. Under certain circumstances, WIRIS quizzes could fail if these expression can't be sent but, in any case, is a security issue. Seems that test info is a bit confusing so we will change that on our next release.

    2.- Checking the filter settings link we notice that fails on Moodle 2.4. In the next release these issue will be fixed.

    3.- WIRIS quizzes, as Moodle itself, needs a cron process on your server. If you have a cron process in it, you don't have to do anything specific. You can find more info about cron process on Moodle here: https://docs.moodle.org/28/en/Cron

    Thanks for your feedback.
  • Matt Bury
    Sat, 23 May 2015, 2:14 AM
    Hi,
    Wiris question types require use Java browser applets and require JRE to be installed on users' computers/devices. This is either impractical or impossible in many cases. So now I need to uninstall them from Moodle 2.9. I've found old instructions for Moodle 1.9 on how to do this but not for Moodle 2.x. Additionally, I've been through all the Site administration settings trying to find a way to make the question types uninstallable. I've managed to uninstall a couple of them but the rest remain and do not have working uninstall links.

    Obviously, if I just delete the WIRIS directories and their contents from /moodle/question/type/ Moodle will continually return "Missing from disc!" errors in administration pages, which is unacceptable.

    Can you please provide comprehensive uninstall instructions for Moodle 2.9 for ALL the WIRIS plugins, including which Moodle core files have been altered and which database tables have been created? Thank you in advance.
  • Picture of WIRIS team SUPPORT
    Mon, 25 May 2015, 6:52 PM
    @Matt

    WIRIS quizzes question types can be uninstalled just like any other Moodle question type: deleting associated questions first and uninstall question types later.

    Detailed uninstall instructions can be found here: http://www.
    wiris.com/en/quizzes/docs/moodle/install/uninstall

    If you are still having problems, please feel free to contact us at support@wiris.com


  • Matt Bury
    Wed, 10 Jun 2015, 2:42 AM
    Hi,

    The link you've provided leads me to a login page. http://www.wiris.com/en/quizzes/docs/moodle/install/uninstall This probably explains why I couldn't find the Moodle 2.x uninstall instructions via web searches (Only the old Moodle 1.9 version). Can you please provide a link to a publicly accessible version of the uninstall instructions?

    All I want to do is get rid of the unwanted WIRIS plugins and database entries, nothing else.
  • Picture of WIRIS team SUPPORT
    Wed, 10 Jun 2015, 10:39 PM
    @Matt

    Sorry for the inconveniences. Uninstall instructions are now public.

    If you are still having problems, please feel free to contact us at support@wiris.com
  • Picture of Riccardo Piatti
    Thu, 23 Jul 2015, 5:51 PM
    Hi everybody,
    I think there is a litte error into the zip file preventing installation ... the "mother folder" into the zip file is "types" but in the moodle tree (...moodle/question/type) is type; I changed "types" in "type" and installatation was succesful. Hope this info is useful.
    Bye,
    Rich
  • Picture of WIRIS team SUPPORT
    Thu, 23 Jul 2015, 8:37 PM
    @Ricardo We changed the name from types to type on purpose inside the zip package to prevent replacing the whole Moodle's type directory accidentally.
    On step 2 at http://www.wiris.com/en/quizzes/docs/moodle/install we indicate that you need to copy the content of the types folder into the folder question/type.
  • Picture of Jarosław Maciejewski
    Mon, 7 Mar 2016, 7:19 PM
    From PHP 7 syntax checker:

    PHP Parse error: syntax error, unexpected '@' in /opt/lampp/htdocs/moodle/question/type/shortanswerwiris/version.src.php on line 28

    Parse error: syntax error, unexpected '@' in /opt/lampp/htdocs/moodle/question/type/shortanswerwiris/version.src.php on line 28
    Errors parsing /opt/lampp/htdocs/moodle/question/type/shortanswerwiris/version.src.php
  • Picture of Kostis Moustakas
    Tue, 8 Mar 2016, 9:30 PM
    When i am trying to install wiris quizzes plugin from moodle org or from wiris.com i am getting the following error.

    File version.php not found


    Can you help me?
    Kind Regards
    Kostis Moustakas
  • Picture of WIRIS team SUPPORT
    Tue, 8 Mar 2016, 9:55 PM
    @Kostis

    We can't reproduce your issue not installing from scratch neither updating the plugin from an older version. Could you contact us at support@wiris.com in order to provide us more details about your issue?

    Thanks,

    Best,

    WIRIS Support team.

    Best regards
1 2 3
Please login to post comments