General plugins (Local): Webservice functions for cohort enrolment

local_ws_enrolcohort
Maintained by This is a picture of me Donald Barrett, Picture of Learning Works Learning Works
A local plugin with webservice functions for managing cohort enrolments.
6 downloads

The webservice functions for cohort enrolment provides the ability to manage cohort enrolment instances using Moodle webservices. This plugin was developed for Te Wānanga O Aotearoa to streamline the enrolment of Tauira (student, learner) into courses.

The following webservice functions are available.

  • add_instance - Add a cohort enrolment instance to a course
  • update_instance - Update an existing cohort enrolment instance
  • delete_instance - Delete an existing cohort enrolment instance
  • get_instances - Gets the cohort enrolment instances for all courses or a single course


The webservice documentation for the above functions can be found at http://yoursite.com/admin/webservice/documentation.php

When the plugin is installed all of the cohort enrolment webservice functions are added to the Built-in services.

An example call to the webservice function for adding a cohort enrolment instance to course would look like this:
http://yoursite.com/webservice/rest/server.php?wstoken=yOurT0k3n&moodlewsrestformat=json&ws_function=local_ws_enrolcohort_add_instance&instance[courseid]=2&instance[cohortid]=4&instance[roleid]=1


This plugin can be installed by following the official Moodle documentation - Installing plugins.
This plugin can be used in accordance with the official Moodle documentation - Using web services.


Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4

Contributors

This is a picture of me
Donald Barrett (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Plugins bot
    Wed, 11 Jul 2018, 10:10 AM
    Approval issue created: CONTRIB-7379
  • Wazza
    Tue, 14 Aug 2018, 4:25 PM
    Hi Donald,
    Thanks for this plugin! It should be core Moodle if you wish to setup a big installation. Will this be working on future Moodle versions? It now only says Moodle 3.3. We seriously need this, but what we don't need is that this will stop working if we upgrade Moodle to f.e. 3.6
Please login to post comments