Themes: Elegance

theme_elegance
Maintained by Picture of Bas Brands Bas Brands
Elegance is a beautiful two column Moodle theme with robust functionality and lots of custom settings.
1399 sites
362 downloads
51 fans

Features

  • Custom "Quick Links" and "Marketing" spots.
  • A Frontpage Carousel.
  • Custom "Front Page Content" and "Footer" content.
  • Custom Colors.
  • Custom log in screen with rotating background images.

Contributors

Notes

  • Please do not use the github version of this theme in a production environment. The current plugin repository version will always be the most stable.
  • Please don't ask for support in the comments section here- there's no easy way for me to discuss with you.  Use the "Discussion" thread under "Useful Links" below.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3

Contributors

Picture of Bas Brands
Bas Brands (Lead maintainer)
Julian Ridden
Julian Ridden: Original author
Picture of Danny Wahl
Danny Wahl: Previous maintainer
Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • Picture of April M
    Fri, 7 Mar 2014, 8:18 PM
    How do I get the "latest posts" module to show up like in the screenshot?
  • Ing. Carlos Correa
    Sat, 8 Mar 2014, 3:58 AM
    How can i install this theme.
  • Julian Ridden
    Sat, 8 Mar 2014, 8:43 AM
    @Carlos just download it and put it in your themes directory in Moodle. Or, click on Install Plugins in your Moodle admin and instal it from there if your server is set up to support that method
  • Julian Ridden
    Sat, 8 Mar 2014, 8:44 AM
    @April What you are seeing there is Moodle's RSS block. I turned on RSS feeds for my forums, put that RSS URL into the block and then dragged that block into the center location on the homepage
  • Picture of eric yullu
    Tue, 11 Mar 2014, 8:26 PM
    After installing the theme, it is disabling the css so i can only see text, how can correct that?
  • Picture of Andrew Downes
    Tue, 11 Mar 2014, 9:06 PM
    I'm getting the same issue as Eric. Failed to load resource: net::ERR_CONNECTION_RESET http://localhost/moodle2_6/theme/styles.php/elegance/1394542689/all

    Interestingly the background image on the login screen still works.

    Is there a problem with the most recent file, or incompatibility with the most recent version of Moodle? I'm using a fresh install to test this.
  • Picture of Andrew Downes
    Wed, 12 Mar 2014, 8:50 PM
    I've also tried with the previous download version - same problem. has anybody got any experience of getting this plugin to work? From the video it looks quite nice!
  • Picture of Brian Peat
    Wed, 12 Mar 2014, 11:07 PM
    I'm looking for a way to shift the side bar to the left on all pages, even if I have to hack some CSS or the theme. Any idea how hard it might be to do that?
  • Picture of Brian Peat
    Wed, 12 Mar 2014, 11:48 PM
    Argh. I also discovered that the text editor isn't scaling well (or adjusting the rows) in this theme. If I size the page down a bit it doesn't resize the browser, and If I click the little "show more icons" button in the new editor, it expands PAST the container and under the right side bar. Can anyone else confirm this?
  • Picture of Emanuele Bucci
    Sat, 15 Mar 2014, 2:51 PM
    In the login Page, when the page is resized, the "Login as a guest" and "Forgot password" buttons may overlap. This also happens on iPad in the portrait mode.
  • Picture of Rodrigo Veiga
    Mon, 17 Mar 2014, 10:58 PM
    Thks for the update. keep doing this awessome job!
  • Picture of arslan ali
    Sun, 23 Mar 2014, 5:05 AM
    Hi, there are some serious issues with this theme. It wont load the CSS when test on locally. And it wont be until and unless we enable the theme designer mode which means it will load CSS all the time - not just creating cache and loading theme with theme cache files.
    So i have not tested on live site but i think it will only be run with theme designer mode enabled and it would lower the optimization of moodle as it every time load the CSS, i mean "EVERY-TIME" instead load it from caches files.
    Kindly fix this issue if any or guide a proper way of using this theme for localhost. Thanks
  • Julian Ridden
    Sun, 23 Mar 2014, 5:44 AM
    @arslan, Sadly these are issues with your server you will need to figure out. Theme works fine and is running on many sites. The latest code is always running on http://2014.imoot.org/
  • Picture of yogesh sharma
    Mon, 24 Mar 2014, 7:06 AM
    Hi,

    Great job on the theme.

    How would you customize the footer moodle logo and the logo on top of the page (The m sign that comes with website name). I just wnat to be able to use my own logo.

    Thanks for all your help.

    Yogesh
  • Julian Ridden
    Mon, 24 Mar 2014, 8:49 AM
    @Yogesh You just need to replace the relevant icon in the theme folder. These are in the /pix folder of the theme.

    The top icon is called favicon.ico

    The footer logo is called moodlelogo.png

    Just overwrite these with your own properly sized and formatted images and purge the cache.

    Julian
Please login to post comments