Adaptable

Themes ::: theme_adaptable
Maintained by Jez H, Manoj Solanki, Gareth J BarnardGareth J Barnard
Adaptable is a highly customisable responsive two column theme designed for use on both large University installations as well as small training companies.
Latest release:
19186 sites
13k downloads
565 fans
Current versions available: 11

Please, DO NOT ASK for technical support on this page. 

Use the Moodle Themes Forum instead.


Adaptable is a highly customisable responsive two column theme with an abundance of features. The concept behind adaptable is to have a common theme developed and tested by a community of users which can be branded and configured according to each organisations needs. The freedom to brand and customise whilst sharing the burden of testing and development.

  • Front page Marketing Blocks. You can display Up to 60 custom blocks with different layout.
  • Layout Builders! You can now define a custom layout to add blocks using drag and drop for:
    • Front Page
    • Footer
    • Dashboard
    • Course Page
  • Fully Customisable:
    • Fonts
    • Colours
    • Block styles (including icons)
    • Buttons (including radius)
  • Choice of two sliders on home page with custom colours
  • News / Announcements Ticker on Home / Dashboard
  • Multiple front page course styles
  • Extensive custom menus (can be targeted to different users based on custom profile field)
  • "My Courses" list can be organised to put older courses in sub menu item
  • Dismissible Bootstrap Alerts
    • Display site-wide notices using different Bootstrap styles
    • Allow users to dismiss alerts once read (persistent between page loads / login)
    • Allow re-use of alerts (display again even if user has dismissed) buy updating a "key" field
  • Additional layout settings for width, slider width, padding of various elements
  • Social icons or Search box in header (admin can choose between the two)
  • Activities and Resources Adaptable icon pack improved 
  • Support for Social Wall Course Format (thanks to Chris Kenniburg for help on this)
  • Support for Grid Course Format (thanks to Gareth J Barnard for help on this)
  • Mobile settings
  • Option to add login form in header on front page
  • Favicon uploader
  • Background image uploader
  • Activities status
  • Additional block regions for Adaptable News Slider and other plugins you may wish to add
  • Tabs on Dashboard and Course Pages for additional block regions
  • Choice of two or three row header

 

In addition many fields (menus, news items, alerts and help links) can be targeted using custom profile fields, thus it is possible to present different users with different navigation items and notices.

It is also possible for individual users to customise where they want top menu navigation to appear (disable, home pages only, site wide) using custom profile fields.

Adaptable has a lot of settings and may seem daunting at first, our advice is to simply install with the default settings and play with it afterwards.

With a little time you should be able to set up an attractive Moodle site with a high degree of individuality without without knowing any CSS.

Credits:

Advice on migrating from BCU to Adaptable can be found here.

Please, DO NOT ASK for technical support on this page. 

Use the Moodle Themes Forum instead.

 

Version information
Moodle version Adaptable version Status
2.8 1.2.1 Last release for M2.8
2.9 1.2.4.2 Last release for M2.9
3.0, 3.1 1.3.4 Last release for M3.0 / 3.1
3.2, 3.3 1.6.2 Last release for M3.2 / 3.3
3.4 1.7.3 Last release for M3.4
3.5 1.8.0.1 Last release for M3.5
3.6 2.2.4 Last release for M3.6
3.7 2.3.2 Last release for M3.7
3.8 3.8.1.2 Last release for M3.8
3.9 3.9.1.2 Current release for M3.9
3.10 3.10.1.2 Current release for M3.10
3.11 TBCIf required by client(s)

Sets

This plugin is part of set Adaptable UI.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4
Screenshot #5
Screenshot #6
Screenshot #7
Screenshot #8
Screenshot #9

Contributors

Jez H (Lead maintainer)
Gareth J Barnard
Gareth J Barnard
Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • Sun, Dec 6, 2020, 1:05 AM
    I updated to theme to 2020070100 version.
    All marketing images where brouken.
    I found than previous file url was
    ///adaptablemarketingimages/
    and after apdating it was changed (on letter "t" added)
    ///adaptablemarkettingimages/
    it is a bug !
  • Gareth J Barnard
    Sun, Dec 6, 2020, 3:39 AM
    Dear Yuriy,

    a) Please, DO NOT ASK for technical support in this page. Use the Moodle Themes Forum instead. As stated above.
    b) Please state the previous version.

    G
  • Sun, Dec 13, 2020, 7:30 AM
    Just installed this theme on my Moodle platform. I really like the ability to customize the theme. I like the course tiles that show the description. One suggestion for improvement: The the expandable icon for the blocks is extremely small and difficult to see. The icon (3 lines) indicates an expandable option when clicking on it, but it is not interactive. I suggest making the entire block header active so that a learner can easily expand/collapse the block.
  • Gareth J Barnard
    Tue, Dec 15, 2020, 8:31 PM
    Dear Brigitte,

    Please, DO NOT ASK for technical support in this page. Use the Moodle Themes Forum instead. As stated above.

    G
  • Tue, Jan 5, 2021, 3:34 AM

    A query: Install the theme and now login with my admin account but it shows the message: "Blocks in this area will only be visible to admin users"
    Una consulta: Instale el tema y ahora ingreso con mi cuenta admin pero muestra el mensaje : "Blocks in this area will only be visible to admin users"
    ¿Que puedo hacer?
  • Al
    Sun, Jan 24, 2021, 6:09 AM
    Is there any chance you make the plugin so that when you update moodle it automatically downloads the plugin as part of the upgrade? This would save so much time as currently when you upgrade it just says, "Additional Missing from disk!". Thank you so much.
  • Gareth J Barnard
    Sun, Jan 24, 2021, 6:16 AM
    Dear Al,

    Not within my power. Please raise a MDLSITE issue on the Moodle Tracker.

    Gareth
  • Mon, May 17, 2021, 8:06 PM
    It's a very nice theme but it's seems to be very difficult to create a child theme based on Adaptable as a parent.
  • Gareth J Barnard
    Tue, May 18, 2021, 7:18 AM
    Dear Ben.

    Please, DO NOT ASK for technical support on this page.

    Use the Moodle Themes Forum instead.

    As you have already.

    G
  • Profile picture
    Tue, Jun 8, 2021, 6:48 AM
    Is it me, or the 3.10 version doesn't seem to extract properly from the zip? I keep getting the "file does not exist" error.
  • Gareth J Barnard
    Wed, Jun 9, 2021, 12:25 AM
    Dear Ivan.

    Please, DO NOT ASK for technical support on this page.

    Please use the Moodle Themes Forum instead.

    G
  • Mon, Jun 14, 2021, 7:15 PM
    When is the version for moodle 3.11 expected to be released?
  • Gareth J Barnard
    Mon, Jun 14, 2021, 10:21 PM
    Dear Elmeser,

    I took over Adaptable after Moodle was dropped by the developing institution because I was asked to by my clients. It is now being released here for the benefit of all whenever a client wants an update or new functionality. Thus there may or may not be a version for Moodle 3.11. It could be the case that no clients need it, but instead intend to upgrade to Moodle 4.0 when that is released and then will need a version of Adaptable for that.

    Kind regards,

    Gareth
  • Wed, Jun 16, 2021, 9:29 PM
    Hi the moodle 3.11 compatible version will be available when
  • Gareth J Barnard
    Wed, Jun 16, 2021, 10:52 PM
    Dear Wilfried,

    A repeat of the same answer to the same question (above) that Elmeser asked:

    I took over Adaptable after Moodle was dropped by the developing institution because I was asked to by my clients. It is now being released here for the benefit of all whenever a client wants an update or new functionality. Thus there may or may not be a version for Moodle 3.11. It could be the case that no clients need it, but instead intend to upgrade to Moodle 4.0 when that is released and then will need a version of Adaptable for that.

    Kind regards,

    Gareth
Please login to post comments