Variable numeric set

Question types ::: qtype_varnumericset
Maintained by Tim at Lone Pine Koala SanctuaryTim Hunt, Picture of Jamie PrattJamie Pratt, Picture of Phil ButcherPhil Butcher
A calculated numeric question type with variable and expression evaluation. All values are precalculated although a question can have several variants with different variable values for each variant.

Variable numeric set 1.4 for Moodle 2.5+

Moodle 2.5, 2.6, 2.7
Released: Wednesday, January 8, 2014, 10:38 PM
Variable Numeric Sets question type

Question type for Moodle - for numeric questions with variable and expression
evaluation. All values are precalculated although a question can have several
variants with different variable values for each variant.

The question type was created by Jamie Pratt (http://jamiep.org/) for
the Open University (http://www.open.ac.uk/).

This version of this question type is compatible with Moodle 2.5+. There are
other versions available for Moodle 2.3+.

To install using git, type this command in the root of your Moodle install:
git clone git://github.com/moodleou/moodle-qtype_varnumericset.git question/type/varnumericset
Then add question/type/varnumericset to your git ignore.

Alternatively, download the zip from
https://github.com/moodleou/moodle-qtype_varnumericset/zipball/master
unzip it into the question/type folder, and then rename the new folder to varnumericset.

You may want to install Tim's stripped down tinymce editor that only allows the use of
superscript and subscript see (https://github.com/moodleou/moodle-editor_supsub).
To install this editor using git, type this command in the root of your Moodle install:

git clone git://github.com/moodleou/moodle-editor_supsub.git lib/editor/supsub

Then add lib/editor/supsub to your git ignore.

If the editor is not installed the question type can still be used but if it is
installed when you make a question that requires scientific notation then this
editor will be shown and a student can either enter an answer with the notation
1x10^5 where the ^5 is expressed with super script.

Version information

Version build number
2014010800
Version release name
1.4 for Moodle 2.5+
Can be updated from
2011082701, 1.0 (2011082701), 1.0 (2011082701), 1.1 for Moodle 2.1 (2012081600), 1.1 for Moodle 2.2 (2012081600), 1.1 for Moodle 2.3+ (2012081600), 1.2 for Moodle 2.3+ (2013031400), 1.3 for Moodle 2.5+ (2013070100)
Can be updated to
1.5 for Moodle 2.6+ (2014111200)
Maturity
Stable version
MD5 Sum
f85f25e0728edf2781656c540cc3fce8
Supported software
Moodle 2.5, Moodle 2.6, Moodle 2.7

Version control information

Version control system (VCS)
GIT
VCS repository URL
VCS branch
master
VCS tag
v1.4

Default installation instructions for plugins of the type Question types

  1. Make sure you have all the required versions.
  2. Download and unpack the module.
  3. Place the folder (eg "myquestiontype") in the "question/type" subdirectory.
  4. Visit http://yoursite.com/admin to finish the installation