Pattern match with molecular editor

Question types ::: qtype_pmatchjme
Maintained by Tim at Lone Pine Koala SanctuaryTim Hunt, Jamie Pratt, Phil Butcher
A question type where the user enters their response using the JavaScript Molecular Editor, and the response is then graded using the OU's pattern-match algorithm.
Latest release:
425 sites
240 downloads
12 fans
Current versions available: 9

There are working examples in eAssessment with Moodle on our OpenLearn site.

The documentation is in How to create questions in Moodle on that site.

Sets

This plugin is part of set Open University.

Screenshots

Screenshot #0

Contributors

Tim at Lone Pine Koala Sanctuary
Tim Hunt (Lead maintainer)
Jamie Pratt: Developer
Phil Butcher: Question type designer
Colin Chambers: Developer
Chris Nelson: Product owner
Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • Tim at Lone Pine Koala Sanctuary
    Fri, Aug 24, 2012, 6:09 PM
    That is roughly what I am doing. I will ask you to peer review the patch when it is done.
  • Tim at Lone Pine Koala Sanctuary
    Fri, Aug 24, 2012, 7:33 PM
  • B.Havel
    Tue, Aug 28, 2012, 7:46 PM
    Now is OK, new install was without problem, upgrades problem was in history track.
  • Wed, Sep 19, 2012, 9:12 AM
    I had a client reported the following JME problem. Please help to identify the issue.
    "
    The JME editor now seems to work perfectly; however, the question engine does not recognize either of the correct answers when they are given. I assume this is a problem with the pattern match mechanism, since there is a function in the JME Editor to acquire the SMILES string and it is identical to the SMILES string entered in the question (although the question version requires escape characters, as per the manual: http://labspace.open.ac.uk/mod/oucontent/view.php?id=470268&section=5.5.2). "
  • Wed, Sep 19, 2012, 4:25 PM
    George can you find out exactly what the molecule or the correct answers are so that I can try them.
  • MD shot of me from his iphone4
    Wed, Jul 3, 2013, 7:53 PM
  • Wed, Aug 27, 2014, 12:04 AM
    I am running into issues with this plugin on my moodle 2.6.4 installation. I have installed version 1.4 following the instructions listed here however when I create and preview a question of this type in moodle the JME applet does not load.

    I see in my access logs that a request is being made for /question/type/pmatchjme/jsme/jsme.nocache.js

    This file(s) are not included in this plugin. I have the jmol/jsmol filter installed in my moodle installation. Any help would be appreciated
  • Thu, Aug 28, 2014, 5:41 PM
    Great spot jason. Sorry about that.

    It turns out that the zip in the Plugins directory is a bit out of date.

    The git repository https://github.com/moodleou/moodle-qtype_pmatchjme is more up to date but there are two fixes that still need to be deployed to it.

    I'm in the process of applying and testing the fixes. Then I will push to the repository and get the plugin zip in the plugins database updated.
  • Thu, Aug 28, 2014, 9:10 PM
    I've updated the git repository with the latest fixes (There was a javascript problem in IE 8) You'll find the JSME folder with the jsme.nocache.js file in there.

    If you're comfortable with git just pull the latest version, visit admin > notification and pmatchjme will be updated (the caches need to be flushed to get the latest javascript files).

    I'll look at getting the version in the Moodle plugins directory changed.
  • Thu, Aug 28, 2014, 9:53 PM
    Thanks Colin. The version of github works. I should have spotted it sooner. I was assuming the zip here and on github were identical.
  • Tim at Lone Pine Koala Sanctuary
    Tue, Nov 11, 2014, 2:59 AM
  • Wed, Jul 3, 2019, 6:25 PM
    Is a version for Moodle 3.7 planned? We have problems with this type of question on our installation. The question type gives no points or other reaction when answering questions.
  • Tim at Lone Pine Koala Sanctuary
    Wed, Jul 3, 2019, 6:49 PM
    I have not yet had time to test my plugins with Moodle 3.7. It surprises me if it has stopped working, because I don't think anything significant changed in 3.7 that would affect this question type, so I don't know why it is not working for you.
  • Tue, Jul 30, 2019, 3:10 PM
    I am also having difficulty with this plugin under Moodle 3.7.1. The JSME Molecular Editor shows up OK, and allows drawing the answer structure, but upon submitting the answer, the question page is re-drawn with red "Please enter an answer" text below the editor area. I can't find anything obviously alarming in the Apache log files. This happens with both Boost and Clean themes. Maybe co-incidentally, a similar issue is also affecting my qtype_fwstructmatch questions in 3.7.1 (these worked fines in 3.5).
Please login to post comments