Question types: Drag and drop onto image

qtype_ddimageortext
Maintained by Tim at Lone Pine Koala SanctuaryTim Hunt, Picture of Jamie PrattJamie Pratt, Picture of Phil ButcherPhil Butcher
As of Moodle 3.0, this question type is part of the standard Moodle release. That is why there is no plugin from Moodle 3.x. You don't need one!
253 sites
141 downloads
82 fans
Current versions available: 6

As of Moodle 3.0, this question type is part of the standard Moodle release. That is why there is no plugin from Moodle 3.x. You don't need one!

There are working examples in eAssessment with Moodle on our OpenLearn site.

The documentation is in How to create questions in Moodle on that site.

Demonstration of this question type courtesy of Dot Garman.

Sets

This plugin is part of set Open University.

Screenshots

Screenshot #0

Contributors

Tim at Lone Pine Koala Sanctuary
Tim Hunt (Lead maintainer)
Picture of Jamie Pratt
Jamie Pratt: Developer
Picture of Phil Butcher
Phil Butcher: Question type designer
Picture of Colin Chambers
Colin Chambers: Developer
Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • not cusack
    Mon, Feb 20, 2012, 6:00 PM
    I've tried adding both text and images to the same question and that seemed to mess things up. Either images or text only seems to work well, but both at the same time doesn't. Otherwise, fantastic new question type with heaps of potential!! Cheers,
    Guido
  • Picture of Colin Cooper
    Sat, Jun 30, 2012, 12:09 PM
    any idea if this will become part of the core moodle package?
  • Picture of Lauren Panton
    Thu, Aug 9, 2012, 11:46 PM
    Hi, I just tried to install this into our fresh install of Moodle 2.2.3. I first installed "gapselect" as instructed (https://github.com/moodleou/moodle-qtype_gapselect/) and then tried to install the "ddimageortext". The installation seems to work, but when I go to our Moodle site/admin, I get the following error: "Required Moodle 2012062500". What is it that I'm missing?
    Thanks in advance for your help, Lauren
  • Picture of Curtis Barker
    Wed, Aug 15, 2012, 12:39 AM
    It seems to have a problem generating the images correctly in 2.3 (actually all of the Drag and Drop set seem to have this problem).
  • Picture of Heinz Schmolke
    Fri, Aug 17, 2012, 4:29 AM
    I have the same problem like Lauren. Can anyone help?
Please login to post comments