Question types: Wiris Quizzes - True/False question type

qtype_truefalsewiris
Maintained by Picture of WIRIS team SUPPORTWIRIS team SUPPORT
This is one of the seven question types of the Wiris Quizzes set. Please install Wiris Quizzes to obtain the entire plugin package with seven question types.

Wiris Quizzes - True/False question type 3.78.2

Release notes

Wiris Quizzes True/False question type

Master Build Status

Build Status

Development Build Status

Build Status

The True/False Wiris Quizzes question type extends the Moodle True/False type, adding mathematical functionality to it.

All mathematical items are generated in a single calculation section and they can be referenced from anywhere in the content, in the question statement, answer, feedback for the student, etc.

On the student's side, they will be able to introduce their answers by using a WYSIWYG formula editor and, if the teacher so specifies, they will have access to a Wiris cas session to make some calculations. The answer syntax checker will prevent the students from unnecessary errors and misspellings.

Install instructions

To install it using git, type this command in the root of your Moodle install:

git clone https://github.com/wiris/moodle-qtype_truefalsewiris.git question/type/truefalsewiris

Then add /question/type/truefalsewiris to your git ignore.

Alternatively, download the zip from https://github.com/wiris/moodle-qtype_truefalsewiris/archive/master.zip it into the question/type folder, and then rename the new folder to "truefalsewiris".

License

Wiris True/False question type is Licensed under the GNU General Public, License Version 3.

Moodle 2.6, 2.7, 2.8, 2.9, 3.0, 3.1, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7, 3.8

Version information

Version build number
2020061600
Version release name
3.78.2
Maturity
Stable version
MD5 Sum
970e623c3cda63e9aa790c0a6fab3362
Supported software
Moodle 2.6, Moodle 2.7, PHP 5.6, Moodle 2.8, Moodle 2.9, Moodle 3.0, PHP 7.0, Moodle 3.1, Moodle 3.2, Moodle 3.3, PHP 7.1, Moodle 3.4, PHP 7.2, Moodle 3.5, Moodle 3.6, Moodle 3.7, PHP 7.3, PHP 7.4, Moodle 3.8
  • This is the latest release for Moodle 2.6
  • This is the latest release for Moodle 2.7
  • This is the latest release for Moodle 2.8
  • This is the latest release for Moodle 2.9
  • This is the latest release for Moodle 3.0
  • This is the latest release for Moodle 3.1
  • This is the latest release for Moodle 3.2
  • This is the latest release for Moodle 3.3
  • This is the latest release for Moodle 3.4
  • This is the latest release for Moodle 3.5
  • This is the latest release for Moodle 3.6
  • This is the latest release for Moodle 3.7
  • This is the latest release for Moodle 3.8

Version control information

Version control system (VCS)
GIT
VCS repository URL
VCS tag
v.3.78.2

Default installation instructions for plugins of the type Question types

  1. Make sure you have all the required versions.
  2. Download and unpack the module.
  3. Place the folder (eg "myquestiontype") in the "question/type" subdirectory.
  4. Visit http://yoursite.com/admin to finish the installation