Themes: Adaptable

theme_adaptable
Maintained by Picture of Jez HJez H, Picture of Manoj SolankiManoj Solanki
Adaptable is a highly customisable responsive two column theme designed for use on both large University installations as well as small training companies.

Adaptable 1.5.2

Release notes

Adaptable - the most adaptable moodle theme
===========================================

Version 1.5.2 (2017101100)

Adaptable is a highly customisable responsive two column moodle theme
based on the popular BCU theme adding:

-Customisable fonts (Google Fonts)
-Fully customisable colors
-Fully customisable block styles (including icons)
-Fully customisable buttons
-Additional header navigation
-News Ticker
-Alternative jQuery slider
-Alternative front page course styles
-Additional customizable marketing blocks
-Additional layout settings for width, slider width, padding of
various elements
-Social icons
-Mobile settings (customise how theme looks on mobile devices)
-Dismissible bootstrap alerts
-Option to add login form in header on front page
-Logo and Favicon uploader
-Modern emojis (thanks to EmojiOne)
-Front Page layout builder
-Dashboard layout builder
-Course layout builder

In addition many fields (menus, news items, alerts and help links) can
be targeted using custom profile fields, thus it is possible to present
different users with different nagivation items and notices. It is also
possible for individual users to customise where they want top menu
navigation to appear (disable, home pages only, sitewide) using custom
profile fields.

Adaptable has a lot of settings and may seem daunting at first, our
advice is to simply install with the default settings and play with it
afterwards.

With a little time you should be able to setup an attractive Moodle site
with a high degree of individuality without without knowing any CSS.

This theme has been developed by:
Jeremy Hopkins (Coventry University)
Fernando Acedo (3-bits.com)


NOTE: This Adaptable version is compatible with moodle 3.2 and higher only.
For older versions use Adaptable 1.3 branch.


Change Log
------------------------------------
The change log is available in: https://adaptable.ws/overview/change-log


Acknowledgments
-----------------------------
Big thanks to all the volunteers that are collaborating and testing
Adaptable continuously. We really appreciate your help and support to
develop the most adaptable theme for moodle.

Development:
- Justin Hunt
- Leonid Chernyavskiy
- COMETE (Paris Ouest University)
- Marina Glancy
- Nick Phillips
- Björn Bettzüche
- Michael Milette
- Bas Brands
- Manoj Solanki
- Gareth Barnard
- Pat Lockley

Testing:
- Andrew Walding
- Alexander Goryntsev

Translation:
- Fernando Acedo (Español - España)
- Germán Valero (Español - México)
- Jordi Rodilla (Català - Andorra)


Contributions
-------------
You are welcome to collaborate in the project. You can fix bugs, add new features or help in translation to your language. See CONTRIBUTING.txt for more information


Licenses
--------
Adaptable is licensed under:
GPL v3 (GNU General Public License) - http://www.gnu.org/licenses

Google Fonts released under:
SIL Open Font License v1.1 - http://scripts.sil.org/OFL
Apache 2 license - https://www.apache.org/licenses/LICENSE-2.0
The Ubuntu fonts use the Ubuntu Font License v1.0 - http://font.ubuntu.com/ufl/ubuntu-font-licence-1.0.txt

The Font Awesome font (by Dave Gandy) http://fontawesome.io) is licensed under:
SIL Open Font License v1.1 - http://scripts.sil.org/OFL

Font Awesome CSS, LESS, and SASS files are licensed under:
MIT License - https://opensource.org/licenses/mit-license.html

Emoji icons provided free by EmojiOne (http://emojione.com) released under:
Creative Commons Attribution 4.0 International - https://creativecommons.org/licenses/by/4.0/


Follow Us
---------
Twitter - https://twitter.com/adaptable_theme
Facebook - https://www.facebook.com/adaptable.theme

### Modify it! - Improve it! - Share it!
Moodle 3.2, 3.3

Version information

Version build number
2017101100
Version release name
1.5.2
Can be updated from
1.4 (2017053000), 1.5 (2017072500), 1.5.1 (2017082500)
Can be updated to
1.6.0 (2018011500), 1.7.1 (2018073000)
Maturity
Stable version
MD5 Sum
e470ca7ae3a983a8c77f9b4400285259
Supported software
PHP 7.0, Moodle 3.2, Moodle 3.3, PHP 7.1

Version control information

Version control system (VCS)
GIT
VCS repository URL
VCS branch
https://bitbucket.org/covuni/moodle-theme_adaptable/branch/version-1.5.2-2017101100

Default installation instructions for plugins of the type Themes

  1. Make sure you have all the required versions.
  2. Download and unpack the module.
  3. Place the folder (e.g. "ponies") in the "theme" subdirectory.
  4. Visit http://yoursite.com/admin to finish the installation