Enrolment: Banner/Luminis Message Broker

enrol_lmb
Maintained by Picture of Eric MerrillEric Merrill
Process courses, users, and enrollments out of Ellucian Banner. Includes support for realtime notifications from Luminis Message Broker, and Glassfish w/Legacy Adapter.

Banner/Luminis Message Broker 3.1.0 for Moodle 2.8.0-3.1.x

Release notes

Luminis Message Broker enrollment Module.
Version: 3.1.0
Moodle version: 2.8.0 through 3.1.x

Changes in 3.1.0
Fix error on enrollment methods page due to missing can_hide_show_instance().
Fix error in ignore domain case setting. Thanks to Charles Fulton.
Change instance_deleteable() to can_delete_instance().
Moodle 2.8, 2.9, 3.0, 3.1

Version information

Version build number
2016042810
Version release name
3.1.0 for Moodle 2.8.0-3.1.x
Can be updated from
2.1.0 (2012040101), 2.1.1 (2012040101), 2.1.5 (2012040101), 2.1.6 (2012040101), 2.1.7 (2012060702), 2.1.8 (2012091202), 2.1.9 (2012091203), 2.5.0 (2013050801), 2.5.1 (2013080202), 2.5.2 (2013091700), 2.5.2 (2013091700), 2.5.3 (2013102800), 2.6.0 (2013110400), 2.6.1 (2013121800), 2.6.1 (2013121800), 2.6.2 (2014011500), 2.7.0 (2014050700), 2.7.1 (2014121400), 2.9.0 (2015091700), 3.0.0 (2016021000), 3.0.1 (2016042800)
Can be updated to
3.3.0 (2017073100), 3.3.1 (2017080900), 3.4.0 (2018011100), 3.4.1 (2018042500)
Maturity
Stable version
MD5 Sum
6c85888b540678dba994d106bd73f9c6
Supported software
Moodle 2.8, Moodle 2.9, Moodle 3.0, Moodle 3.1
  • This is the latest release for Moodle 2.8
  • This is the latest release for Moodle 2.9
  • This is the latest release for Moodle 3.0
  • This is the latest release for Moodle 3.1

Version control information

Version control system (VCS)
GIT
VCS repository URL
VCS tag
3.0.1

Default installation instructions for plugins of the type Enrolment

  1. Make sure you have all the required versions.
  2. Download and unpack the module.
  3. Place the folder (eg "myenrol") in the "enrol" subdirectory.
  4. Visit http://yoursite.com/admin to finish the installation