Activities: Interactive Content – H5P

mod_hvp
Maintained by Picture of Frode PettersonFrode Petterson, Picture of Thomas MarstranderThomas Marstrander, Picture of Pål JørgensenPål Jørgensen, Picture of Svein-Tore Griff WithSvein-Tore Griff With
Create and add rich content inside your LMS for free. Some examples of what you get with H5P are Interactive Video, Quizzes, Collage and Timeline.
22468 sites
11k downloads
415 fans
Current versions available: 1

One of the great benefits with using H5P is that it gives you access to lots of different interactive content types.

Another great benefit with H5P is that it allows you to easily share and reuse content. To reuse content, you just download the H5P you would like to edit and make your changes – e.g. translate to a new language or adjust it to a new situation.

H5P is:

  • Open Source
  • Free to Use
  • HTML5
  • Responsive

Note that it is currently possible for people with programming skills to cheat in H5P interactions and obtain the full score without knowing the correct answers. H5Ps must not be used for exams or similar.

The H5P community is actively contributing to improve H5P. Updates and new features are continuously made available on the community portal H5P.org.

View our setup for Moodle to get information on how to get started with H5P.

GDPR Compliance

Information useful to help you achieve GDPR compliance while using this plugin can be found at H5P.org's GDPR Compliance page.

Sets

This plugin is part of set Gamification.

Potential privacy issues

The plugin is set up to automatically download content types and provide anonymous usage data which can be disabled through settings.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

Picture of Frode Petterson
Frode Petterson (Lead maintainer)
Picture of Thomas Marstrander
Thomas Marstrander: Developer
Picture of Pål Jørgensen
Pål Jørgensen: Developer
Picture of Svein-Tore Griff With
Svein-Tore Griff With: Developer
Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • Picture of Valentino Santucci
    Thu, Jun 25, 2020, 3:52 AM
    Hello. I have this plugin on a 3.7 instance and now planning to update to 3.9 version which has its own h5p editor. What I have to do? Keep the plugin in the new version? If I remove it, previous interactive content will disappear?
  • Picture of Thomas Marstrander
    Thu, Jun 25, 2020, 3:29 PM
    Hi, the core H5P and the plugin are two separate activities. They can live side by side, or you can migrate content over to the other activity type. You could check with Moodle if they have a migration path for getting plugin content to the core version if you wish.
  • Picture of Sara Arjona Téllez
    Thu, Jun 25, 2020, 3:49 PM
    Hi Valentino!
    We're working on a migration tool from mod_hvp to mod_h5pactivity: https://tracker.moodle.org/browse/MDL-67203
    As you'll see, there is the first version of this migration tool in the Moodle HQ repository: https://github.com/moodlehq/moodle-tool_migratehvp2h5p . It's still a beta version and once it will be reviewed and accepted, it will appear into the Moodle plugins database too. However, if you have time and test it before, we'll really appreciate your comments smile
  • Picture of Thomas Marstrander
    Thu, Jun 25, 2020, 4:19 PM
    By the way, the OER content hub (https://h5p.org/oer-hub-cominghttps://h5p.org/oer-hub-coming) for H5P is bound for release soon through the H5P plugin, so if this is something that peaks your interest you might want to keep the H5P plugin around until it gets integrated in Moodle core's H5P.
  • Picture of Roberto Hebert de Souza Vinha
    Sat, Jun 27, 2020, 2:29 AM
    How to use H5p native extension in the Moodle 3.9? If is it native, why download the plugin?
  • Picture of Jesus Marquez
    Sat, Jul 4, 2020, 3:36 AM
    Hi, I am creating an H5P activity and when I choose type content Course Presentation, I got this message: [field:group:coursepresentation:presentation] My environment: moodle 3.5.6 and H5P version 1.18. Thanks

    Thanks!
  • Picture of Ken Hui
    Thu, Jul 9, 2020, 3:34 PM
    Hello, the h5p plugin is disabled in default. And it doesn't show up on manage activities. I would like to know how do I enable it in such case?
    Moodle version is 3.8.2
    What I tried (but not working)
    1. Select another theme
    2. Clean cache
    3. reinstall plugin
    Thanks.
  • Picture of Thomas Marstrander
    Thu, Jul 9, 2020, 7:56 PM
    Hi Roberto, you can install the H5P plugin and it can live alongside the Moodle integration of H5P. The Moodle core H5P and the H5P plugin have slightly different features sets and release cycles, which may sway you in the direction of one or the other.
  • Picture of Thomas Marstrander
    Thu, Jul 9, 2020, 7:57 PM
    Hi Jesus, this may typically happen if you have a broken installation of a content type, I suggest trying to reinstall the content type you're experiencing this problem with. Alternatively if that doesn't solve it you can debug it using Moodle's php debugging features: https://docs.moodle.org/39/en/Debugging
  • Picture of Thomas Marstrander
    Thu, Jul 9, 2020, 7:59 PM
    Hi Ken, I can not reproduce this, sounds like the installation was not successfull, please ensure that you follow the steps to install a Moodle plugin: https://docs.moodle.org/39/en/Installing_plugins. If it still doesn't work I suggest enabling Moodle's php debugging to explore what is going wrong: https://docs.moodle.org/39/en/Debugging
  • Picture of Matt Jarvis
    Thu, Aug 20, 2020, 12:07 AM
    A cheeky question. I'm using Moodle 3.8 as it's LTS but the new H5P interface in Moodle 3.9 looks amazing. Is there any chance of making this available for 3.8 or is it a Moodle issue rather than an H5P one? Apologies in advance if that's the case and it's a daft question.
  • Picture of Thomas Marstrander
    Thu, Aug 20, 2020, 3:35 PM
    Hi Matt, the H5P plugin, which you download here, is available for any Moodle version, so you don't need to upgrade if you're just planning to use the plugin. If you're talking about the Moodle core integration of H5P that is included with the Moodle version, so you'd have to get the new Moodle core version in order to get that integration.
  • Picture of Sara Arjona Téllez
    Thu, Aug 20, 2020, 7:46 PM
    Hi Matt! I have good news for you because Moodle 3.9 is LTS: https://docs.moodle.org/dev/Releases#Moodle_3.9_.28LTS.29

    Maybe that makes easier for your institution to upgrade to 3.9 instead of 3.8 wink
  • Picture of Numerofobia Lealdino Filho
    Wed, Aug 26, 2020, 9:10 AM
    The interactive video plugin is not working for me. V. 3.9
  • Picture of Thomas Marstrander
    Wed, Aug 26, 2020, 3:00 PM
    Please follow the template for creating a bug report at https://h5p.org/forum/9 if you're having problems with a content type.
Please login to post comments