Activities: Flash Card Set

mod_flashcard
Maintained by Picture of Valery Fremaux Valery Fremaux, Picture of Tomasz Muras Tomasz Muras
Flashcards
1004 sites
251 downloads
30 fans

Important information.

The flashcard module was originally written by Valery for 1.9. It was hosted on the old Moodle plugins database, there was also an version initially ported to Moodle 2.

Tomek took over the work on it, finished porting into Moodle 2 and done few releases on the new plugins database page (this one). The latest version of this module is 3.2 and is available on github: https://github.com/tmuras/Moodle-Flashcard . It includes set of fixes from alekiy that should get it to work on Moodle 2.5. You can use it but this development is dis-continued.

Valery has now updated his branch of flashcard module into Moodle 2.5. The source code is https://github.com/vfremaux/moodle-mod_flashcard and the latest release is also on this, new plugins database as 2.4.0 (Build 2012040100). This is the branch you should be using now.

Both versions of flashcard module have diverged and are not compatible with each other. It's not possible to easily switch from one version (3.1 or 3.2) to another (2.4.0) without re-installing (and hence loosing all data).

Screenshots

Screenshot #0

Contributors

Picture of Valery Fremaux
Valery Fremaux (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • Picture of Knight Detroja
    Sun, 26 May 2013, 11:42 PM
    Is there a version of this plugin that is compatible with Moodle 2.5? Does anyone know if it will be available in the future? Thank you.
  • Picture of Moises Lizárraga
    Fri, 12 Jul 2013, 5:02 AM
    I see Yogesh Nahar talks about using version 2012080800, however I only see the link to download the 2012071800 version. Would someone be so kind to please post the link to download the latest version? I need to use this plugin with moodle 2.4 and I only see the version supported for 2.3 on the downloads section. Thanks in advance for your help.
  • Picture of Jeff Jones
    Wed, 20 Nov 2013, 11:37 PM
    Hi,
    We just installed Flashcard on Moodle 2.4.5+ (Build: 20130802). It looks like a great tool however on our edit screen there are two links that are missing:

    Question media type

    and Media type for answers.

    Attached are two screen shots, the first on is of my screen and the other is from the documentation for Flashcard.
    https://moodle.org/mod/forum/discuss.php?d=244147

    http://docs.moodle.org/24/en/Flashcard_module:_Configuration_Parameters#Media_Type_Selectors_.285.29

    Any advise would be greatly appreciated!

    Jeff
  • Picture of Valery Fremaux
    Fri, 22 Nov 2013, 6:42 AM
    Hi Jeff, would you consider trying the version published here :

    https://github.com/vfremaux/moodle-mod_flashcard

    We checked with Tomaz that we might not remerge our both diverging tracks but follow up with the rework i followed up starting from Tomaz's one but reintegrating proper use of moodle new file storage for media files.

    I waited for access to the plugin publication entry to revise the plugin version packages on Moodle. This seems to be now writable again. Communication will be pushed in soon.
  • Picture of Jeff Jones
    Sat, 23 Nov 2013, 3:13 AM
    Thanks Valery, that worked.
    FYI for anyone using Flashcard you cannot use .wav files, MP3 worked just fine.
  • Doc and Kayla
    Sat, 30 Nov 2013, 1:50 AM
    We are just now upgrading to Moodle 2.6 and would like to install Flashcards. Will the latest version work or should we wait until it is updated for 2.6?
  • Picture of Valery Fremaux
    Sat, 30 Nov 2013, 2:27 AM
    We can expect some minor deseases if soem part of very central APIs still change... on Flashcard, i do not forecast much trouble though. I have a fresh 2.6 installed version but no time yet to make it run... Moodle is evolving too fast those months to keep abiity to follow all tracks by my own...
  • Doc and Kayla
    Sat, 30 Nov 2013, 3:40 AM
    Thank you Valery for your prompt response and the work on this plug-in.
  • Picture of Valery Fremaux
    Sat, 30 Nov 2013, 5:53 AM
    if you have occasion andt some possibiity to make tryouts on a test instance, this would probbly speed up the process to get some "testing session report". I have yet not so much time to make end user testing, but can eventually free some time for bugfix on focussed issues.... Cheers !
  • Picture of Rodney Wolford
    Thu, 19 Dec 2013, 11:48 AM
    Hello,
    I have just tried to install this flashcard module and received the error shown below. I followed the "more information" option and it suggested that it might be appropriate to contact the developer. If this is not the right place, I can move it to a forum. I'd sure like to be able to use this module. Thanks for any help in advance. Rod Wolford
    DDL sql execution error

    More information about this error
    Debug info: Unknown column 'customreviewemptyfileid' in 'flashcard'
    ALTER TABLE flashcard ADD extracss LONGTEXT CHARACTER SET utf8 COLLATE utf8_general_ci AFTER customreviewemptyfileid
    Error code: ddlexecuteerror
    Stack trace:

    line 429 of /lib/dml/moodle_database.php: ddl_change_structure_exception thrown
    line 842 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
    line 88 of /lib/ddl/database_manager.php: call to mysqli_native_moodle_database->change_database_structure()
    line 77 of /lib/ddl/database_manager.php: call to database_manager->execute_sql()
    line 538 of /lib/ddl/database_manager.php: call to database_manager->execute_sql_arr()
    line 310 of /mod/flashcard/db/upgrade.php: call to database_manager->add_field()
    line 664 of /lib/upgradelib.php: call to xmldb_flashcard_upgrade()
    line 381 of /lib/upgradelib.php: call to upgrade_plugins_modules()
    line 1586 of /lib/upgradelib.php: call to upgrade_plugins()
    line 412 of /admin/index.php: call to upgrade_noncore()
  • Picture of Andreas Grupp
    Mon, 13 Jan 2014, 5:12 PM
    Hello
    just tried the upgrade from 2012071800 to 2014010600 in the new Moodle 2.6.1. I have the same problem as Rodney. The error message is:

    Debug info: Unknown column 'customreviewemptyfileid' in 'mdl_flashcard'
    ALTER TABLE mdl_flashcard ADD extracss LONGTEXT CHARACTER SET utf8 COLLATE utf8_unicode_ci AFTER customreviewemptyfileid
    Error code: ddlexecuteerror
    Stack trace:

    line 447 of /lib/dml/moodle_database.php: ddl_change_structure_exception thrown
    line 833 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
    line 88 of /lib/ddl/database_manager.php: call to mysqli_native_moodle_database->change_database_structure()
    line 77 of /lib/ddl/database_manager.php: call to database_manager->execute_sql()
    line 538 of /lib/ddl/database_manager.php: call to database_manager->execute_sql_arr()
    line 310 of /mod/flashcard/db/upgrade.php: call to database_manager->add_field()
    line 670 of /lib/upgradelib.php: call to xmldb_flashcard_upgrade()
    line 395 of /lib/upgradelib.php: call to upgrade_plugins_modules()
    line 1580 of /lib/upgradelib.php: call to upgrade_plugins()
    line 431 of /admin/index.php: call to upgrade_noncore()

    This problem seems to be still in the January version. Any help???
  • Picture of Krister Viirsaar
    Tue, 21 Jan 2014, 5:05 PM
    Updating from 2012080800 to 2014010600 on Moodle 2.6.1, getting EXACTLY the same error as Rodney Wolford and Andreas Grupp.
  • Picture of Valery Fremaux
    Tue, 21 Jan 2014, 5:20 PM
    This seems a break in the upgrade chain between branches... Could you try the following : Revert the flashcard in version 2012040201 in the table mdl_modules of Moodle, and rerun the updater...
  • Picture of Valery Fremaux
    Tue, 21 Jan 2014, 5:21 PM
    Note that the flashcard upgrade chain discontinues the previous version from Tomaz Muras, as the model did have big shifts between both tracks...
  • Picture of Krister Viirsaar
    Tue, 21 Jan 2014, 5:45 PM
    Valery, you mean to say that upgrading from 3.2 to 2.6 is impossible and needs to be completely reinstalled?
Please login to post comments