Activities: BigBlueButtonBN

mod_bigbluebuttonbn
Maintained by Picture of Fred DixonFred Dixon, Picture of Jesus FedericoJesus Federico
Integrate BigBlueButton within Moodle - including record and playback of sessions.
6884 sites
6k downloads
144 fans
Current versions available: 6

BigBlueButton is an open source web conferencing system for online learning.  The goal of the project is to enable instructors to effectively engage remote students.  The project supports live online classes, virtual office hours, and group collaboration with remote students. 

BigBlueButton supports real-time sharing of slides (including whiteboard), audio, video, chat, emojis, breakout rooms, and screen.  It also record all content for later playback.

Like Moodle, BigBlueButton is open source.  The BigBlueButton project was started in 2008 by Blindside Networks.  In addition our work on BigBlueButton core, we created this BigBlueButtonBN Moodle plugin so you can fully leverage BigBlueButton's capabilities from within your Moodle site.

The BigBlueButtonBN plugin enables you to:

  • Create multiple activity links to online sessions within any course
  • Restrict students from joining a session until a teacher (moderator) joins the session
  • Launch BigBlueButton in a separate window
  • Create a custom welcome message that appears at the top of the chat window when joining the session
  • Specify join open/close dates for the session that appears in the Moodle's calendar
  • Record a session
  • Access and manage recordings

The best way to install is directly from moodle.org.  For a video walkthrough of installing the plugin, click the image below


You’ll notice in the video that BigBlueButtonBN module comes pre-configured with a test BigBlueButton server, aptly called test-install.blindsidenetworks.com.  This server is maintained by Blindside Networks maintains to help test your installation with BigBlueButton.  Blindside Networks also develops and maintains the BigBlueButtonBN plugin. 

For information on setting up your own BigBlueButton server, see http://bigbluebutton.org/.

BigBlueButton and the BigBlueButton logo are trademarks of BigBlueButton Inc.

 

If you think you have found a bug in this plugin, please open a ticket in the Bug Tracker and provide details of how to reproduce the issue. The more details you provide the easiest for us to find and solve the problem. 

If you need help for configuring or using this plugin, please use the Forums. There are hundreds of users subscribed in the forums and many of them are willing to help. Besides your question may have been responded already. Using the search option can save you time. Also when asking for help provide the more possible details. Please provide (a) your version of Moodle, (b) the version of the BigBlueButtonBN plugin, and (c) the error message you are receiving.  A screen capture is usually very helpful. 

While we certainly appreciate feedback on this plugin in the comments sections, but if you found a bug or are looking for support, please use either the Bug Tracker or Forums. 


Sets

This plugin is part of sets Big Blue Button, MoodleCloud.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3
Screenshot #4

Contributors

Picture of Fred Dixon
Fred Dixon (Lead maintainer)
Picture of Jesus Federico
Jesus Federico: Project Manager
Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • Picture of Tassos Aroaneios
    Fri, Nov 22, 2013, 2:44 PM
    I have installed the plugin (latest version) in my moodle 2.5.2 site, and when I try to open a virtual class, whici I have created I have the message "Directory "/home/jereisma/public_html/eclass/mod/bigbluebuttonbn" is writeable by group"
  • Picture of Calvin Tan
    Mon, Jan 13, 2014, 12:00 PM
    I'm using moodle 2.6 and getting an error in view.php line 126. Seems $module->version is not defined. Anyway I changed that to get_config('mod_'.$module->name, 'version') to do the same thing.
    This issue occurs in recordingsbn view.php too, line 81.

    Anyone else experienced this?
  • Picture of Jesus Federico
    Tue, Jan 14, 2014, 12:18 AM
    Good catch Calvin Tan. Apparently the way the version for plugins is handled has changed in M2.6. The patch you proposed is correct for M2.6. Unfortunately it won't work on previous versions, so the "official" fix will be a selective assignation. For your case you can keep the patch you made.

    On the other hand, the version is not really important if you dont give support for multiple Moodle versions. So if you could also safely get rid off these lines, and also the one that assigns the value to $module. ( $module = $DB->get_record('modules', array('name' => 'recordingsbn'));)

    Thanks for letting us know.
  • Picture of Radi Penchev
    Fri, Jan 17, 2014, 1:21 AM
    Error: Exception - String could not be parsed as XML in moodle 2.6
    how to fix it?
  • Floyd Saner - Tail of the Dragon, U.S. 129, NC
    Thu, Jan 23, 2014, 9:29 AM
    We installed a BBB server, version 0.81. We are running Moodle 2.5.3+ (20131224). We installed BBB/BN (2013110100) and RecordingsBN (20131101) plugins on Moodle.

    On our server and on the BBB test server, we can initiate a session. However, when recording is enabled for the session (the login message panel says recording is on), no recordings are listed in the RecordingsBN Resource page. This is the same for our server and the BBB test server.

    Any suggestions?

    Thanks, Floyd
  • Picture of David Scotson
    Wed, Mar 26, 2014, 6:06 PM
    Is it possible to disable the recordings feature? Currently it seems like any user can choose to record. I'd like them not be offered this option.
  • Picture of Jesus Federico
    Wed, Mar 26, 2014, 10:02 PM
    Hi David,

    Indeed, you can disable the recording feature by modifying the code in your deployment. Just comment third block in mod_form.php (line 76 to 87).

    The whole configuration of the meeting can be done by any user with granted privileges for editing content in the course. Normally teachers.

    Regards,
  • Picture of Johan Reinalda
    Fri, Apr 4, 2014, 12:24 AM
    The download (and Moodle notification) show there is a new version 2013110104 .
    Howver, your git repo (which we use), is still showing version 2013110103
    Are you no longer updating your github repo ?
    (same for recordingsbn module)
    Thanks,
    Johan
  • Picture of Jesus Federico
    Fri, Apr 4, 2014, 2:05 AM
    We do, but that was a "hot fix" only required for the packaging available in the moodle plugin database.

    There were a couple of shell files that needed to be removed and they were not in github repo because the .gitignore file

    The only inconvenient was that in order to upload a new package the version tag needs to be updated.

    I jave just updated the github repo anyways.

    Thanks
  • Picture of Rupert Martin
    Sat, Apr 26, 2014, 7:11 PM
    The bigbluebutton plugin was installed ok, but when I tried to load the activity I am getting this error: "Exception - String could not be parsed as XML". Also having a problem loading the the plugins.php file to get a list of plugins so I can uninstall the plugin and try again. Can someone help?
  • Picture of Hossein Taleghani
    Wed, May 21, 2014, 12:48 AM
    Hi,
    As you may know, moodle 2.7 stable released about a week ago. Do you have any plans for updating this module for moodle's latest version?
  • Picture of Jesus Federico
    Wed, May 21, 2014, 12:52 AM
    Hi Hossein,

    Yes we have. But we haven't started working on it, so please keep visiting this page. As soon as we have it, it is going to be released. You can count on it!

    Thanks for the interest.
  • Picture of Stacy Rempel
    Sat, May 24, 2014, 12:06 AM
    Thank you, Jesus. This is great news! Can't wait to hear about a 2.7 update for BigBlueButton!
  • Picture of Gordon Bateson
    Fri, Jul 4, 2014, 12:39 PM
    Hi Fred,
    thanks for all your marvellous work with BigBlueButton and the associated Moodle plugins. There's a small problem with "mod/bigblubuttonbn/version.php", which causes installation warnings on Moodle 2.6.

    CHANGE THIS: $plugin->component = 'moodle-mod_bigbluebuttonbn';
    TO THIS: $plugin->component = 'mod_bigbluebuttonbn';

    regards
    Gordon
  • Picture of Jesus Federico
    Fri, Jul 4, 2014, 11:07 PM
    Hi Gordon,

    thanks for the heads up. I am actually working on an update for Moodle 2.7 and yesterday I uploaded a wrong package.

    The package was live for less than one hour and I was hoping that no one had used it to update. But it seems that you just did smile.

    I am testing right now, and depending of the plugin database the last version with support for 2.0, 2.1, 2.2, 2.3, 2.4, 2.5 and 2.6 could be 1.0.10 and the one for Moodle 2.6, 2.7 and further would be 1.0.11. This is because the deprecated components since 2.6, but nothing sure yet. I am still testing.

    Regards,
    Jesus Federico
Please login to post comments