Twitter card

General plugins (Local) ::: local_twittercard
Maintained by Matteo Scaramuccia
This Moodle local plugin emits a Twitter summary card for courses.

Twitter card 1.1.7 (Build: 2021052300)

Moodle 3.4, 3.5, 3.6, 3.7, 3.8, 3.9, 3.10, 3.11
Released: Tuesday, May 25, 2021, 4:17 PM

v1.1.7 (Build: 2021052300)

  • [Tests] Align Travis CI to GitHub Actions PHP 8.0 configuration
  • [Tests] Limit 'max_input_vars = 5000' requiment to PHP 8.0 (MDL-71390)
  • [Tests] PHP 8.0 requires 'max_input_vars = 5000' (MDL-71390)
  • [Tests] Moodle 3.11 supports PHP 8.0 (MDL-70745)
  • Remove old (MOODLE_33_STABLE) \core_privacy\local\legacy_polyfill use
  • Add more badges
  • [Tests] Replace build status badge w/ GHA one
  • [Tests] Schedule weekly GHA runs
  • [Tests] Add GitHub Actions support

v1.1.6 (Build: 2020111500)

  • [Tests] Add next Moodle under parallel development, 3.11.x on MOODLE_311_STABLE
  • [Tests] Replace PHPUnit 8.5 deprecations
  • [Tests] Add PHPUnit 8 compatibility (MDL-67673)
  • [Tests] Add support for 310 branch (MDL-67415)
  • [Tests] Remove Moodle 3.3 from automated testing (MDL-64725).
  • [Tests] Bump travis to use moodlehq/moodle-plugin-ci^3 (Upgrading from 2.X to 3.0).

v1.1.5 (Build: 2020061500)

  • [Tests] Moodle 3.9 requires PHP 7.2+ (MDL-65809).
  • [Tests] Moodle 3.8.3+ supports PHP 7.4 (MDL-66260).
  • [Tests] Moodle next, master branch, only on pgsql.
  • [Tests] Moodle 3.5.13+, 3.7.7+, 3.8.4+, 3.9+ requires Node v14 (ready for lts/fermium) (MDL-66109).
  • [Tests] Our Behat tests do not require JavaScript i.e. remove requirements for Selenium but be ready to activate Selenium when it will be required. Refs:
  • [Tests] Added Moodle 3.9.x release branch.

v1.1.4 (Build: 2019111700)

  • [Tests] Added Moodle 3.8.x release branch.

v1.1.3 (Build: 2019051900)

  • [Tests] Moodle 3.7 requires PHP 7.1+ (MDL-63276).
  • [Tests] Moodle 3.7+ runs on PHP 7.3 (MDL-63420).
  • [Tests] Project organization renamed for moodle-plugin-ci repo.
  • [Tests] Switch to OpenJDK headless JRE 8: blackboard-open-source/moodle-plugin-ci#83.
  • [Tests] Fixed empty FINALLY statement complaints.
  • [Tests] Added Moodle 3.7.x release branch.

v1.1.2 (Build: 2018120200)

  • [Tests] Added Moodle 3.6.x release branch.

v1.1.1 (Build: 2018082500)

  • [Tests] Replaced deprecated Behat step (#18).

v1.1.0 (Build: 2018040900)

  • Implemented the Moodle Privacy API (#15, #17).

v1.0.4 (Build: 2017121000)

  • Fixed an error when the course summary is not provided (#13).

v1.0.3 (Build: 2017111200)

  • Added PHP 7.2 to the tested env matrix: Moodle 3.4 supports it.

v1.0.2 (Build: 2017102700)

  • Ready for Moodle 3.4beta (Build: 20171025).

v1.0.1 (Build: 2017093000)

  • Improved test coverage (#5).

v1.0.0 (Build: 2017092901)

  • Do not emit the card when editing the course (#4).
  • Do not enable the Twitter summary card by default (#4).

v0.2 (Build: 2017092900)

  • Multi-language content now supported (#2).
  • Improved text shortening (#2).

v0.1 (Build: 2017092300)

  • First release.

Version information

Version build number
2021052300
Version release name
1.1.7 (Build: 2021052300)
Can be updated from
1.0.0 (Build: 2017092901), 1.0.1 (Build: 2017093000), 1.0.2 (Build: 2017102700), 1.0.3 (Build: 2017111200), 1.0.4 (Build: 2017121000), 1.1.0 (Build: 2018040900), 1.1.1 (Build: 2018082500), 1.1.2 (Build: 2018120200), 1.1.3 (Build: 2019051900), 1.1.4 (Build: 2019111700) (2019111700), 1.1.5 (Build: 2020061500) (2020061500), 1.1.6 (Build: 2020111500) (2020111500)
Maturity
Stable version
MD5 Sum
77e1cdb861f705e35ae7df90335a047e
Supported software
Moodle 3.4, Moodle 3.5, Moodle 3.6, Moodle 3.7, Moodle 3.8, Moodle 3.9, Moodle 3.10, Moodle 3.11
  • Latest release for Moodle 3.4
  • Latest release for Moodle 3.5
  • Latest release for Moodle 3.6
  • Latest release for Moodle 3.7
  • Latest release for Moodle 3.8
  • Latest release for Moodle 3.9
  • Latest release for Moodle 3.10
  • Latest release for Moodle 3.11

Version control information

Version control system (VCS)
GIT
VCS repository URL
VCS tag
v1.1.7

Default installation instructions for plugins of the type General plugins (Local)

  1. Make sure you have all the required versions.
  2. Download and unpack the module.
  3. Place the folder in the "local" subdirectory.
  4. Visit http://yoursite.com/admin to finish the installation.