CodePen

Filters ::: filter_codepen
Maintained by Arnaud Trouvé
A filter to embed Pens from their URL on codepen.io

CodePen 3.4.0

Moodle 3.4, 3.5, 3.6, 3.7, 3.8, 3.9, 3.10, 3.11
Released: Friday, March 1, 2019, 6:53 PM

3.4.0

  • Fix privacy provider get_reason declaration. This leads to drop PHP5 (Moodle 3.3 and prior) support
  • Switch versioning policy to use Semantic Versioning starting from 3.4.0

v3.3-r1.0

  • Add privacy implementation / GDPR compliance.

v3.1-r1.1

  • Fix #5 : issue concerning border 'none'
  • Performance improvement

v3.1-r1

  • Add support for https pen
  • Add setting to select which embed version to use and set version 2 as default value
  • Add setting to select which tabs must be displayed by default
  • Add a theme selector setting with CodePen default themes
  • Add settings to override theme
  • Add a preview panel

Version information

Version build number
2018050300
Version release name
3.4.0
Maturity
Stable version
MD5 Sum
9aac77a89dcf1e8dc55bf4ca45070a4e
Supported software
Moodle 3.4, Moodle 3.5, Moodle 3.6, Moodle 3.7, Moodle 3.8, Moodle 3.9, Moodle 3.10, Moodle 3.11
  • Latest release for Moodle 3.4
  • Latest release for Moodle 3.5
  • Latest release for Moodle 3.6
  • Latest release for Moodle 3.7
  • Latest release for Moodle 3.8
  • Latest release for Moodle 3.9
  • Latest release for Moodle 3.10
  • Latest release for Moodle 3.11

Version control information

Version control system (VCS)
GIT
VCS repository URL
VCS tag
3.4.0

Default installation instructions for plugins of the type Filters

  1. Make sure you have all the required versions.
  2. Download and unpack the filter plugin.
  3. Place the folder (eg "myfilter") in the "filter" subdirectory.
  4. Visit http://yoursite.com/admin to finish the installation