Blocks: Adaptable News Slider

block_news_slider
Maintained by Picture of Manoj SolankiManoj Solanki, Picture of Fernando AcedoFernando Acedo, Picture of Jez HJez H, Picture of Kevin MooreKevin Moore
Part of the Adaptable UI set, this block allows you to add a news slider that displays: 1: Unread course announcements (from all enrolled courses) 2: Site announcements (front page news announcements) 3: Both of the above (combined course and site announcements) The slider uses the jQuery slick slider and whilst designed to work with the Adaptable Theme, it *may* work with other themes.
265 sites
681 downloads
19 fans
Current versions available: 2

Moodle News Slider is a jquery news slider that integrates the slick carousel jquery slider with some customisation.  It has been designed to work well on large and small screen devices.  It displays site announcements, course announcements for the current user, or both of these.   These are ordered by date.

Currently this plugin works only with the Adaptable theme, version 1.4 onwards.

The video below shows the News Slider plugin in use alongside two other plugins (Course Discuss and Discussion Feed):



Configuration

Each slider instance can be configured to display only site announcements, course announcements or both. There are also options for max length of subject and excerpt strings.  Full configuration options available are shown below.  When used on a course page, only that specific course's unread announcements will display.


General configuration

  • Configurable max length of excerpt
  • Configurable max length of subject
  • Use caching plus cache expiry time


Per instance configuration

  • Option to display site news or course news or both
  • Maximum number of site announcements to display
  • Maximum period (in days) to show site announcements for
  • Link to older news items
  • Show bullet (dots) navigation on bottom of slider


Compatibility

  • Moodle 3.2, 3.3, 3.4
  • Adaptable version 1.4 onwards

Guidelines for use

You may want to experiment with the general configuration settings. E.g. for wider displays, you could increase max lengths of excerpts and vice-versa.


Sets

This plugin is part of set Adaptable UI.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

Please login to view contributors details and/or to contact them

Comments RSS

Comments

  • Picture of Plugins bot
    Thu, Sep 14, 2017, 5:10 PM
    Approval issue created: CONTRIB-7046
  • Picture of Enrique Castro
    Tue, Feb 27, 2018, 9:14 PM
    Hi: I know that this is designed to work with Adaptable theme. In fact, at my University we are using Adaptable currently (on moodle 3.1). But our planification for 2018-19 include using moodle 3.4 and Boost theme. This block is breaking javascript when displayed with Boost theme and derivatives. Nothing that uses javascript is working in Boost with this block.

    Any hint on where to search to fix this?
  • Picture of Fernando Acedo
    Wed, Feb 28, 2018, 2:17 AM
    As you stated, this block is part of Adaptable UI and only works with Adaptable. Anyway, this block never could work with Boost because are based in a different Bootstrap version.

    You are free to modify the code to adapt the block for Boost.
  • Picture of Manoj Solanki
    Fri, Mar 2, 2018, 12:13 AM
    Whilst the block has been designed to work with Adaptable UI, it could work with Boost. I suggest you check if anything else on the page, such as other custom block plugins, are conflicting with this plugin.
  • Picture of Cathy Hunt
    Fri, Mar 2, 2018, 12:15 AM
    Love this slider but just checking if I can change the colour.. as orange isn't in our branding
  • Picture of Jamie Kramer
    Thu, Mar 8, 2018, 10:56 PM
    I've reported an issue with installing this plugin at https://bitbucket.org/covuni/moodle-block_news_slider/issues/31/dependencies-check-failed
    There is a dependencies check error when installing, even with theme_adaptable already installed.
  • Picture of Manoj Solanki
    Wed, Jul 18, 2018, 10:08 PM
    @Cathy, it is possible to change the banner colour in custom css for the theme. You can modify the background colour for this css class: ".slider-banner-col" in your custom css settings.
  • Picture of Rheman Pessek
    Tue, Aug 28, 2018, 1:53 PM
    Hello. Great plugin. I am using the lastest release under moodle 3.3 with adaptable plugin. But I have created course announcement but nothing is displayed on Adaptable News Slider. Moreover how to create site announcement under moodle 3.3.

    regards
  • Picture of Manoj Solanki
    Mon, Sep 3, 2018, 3:50 PM
    Hi Rheman,

    Course announcements display for users enrolled on that particular course only. Maybe that's the issue. Other than that, check the other settings for news slider (maximum period) and cache settings. If cache enabled, it may not show straight away.

    M
  • Picture of Kathryn Woodhead
    Sat, Jan 12, 2019, 12:18 AM
    Hi, I have just installed this and its on my front page, but its not picking up any of the announcements.

    I would also like it on each course page, how do I do this?

    Thanks,
    Kathryn
  • Picture of Manoj Solanki
    Tue, Jan 15, 2019, 6:00 PM
    Hi Kathryn,

    For the front page, have you checked the settings for the news slider instance? In particular, the one called "Maximum period to show site announcements for (in days)", and if there are some valid site announcements within that period?

    To have it on a course page will require you to add a news slider block to a region that will appear on the course page. I don't know which theme you are using, but this is available in the Adaptable theme, as there is a specific block region that has been created in there for that purpose. I don't know if there are any other themes that have a block region you can add it to in this way.

    Hope that helps,

    M
Please login to post comments