Installing and upgrading help

Got a problem installing, upgrading or migrating your Moodle site?

Documentation: Installing Moodle, Installation FAQ, Upgrading and Upgrading FAQ
Forum moderator: Howard Miller

Before starting a new discussion topic, please check the Installation FAQ and Upgrading FAQ and try a forum search.

Remember to include in your post which version of Moodle (e.g. 3.2.1) you are using!

(You can find your Moodle version via Settings > Site administration > Notifications.)

Also provide as much relevant background information as you can about the versions and configuration of your server OS, PHP and browser.

(including upgrading and migration help)


Page: () 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 ... 169 ()
DiscussionStarted byRepliesLast post
error/moodle/locktimeout error while upgrading from 3.4.3 to 3.4.3+ 8 Ken Task
Fri, 1 Jun 2018, 6:41 AM
Fresh install Moodle 3.5+ 1 Ken Task
Thu, 31 May 2018, 1:35 AM
Moodle Blank page 7 Howard Miller
Wed, 30 May 2018, 7:48 PM
[3.4 -> 3.5] Data too long for column 'capabilities' at row 1 1 Richard van Iwaarden
Wed, 30 May 2018, 5:32 PM
innodb_file_format = Barracuda 6 Payman Zafar
Mon, 28 May 2018, 7:56 PM
After upgrading to 3.4 I get a white page HTTP ERROR 500 27 Ken Task
Mon, 28 May 2018, 7:40 AM
error connection timed out 7 Ken Task
Sun, 27 May 2018, 7:50 PM
install plugins hidden 2 altan ahmet
Sat, 26 May 2018, 10:16 PM
Moodle 3.5 Unicode UTF8mb4 support (Emoji Support) 6 D Anderson
Sat, 26 May 2018, 5:20 AM
inserting row into mysql through adminer 6 Jamie Tinley
Sat, 26 May 2018, 12:11 AM
Can not play all mp4 files after upgrading to Moodle 3.5 1 Bente Olsen
Fri, 25 May 2018, 5:34 PM
Memcahed and moodle 3.5 4 Alain Raap
Fri, 25 May 2018, 1:49 PM
Dataroot not writable (folder on a different server)... 3 Jeff Noel
Thu, 24 May 2018, 10:02 PM
unoconv issues in Moodle 3.1, trying to upgrade Moodle 3 Howard Miller
Thu, 24 May 2018, 3:59 PM
Pearson TCC Thin Common Storage and Moodle integration 10 Ken Task
Thu, 24 May 2018, 7:43 AM
Install updated plugins after Moodle upgrade or during? 7 Luis de Vasconcelos
Thu, 24 May 2018, 4:40 AM
What is the best idea for upgrade to 3.5 from very old version 7 Luis de Vasconcelos
Thu, 24 May 2018, 4:35 AM
How do I upgrade from 3.0.2 to 3.5 3 Howard Miller
Wed, 23 May 2018, 8:44 PM
Class 'core\session\manager' not found 5 Gernot Schirmbacher
Wed, 23 May 2018, 2:58 PM
navigation block missing after upgrade 0 Kevin S
Wed, 23 May 2018, 2:35 AM
New Install error 3 Ken Task
Tue, 22 May 2018, 11:31 PM
Let's encrypt and https 10 Javier Tejera
Tue, 22 May 2018, 11:09 PM
Moodle 3.1 and php 7.1 risks ? 3 Paul L
Tue, 22 May 2018, 8:58 PM
Moodle Installation Last Step Error 2 Trần Quý Phi
Tue, 22 May 2018, 5:06 PM
Creating New User Account - Code Error after Upgrade 1 Nitesh Kumar
Tue, 22 May 2018, 3:21 PM
Error while migrating existing Moodle 3.1.3 w/PostgreSQL to Google Cloud Platform 1 Ken Task
Tue, 22 May 2018, 8:12 AM
After update to Moodle 3.5 one course shows "Class 'Object' not found" 2 Andreas Giesen
Tue, 22 May 2018, 1:22 AM
Error Using Big Blue Button after 3.5 Upgrade 4 Paul Roberts
Tue, 22 May 2018, 1:10 AM
Blank spaces in filenames stopped working after upgrading to Moodle 3.5 2 Bente Olsen
Mon, 21 May 2018, 7:57 PM
How do I start a course? (Moodle4Mac 3.5) 1 Joshua Gaston
Mon, 21 May 2018, 6:34 PM
Suggested upgrade path 3.1->3.5 7 Howard Miller
Mon, 21 May 2018, 4:01 PM
Upgrade to 3.5 via git offers 3.6 8 Anze Pratnemer
Mon, 21 May 2018, 2:39 PM
Plugin setup error loop 5 Ken Task
Mon, 21 May 2018, 11:08 AM
Choosing web-camera / microphone in version 3.5 0 Jens Gammelgaard
Sun, 20 May 2018, 4:20 PM
Error when updating to Moodle 3.4 6 James Steerpike
Sun, 20 May 2018, 11:08 AM
Nginx slasharguments almost working 1 Richard Pavonarius
Sun, 20 May 2018, 9:16 AM
problem after update 0 Berrie Sleijster
Sat, 19 May 2018, 10:18 PM
Installation Error code: nopermissions 16 Ken Task
Sat, 19 May 2018, 8:13 PM
Upgrade from 3.1 to 3.5 2 Jayden Tyronian
Sat, 19 May 2018, 3:19 PM
Anti Virus Issues after install 2 Chris Simpson
Sat, 19 May 2018, 9:38 AM
version 5.5.31 is required and you are running 5.5.5.10.1.29.6 2 Howard Miller
Sat, 19 May 2018, 12:50 AM
Annoying restored test Moodle 7 Tim Williams
Fri, 18 May 2018, 11:52 PM
Issues after Upgrade to 3.5 0 Chad Hivner
Fri, 18 May 2018, 10:49 PM
Help with updating PHP on our Moodle v2.97 0 Mark Little
Fri, 18 May 2018, 9:52 PM
Error when upgrading to 3.4 15 Ken Task
Fri, 18 May 2018, 9:09 PM
moving moodle from win to linux moodle 3.3.5+ 13 Adam Cripps
Fri, 18 May 2018, 8:46 PM
Upgrade to Moodle 3.5 fails when using external registration database 7 Howard Miller
Fri, 18 May 2018, 5:27 PM
Is it your first time here disappeared and user management error 0 Otmar Bender
Fri, 18 May 2018, 1:25 PM
Update from 3.2 to 3.5 fails on missing Add-Ons 3 Andreas Giesen
Fri, 18 May 2018, 7:03 AM
https: mixed content error 3 Matteo Scaramuccia
Fri, 18 May 2018, 5:26 AM
Upgrade steps 2 Visvanath Ratnaweera
Fri, 18 May 2018, 2:06 AM
Microsoft Drivers for SQL Server for PHP are not installed or not configured properly: Moodle 3.4, PHP 7 3 Luis de Vasconcelos
Fri, 18 May 2018, 12:25 AM
Upgrading 2.5.2 with very large SQl db. 2 Jean-Francois Lepage
Thu, 17 May 2018, 10:15 PM
Database Driver Problem 3 Roman Cylwa
Thu, 17 May 2018, 8:34 PM
Recommended linux partition for moodle server 3 Visvanath Ratnaweera
Thu, 17 May 2018, 4:37 PM
Error installing plugin and purge cache 1 Colin Fraser
Thu, 17 May 2018, 3:11 PM
Migrating Moodle site from computer to live website 11 Rick Jerz
Wed, 16 May 2018, 10:42 PM
Installing Moodle 0 Derrick Llewellyn
Wed, 16 May 2018, 8:34 PM
Problem with "completed" command-line installation of Moodle 3.4 16 Gary Lebowitz
Wed, 16 May 2018, 4:42 AM
clean uninstall of Moodle 3.4.2+ 4 Rick Jerz
Tue, 15 May 2018, 8:32 PM
Moodle 3.5 Release Candidate - release date 9 Paul Raper
Tue, 15 May 2018, 4:36 PM
How to fixed "your site is not secured using HTTPS" 2 Phuong Hoang
Tue, 15 May 2018, 4:31 PM
Installing behind a nginx proxy gives - Error code: nopermissions 6 Pierre V
Mon, 14 May 2018, 11:59 PM
dataroot is not configured properly 3 Ken Task
Mon, 14 May 2018, 9:07 PM
How to increase session timeout to greater than 4 hours? 5 Howard Miller
Mon, 14 May 2018, 8:49 PM
undefined window popup 2 Howard Miller
Mon, 14 May 2018, 4:27 PM
error setuping moodle 3 Roberts tate
Mon, 14 May 2018, 12:02 AM
Upgrade 1 Nitesh Kumar
Fri, 11 May 2018, 6:25 PM
Help - new user Admin password problems! 1 Nitesh Kumar
Thu, 10 May 2018, 7:01 PM
Update registration: Coding error detected, it must be fixed by a programmer: Invalid core subtype "register" in renderer request 5 Hanson Haki
Wed, 9 May 2018, 12:10 PM
Cannot add admin site user in moodle 3.1 2 Ken Task
Wed, 9 May 2018, 4:40 AM
can't disable open_base restriction 4 Howard Miller
Tue, 8 May 2018, 5:01 PM
Only one user getting a 403 Error message 0 Fran Johnson
Tue, 8 May 2018, 2:28 AM
Installing Moodle 3.4.2+ (Build: 20180502) 10 Mark Gaskell
Mon, 7 May 2018, 7:33 PM
Exception - Call to a member function find() on null 5 ARUN KUMAR. SP
Mon, 7 May 2018, 11:14 AM
How I can to block video Menu???? 10 Cláudia Franca
Sun, 6 May 2018, 1:58 AM
MoodleWindowsInstaller-latest-34 connection reset after install 1 Alex Smith
Sat, 5 May 2018, 11:34 PM
Database not linked to upgraded 3.4.2 2 Karen Barber
Sat, 5 May 2018, 10:06 AM
Changing Moodle server 1 Ken Task
Sat, 5 May 2018, 7:14 AM
moodle 3.4.2, sql server 2017, localhost IIS windows server 2016, php 7 3 Usman Asar
Sat, 5 May 2018, 5:20 AM
cron installation 5 Luis de Vasconcelos
Fri, 4 May 2018, 6:26 PM
Upgrade issue 3.1 -> 3.5 2 Luis de Vasconcelos
Fri, 4 May 2018, 5:41 PM
Upgrade from 3.0.2 to 3.4.2 error 8 Howard Miller
Thu, 3 May 2018, 10:00 PM
tracking what user is being used 3 Heather P
Thu, 3 May 2018, 9:19 PM
Problem in Install 2 Lu Zheng
Thu, 3 May 2018, 5:37 PM
IIS permissions on Moodle data folder 7 Luis de Vasconcelos
Thu, 3 May 2018, 6:19 AM
Here is a suggestion aboutCRON and Windows Server 2016 1 Luis de Vasconcelos
Thu, 3 May 2018, 5:54 AM
Arabic language from Oracle turns to ????? ????? 3 Matteo Scaramuccia
Wed, 2 May 2018, 4:37 AM
Google SSO 1 Emma Richardson
Mon, 30 Apr 2018, 8:30 PM
The page isn't redirecting properly with Fresh installation 1 Emma Richardson
Mon, 30 Apr 2018, 8:25 PM
error/An error occurred whilst communicating with the server 1 Danielle Akini
Mon, 30 Apr 2018, 3:24 PM
will Git automatically upgrade across generations? 3 Ken Task
Sun, 29 Apr 2018, 8:19 PM
Upgrading from 2.8 to 3.4 2 Harold Bieber
Thu, 26 Apr 2018, 11:58 PM
TopColls giving an error after upgrade 0 Francesca ashley cooper
Thu, 26 Apr 2018, 8:27 PM
Out of Memory error since upgrading from 3.3 to 3.4 2 yazie alfy
Thu, 26 Apr 2018, 7:34 PM
SOLR not searching in specified search areas 3 Alexandra F
Thu, 26 Apr 2018, 3:14 PM
Installation Error when Upgrading to 3.0 0 G R
Thu, 26 Apr 2018, 1:53 AM
Accidently deleted Chat module. How do I reinstall? 2 Andrew Chang
Wed, 25 Apr 2018, 6:27 AM
installing err on windows 1 Luis de Vasconcelos
Wed, 25 Apr 2018, 5:45 AM
moodle link from Ip to Dns 11 Ken Task
Sun, 22 Apr 2018, 10:43 PM
Page: () 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 ... 169 ()