Installing and upgrading help

Got a problem installing, upgrading or migrating your Moodle site?

Documentation: Installing Moodle, Installation FAQ, Upgrading and Upgrading FAQ
Forum moderator: Howard Miller

Before starting a new discussion topic, please check the Installation FAQ and Upgrading FAQ and try a forum search.

Remember to include in your post which version of Moodle (e.g. 3.2.1) you are using!

(You can find your Moodle version via Settings > Site administration > Notifications.)

Also provide as much relevant background information as you can about the versions and configuration of your server OS, PHP and browser.

(including upgrading and migration help)


Page: () 1 ... 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 ... 169 ()
DiscussionStarted byRepliesLast post
installing moodle2.4 on host 4 zahra shahsavari
Sun, 12 Feb 2017, 2:56 AM
installation complete with problems 4 ihab ali
Sat, 11 Feb 2017, 5:50 PM
Moodle 3.2 - CSS styles won't load on server & file picker won't load 1 Joe Cape
Fri, 10 Feb 2017, 7:40 PM
Upgrade moodle2.8.3 to moodle3.2.1 or latest one. 1 Emma Richardson
Wed, 8 Feb 2017, 11:00 PM
Storage of courses 2 AL Rachels
Wed, 8 Feb 2017, 4:06 AM
E-mail Based Registration Issue after Migration 1 Ken Task
Wed, 8 Feb 2017, 1:20 AM
Make a copy of old Moodle 3.0.4 site under new Moodle 3.2 site ? 13 Dee K
Tue, 7 Feb 2017, 6:54 PM
Moving courses from Moodle 2.2.1 server to new 3.1.2 server 1 Ken Task
Tue, 7 Feb 2017, 8:46 AM
3.1.2 to 3.1.3 upgrade by cpanel (godaddy) 65 Just H
Mon, 6 Feb 2017, 5:39 AM
Exception - Call to undefined method flexible_table::get_download_menu() 3 Ken Task
Sat, 4 Feb 2017, 11:10 PM
Moodle 2.7 plugins and upgrade - ESIG 8 Mike Bourdin
Sat, 4 Feb 2017, 12:56 AM
Who can summarize a best practice for upgrading Moodle? 6 AL Rachels
Fri, 3 Feb 2017, 11:56 PM
Change default text in Moodle core 2 gary asselbergs
Fri, 3 Feb 2017, 10:14 PM
Can't install plugins 4 Attila Meszaros
Fri, 3 Feb 2017, 9:37 PM
It is possible that the database is overloaded or otherwise not running properly 23 Meindert Jorna
Fri, 3 Feb 2017, 6:05 PM
two errors while installing 1 sandeep baghel
Fri, 3 Feb 2017, 5:03 PM
Professional help upgrading without contract 8 sandeep baghel
Fri, 3 Feb 2017, 11:56 AM
Deleted cache, can't get to anything 6 Rich Ingordo
Thu, 2 Feb 2017, 9:51 PM
Upgrading PHP version from 5.5 to 7.0 for Moodle 3.2 use 14 Gary Lebowitz
Wed, 1 Feb 2017, 7:21 PM
Moodle Url Change 1 Damyon Wiese
Wed, 1 Feb 2017, 4:35 PM
recommended hosting with auto installer 7 f. nunes
Wed, 1 Feb 2017, 8:02 AM
Edit user / add user not available 1 James Yeo
Wed, 1 Feb 2017, 3:01 AM
Installing Moodle update fears 3 Usman Asar
Wed, 1 Feb 2017, 1:50 AM
Looking for VERY specific release of older Moodle 3 Randy Thornton
Tue, 31 Jan 2017, 1:10 PM
Fatal error: $CFG->dataroot is not configured properly (but moodle 3.2.1 works) 1 Randy Thornton
Tue, 31 Jan 2017, 8:39 AM
Appearance of the new version 3.2.1 5 Emma Richardson
Tue, 31 Jan 2017, 4:07 AM
Rolling Back 3.2.1 5 Ken Task
Tue, 31 Jan 2017, 3:26 AM
PHP unable to connect to PG DBMS 7 Ken Task
Tue, 31 Jan 2017, 1:07 AM
Updating plugins behind firewall | Automatic Updates 3 Ken Task
Mon, 30 Jan 2017, 11:17 PM
Old Moodle 1.9 on new PHP 5.6 1 Howard Miller
Mon, 30 Jan 2017, 6:51 PM
Upgrading from Moodle 3.0.X to 3.2 on Ubuntu 14.04 2 Gary Lebowitz
Mon, 30 Jan 2017, 3:52 AM
Trying to install Moodle through GoDaddy 2 Rick Jerz
Mon, 30 Jan 2017, 2:41 AM
NFS setup and permissions moodle 2.8.5 2 Olav Haunsvig
Sun, 29 Jan 2017, 3:11 PM
Installation coming without css 21 Dave Emsley
Sat, 28 Jan 2017, 8:27 PM
Unable to install Moodle Successfully 2 Moodle Admin
Sat, 28 Jan 2017, 7:15 PM
Themes not working after upgrade 2 Martina Martin
Sat, 28 Jan 2017, 4:37 AM
Installing a new 3.2.1+ but freezes on Plugins Check upgrade database 4 Larry Johnsen
Sat, 28 Jan 2017, 4:19 AM
Updating Ubuntu to 16.04 LTS / Moodle 3.1.4+ 2 Ken Task
Sat, 28 Jan 2017, 1:01 AM
user profile not editable in 3.2.1 3 Emma Richardson
Fri, 27 Jan 2017, 10:01 PM
Installation of 3.2.1 1 Emma Richardson
Fri, 27 Jan 2017, 4:45 AM
Activate plugins 3 AL Rachels
Thu, 26 Jan 2017, 12:57 AM
JQuery Errors in Moodle 14 Ken Task
Wed, 25 Jan 2017, 4:10 AM
Upgraded to 3.2, admin unable to connect to courses 2 Helen Foster
Tue, 24 Jan 2017, 10:55 PM
Installing 3rd party plugin 2 Marcus Green
Tue, 24 Jan 2017, 9:14 PM
'Error Connecting to Server' Moodle 3.1 3 Bryson Stansfield
Mon, 23 Jan 2017, 9:06 AM
How to upgrade from a 1.9.5 version to a 3.x version? 4 Ken Task
Mon, 23 Jan 2017, 4:00 AM
Plugins Missing From Disk After Upgrade To 3.2.1 2 Ken Task
Mon, 23 Jan 2017, 12:02 AM
Upgraded to 3.2.1, in mobile app, Audio not playing 5 Justin Hunt
Sat, 21 Jan 2017, 9:10 PM
Moodle update notification 2 Bente Olsen
Sat, 21 Jan 2017, 12:02 AM
students cannot see lessons after upgrade to 3.2 3 Emma Richardson
Fri, 20 Jan 2017, 11:49 PM
How to upgrade from a 3.1.1 version to a 3.1.4 version? 3 Emma Richardson
Fri, 20 Jan 2017, 9:06 PM
Restore courses into 3.2.1 from backups made on 2.4 0 Sergio Sanchez
Thu, 19 Jan 2017, 9:12 PM
upgrade from Moodle 3.1 to 3.2 5 Miyone G
Thu, 19 Jan 2017, 5:26 AM
" Authentication plugin manual not found" Error 2 Fidel Captain
Thu, 19 Jan 2017, 1:54 AM
Enabling other people to acess my Moodle Windows Installer 2 Victor Kindinger
Thu, 19 Jan 2017, 1:17 AM
Moodle 2.6.2 connection to SQL Server with TLS1.2 0 Elavarasan MS
Wed, 18 Jan 2017, 9:13 AM
Exception : Call to a member function getAttribute() on null 1 Howard Miller
Wed, 18 Jan 2017, 5:14 AM
Blank page after Git upgrade to Moodle_32_Stable 5 graham woodsford
Tue, 17 Jan 2017, 11:57 PM
PHP 5.6.5 version is not available on internet (Moodle 3.2 upgrade requirement) 1 Howard Miller
Tue, 17 Jan 2017, 6:56 PM
Upgrade from Moodle 2.4 (Build: 20121203) to Moodle 3.2.1 7 Jamshed I
Tue, 17 Jan 2017, 3:09 AM
moodledata not accessible under CentOS 12 Lorenzo Eccher
Mon, 16 Jan 2017, 5:14 PM
Problem with images - Moodle 3.1.1 5 spyros zoup
Mon, 16 Jan 2017, 10:16 AM
Syntax Error in Site Admin Menu 5 Howard Miller
Sun, 15 Jan 2017, 7:54 PM
Weird behavior afte upgrading 2 Milciades Ramirez
Sun, 15 Jan 2017, 9:24 AM
Class cachestore_apc contains 1 abstract method 3 Josiah Philipsen
Sat, 14 Jan 2017, 2:27 AM
Microsoft web app install - error 0 Rob Gutshall
Fri, 13 Jan 2017, 9:36 PM
Upgraded from 2.6 > 2.7 > 3.2, now Add Activity or Resource isnt clickable 7 Michael Collier
Fri, 13 Jan 2017, 5:06 PM
3.2 seems to allow admin priviledges 4 Emma Richardson
Fri, 13 Jan 2017, 3:40 AM
Moodledata folder 4 Tech1 Web
Thu, 12 Jan 2017, 9:03 AM
Best file permissions to use 3 AL Rachels
Thu, 12 Jan 2017, 3:39 AM
Install Warning 1 Ken Task
Wed, 11 Jan 2017, 9:11 PM
Downgrading Moodle 2 Howard Miller
Wed, 11 Jan 2017, 9:10 PM
Coding error detected, it must be fixed by a programmer: Invalid property requested, or the property does not has a default value. 1 Emma Richardson
Wed, 11 Jan 2017, 8:00 PM
Moodle CommandLine upgrade 1 Moodle Admin
Wed, 11 Jan 2017, 9:05 AM
Reinstall Moodle without full delete and re-download from Git? 2 Moodle Admin
Wed, 11 Jan 2017, 8:56 AM
bad display 18 joel Green
Tue, 10 Jan 2017, 4:19 PM
Windows - MSVCP140.dll Missing 3 Barry Schell
Tue, 10 Jan 2017, 4:01 AM
Plugin "mod_wiki" is defective or outdated 1 Emma Richardson
Tue, 10 Jan 2017, 3:45 AM
Moodle database version 5.5.5.10.0.14 6 Admin IKT-Wissen
Tue, 10 Jan 2017, 12:30 AM
Migrating users from 1.9.19 to 3.1.2 7 Marjan Milošević
Mon, 9 Jan 2017, 10:10 PM
To change theme or not to change theme 3 Lynne Hand
Sun, 8 Jan 2017, 10:06 PM
Moodle 3.2 is not getting installed on godaddy 6 Rick Jerz
Sun, 8 Jan 2017, 10:01 AM
Installation - Moodle 3.1.3+ (Build: 20170106); Dependencies check failed for ltiservice_toolproxy, ltiservice_toolsettings 3 Howard Miller
Sun, 8 Jan 2017, 12:43 AM
SCORM Package Upload on Moodle 3.2 2 L Passaglia
Sat, 7 Jan 2017, 7:09 AM
Moodle 2.7 Cron problems 3 Howard Miller
Sat, 7 Jan 2017, 4:18 AM
Shared Hosts that CAN and CAN'T Run Joomdle 3 Emma Richardson
Sat, 7 Jan 2017, 3:25 AM
Help required with Moodle Upgrade from 3.1 to 3.2 4 Emma Richardson
Fri, 6 Jan 2017, 8:56 PM
Log in not responding on moodle 10 morola oyedele
Fri, 6 Jan 2017, 4:38 PM
Upgrading PHP5.5 to 5.6 on Ubuntu 14.04 LTS 24 Mark Hayes
Fri, 6 Jan 2017, 8:32 AM
Code Moodle 2.6.2+ 1 Iban Cardona i Subiela
Thu, 5 Jan 2017, 10:17 PM
Upgrade 2.7->3.2 "Die Abhängigkeitprüfung ist fehlgeschlagen für..." 1 A FRI
Thu, 5 Jan 2017, 7:28 PM
moodle front page 1 Martin Greenaway
Thu, 5 Jan 2017, 2:09 AM
PHP version incompatible for moodle install 3 Teresa Crumpton
Thu, 5 Jan 2017, 2:06 AM
Plugin "block_course_overview" is defective or outdated 3 Ravina Parab
Wed, 4 Jan 2017, 1:50 PM
Database conflicts between production and sandbox Mdl? 3 Randy Thornton
Wed, 4 Jan 2017, 7:12 AM
Why not Php 7.0? 4 Matteo Scaramuccia
Tue, 3 Jan 2017, 5:34 PM
Cannot install moodle on godaddy server 37 roland salim
Tue, 3 Jan 2017, 4:18 PM
Trouble upgrading from 3.1.1 to 3.2 8 Fred Frazelle
Tue, 3 Jan 2017, 12:10 PM
Moving contents from Moodle 1.9 to Moodle 3.2 17 Ken Task
Sun, 1 Jan 2017, 11:35 PM
upgraded to 3.2 and now emails being sent (via Moodle) 4 Brian Yanosik
Fri, 30 Dec 2016, 11:09 PM
Page: () 1 ... 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 ... 169 ()