Installation help

 
 
Picture of stephen mills
Remote Access Problems
 

Hi,

I have installed Moodle on Windows 2003 using IIS and MySQL. when I log into moodle using the servers browser it displays fine, however when I log into moodle from a remote machine the web page doesnt display correctly, all the objects are jumbled up on the page and when i click on login it shows a cant display page. i'm thinking this is a permissions related issue but am unsure. i have the IUSER_machinename account having read and execute permissions on the C:\Inetpub\wwwroot\moodle folder and all sub folders.

On the moodle folder in IIS, in properties, directory tab i have the read checkbox ticked, and scripts only from the execute permissions dropdown selected. on the directory tab i have the index.php listed at the top, on the directory security tab i have the anonymous access ticked and windows authentication ticked (though i have tried this without being ticked with no success).

I also have the PHP ISAPI Extension allowed which uses the php5isapi.dll file. i'm really stuck on this and am not sure what else i can do to make this work correctly, i appreciate any help people can give me on this and if you need to know more information about my setup please ask and ill supply the info.

thank you very much. Steve

 
Average of ratings: -
Picture of Mauno Korpelainen
Re: Remote Access Problems
Group Particularly helpful Moodlers

Have you used localhost in config.php wwwroot? Try to use server address or ip like

$CFG->wwwroot = 'http://www.nameofyourserver.com/moodle';

or

$CFG->wwwroot = 'http://123.123.123.123/moodle';

 
Average of ratings: -
Picture of harsimran singh
Re: Remote Access Problems For xampp server on Server 2003
 

Setting for accessing moodle on remote server
First set the xampp settings
go to xampp folder -> apache folder -> conf-> extra ->httpd-xampp.conf
Change these setting in this file change only LocationMatch

*****************************************

Before:

<LocationMatch "^/(?isad?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">

Order deny,allow

Deny from all

Allow from 127.0.0.0/8

ErrorDocument 403 /error/HTTP_XAMPP_FORBIDDEN.html.var</LocationMatch>

After:

<LocationMatch "^/(?isad?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">

Order deny,allow

#Deny from all

Allow from 127.0.0.0/8

ErrorDocument 403 /error/HTTP_XAMPP_FORBIDDEN.html.var</LocationMatch>

*************************************************
convert the deny  line into comment then you can access the xampp on remote server client environment
*************************************************
Know for accessing the moodle folder from your server change these settings in moodle folder
1)Go to your moodle folder

2)Open moodle -> conf.php

Before:config.php

********************************************

<?php  // Moodle configuration file

unset($CFG);global $CFG;$CFG = new stdClass();
$CFG->dbtype    = 'mysqli';

$CFG->dblibrary = 'native';

$CFG->dbhost    = 'localhost';

$CFG->dbname    = 'moodle';

$CFG->dbuser    = 'root';

$CFG->dbpass    = '';

$CFG->prefix    = 'mdl_';

$CFG->dboptions = array (  'dbpersist' => 0,  'dbsocket' => 0,);
$CFG->wwwroot   = 'http://localhost/moodle';

$CFG->dataroot  = 'C:\\xampp\\moodledata';$CFG->admin     = 'admin';
$CFG->directorypermissions = 0777;
$CFG->passwordsaltmain = '7_TuLJal*c<zh?XI9=4PNfXV~U';
require_once(dirname(__FILE__) . '/lib/setup.php');
// There is no php closing tag in this file,// it is intentional because it prevents trailing whitespace problems!

**********************************************************************************change only$CFG->wwwroot   = 'http://localhost/moodle';

to

your serverip

$CFG->wwwroot   = 'http://xxx.xxx.xxx.xxx/moodle';

******************************************************************************<?php  // Moodle configuration file
unset($CFG);global $CFG;$CFG = new stdClass();
$CFG->dbtype    = 'mysqli';

$CFG->dblibrary = 'native';

$CFG->dbhost    = 'localhost';

$CFG->dbname    = 'moodle';

$CFG->dbuser    = 'root';

$CFG->dbpass    = '';

$CFG->prefix    = 'mdl_';

$CFG->dboptions = array (  'dbpersist' => 0,  'dbsocket' => 0,);
$CFG->wwwroot   = 'http://xxx.xxx.xxx.xxx/moodle';

$CFG->dataroot  = 'C:\\xampp\\moodledata';$CFG->admin     = 'admin';
$CFG->directorypermissions = 0777;
$CFG->passwordsaltmain = '7_TuLJal*c<zh?XI9=4PNfXV~U';
require_once(dirname(__FILE__) . '/lib/setup.php');
// There is no php closing tag in this file,// it is intentional because it prevents trailing whitespace problems!
********************************************************************************

After this please Restart your xampp server

 
Average of ratings: -