Hi Paul, Martin,
sorry not to have responded earlier.
There was a problem with this error message a few weeks ago:
But as you have found, it is fixed in the latest releases of the HotPot module.> Gordon ... may want to post the update to the modules download page for others who are running vers. 1.7 or 1.8.
Do you mean the download
page for Moodle modules and plugins? That has two versions of the HotPot module, one for Moodle 1.6 and one for the Moodle 1.9. I don't think there is a download intended for Moodle 1.7 or 1.8. Hmm ...
I am bit worried that you have not installed the correct version of the HotPot module for you site.
Since the the HotPot module is part of the standard Moodle package, the recommended way to update it is to update your entire Moodle site. If you cannot update your whole site, or do not wish to, then you should download an entire Moodle package to your PC, unzip it, extract just the "mod/hotpot" folder, and upload that to your Moodle site.
The HotPot downloads on the Moodle Module and Plugins downloads pages are only really intended for people with Moodle 1.6 or earlier, or rash daredevils (and developers!) who run the "development" branch of Moodle, sometimes called the "head" branch. One day this will become a stable version called Moodle 1.9, but for the time being I recommend you stick with downloading a stable Moodle package, and using the "mod/hotpot" folder from there.