General help

Uploaded file exceeded the maximum size limit set by the server,

 
 
Picture of Arnel Pastrana
Uploaded file exceeded the maximum size limit set by the server,
 
Hi,

I didn't do any update on my server, before i don't have any problem this is the first time i encounter this error: Uploaded file exceeded the maximum size limit set by the server, I cant upload anything even the filesize is just 2kb.

Any body who experience this please? I have tried all some tips on this lists.

Looking at my phpinfo:
memory_limit 400M 400M
upload_max_filesize 400MB 400MB

Thanks in advance.

Arnel
 
Average of ratings: -
Picture of Ken Wilson
Re: Uploaded file exceeded the maximum size limit set by the server,
 

Hi Arnel

The value of the php variable "memory_limit" should not effect the size limit on uploads. Instead the php settings which need changing are: upload_max_filesize and post_max_size. Check also that the value of LimitRequestBody in your apache httpd.conf. See this in the admin FAQ for more details.

Ken

 
Average of ratings: -
Picture of Cagdas Essiz
Re: Uploaded file exceeded the maximum size limit set by the server,
 
Hey arnel,

I had the same problem. I don't know exactly what the problem is but i guess its related to recent windows update, since i didn't update my moodle installation, neither my php installation nor my mysql installation.

I've just converted megabyte values in my php.ini file to bytes. And now its working as it used to be. I hope this helps.
 
Average of ratings: -
Picture of Ekachai Singthong
ตอบ: Uploaded file exceeded the maximum size limit set by the server,
 

Hi Arnel

I have this error too. It's occured after I move Moodle site from Windows 2003 Server to Windows 2008 Server. I follow Cagdas Essiz sugguestion but not solved. I try to change system config, 'Maximum uploaded file' at Security > Site Policies page from 'Server Limit' To 50 MB then it work.

My Moodle site is 1.9.x version.

 
Average of ratings: -