General help

Parse error

 
 
Picture of W Page
Re: Parse error
 
Hi Dale!

I do not think that students are notified when assignments are graded. It would be a nice feature to have (by teacher choice) however. Also, it would be nice to be able to also have e-mails sent to parents (again by teacher choice) when assignments are graded.

The Moodle programmers seem to be tied up in the MyDMS feature for now. Maybe we can ask them about adding this to Moodle after they finish with that project.

WP1

 
Average of ratings: -
Picture of Dale Jones
Re: Parse error
 
Hi WP;
If I read it correctly, the FAQ entry for "email from forums" suggests that emails are provided for assignments.  Looking at the lang/en/assignments.php lines 7-12 the code seems to suggest that also (but I'm no understander of code!). 
I still can't get it to work though - still that parse error.  I'm going to check all the en files to see if one of them has a problem.


 
Average of ratings: -
Picture of Dale Jones
Re: Parse error
 
FWIW, forum emails are sent out properly. It seems to be just assignments and journals that are giving a fault...unfortunately I don't know any php to be able to check the en/assignment and en/journal.php for possible errors.
I just copied them from cvs, having firstly deleted the old en directory. It's still driving me nuts.
EDIT  - The plot thickens; I was wrong, the assignment email is sent out, but it has no content.  It simply has this:

CW1 Home ->Assignments ->Upload your database





It doesn't look like the journal emails are getting sent though.



 
Average of ratings: -
Picture of W Page
Re: Parse error
 
This is all so confusing!

WP1
 
Average of ratings: -
Picture of Daniel Mikšík
Re: Parse error
 
I had a similar problem. In my /lang/en/assignment.php file I had this:
$string['assignmentmailhtml'] = '$a->teacher has posted some feedback on your
assignment submission for \'<i>$a->assignment</i>\'<br /><br />
You can see it appended to your <a href="$a->url">assignment submission</a>.';
What removed the parse error for me was adding backslahes into the anchor tag on the third line:
<a href=\"$a->url\">assignment submission</a>.

Hope this helps.
Dan

P.S. The original version is still in the CVS, so no help getting the latest CVS.
 
Average of ratings:Useful (1)
Martin Dougiamas
Re: Parse error
Group DevelopersGroup Documentation writersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers
Thanks, Daniel - fixed in CVS and soon Moodle 1.2.1.
 
Average of ratings: -