General help

 
 
Picture of Gary Mayer
Your session has timed out. Please login again.
 
I downloaded and installed the latest 1.5.4 version of Moodle eariler this week.  A New install on a Windows desktop.  I worked with the package several times over the last few days, read the documentation and even started to create a course.

Suddenly this morning, I was unable to login to the system with any of the users, including 'admin'.  The message on the login page states "Your session has timed out. Please login again."  I've spent the day reviewing this forum, checked Google for other references and have failed to find an answer.

Has anyone found a way to get past this problem?  The solutions presented in other forums (clear cookies, etc.) haven't worked and many of the posts were from late last year.

This is a very nice system and any help would be appreciated.

Thanks in advance.
 
Average of ratings:Useful (1)
Picture of Simon Bryan
Re: Your session has timed out. Please login again.
 
As the only way Moodle knows about the length of your login is via cookies, this is almost certainly a cookie problem. This does happen to me on a regular basis (say once a week) and clearing the cookies always works. However you need to close the Moodle page, clear all cookies and restart the browser.
In firefox you can select just the cookies related to the moodle server, not sure in IE. However in IE you can clear the cookies with the browser closed from Internet Options in the Control Panel.
What browser are you using?
What was the exact sequence you used to clear the cookies and attempt to login again?
What about logging in from another machine?
 
Average of ratings: -
Picture of Winn Griffin
Re: Your session has timed out. Please login again.
 

Hi Simon,

I have experienced the problem of being locked out from logging in with the message "Your session has timed out. Please login again" I cleared all the cookies. I even used another browser. And of course students at a distance are have the same problem.

So is there another solution? One solution from a major university that had the same problem was that they had to blow Moodle off and reinstall.

I hope that's not the only solution. smile

 
Average of ratings: -
Picture of Petr Škoda
Re: Your session has timed out. Please login again.
Group DevelopersGroup Documentation writersGroup Moodle HQGroup Particularly helpful Moodlers
Hi!

First check your moodledata/sessions directory. New file should be created after first access from browser. If they do not appear, fix your permissions.

skodak
 
Average of ratings: -
Picture of Winn Griffin
Re: Your session has timed out. Please login again.
 

Thanks Petr,

I am rather new to all this: I could not find the folder you refered to.

I did find a sessions folder here:

/ public_html / web / moodle / uploadata / sessions /

All the files were set to 600.

There are about 20 of them. There are no dates to discover when they were created.

BTW: The site has been running for about a year with no problems, out of the clear blue this problem appears.

Thanks
Winn

 
Average of ratings: -
Not a PHM :-)
Re: Your session has timed out. Please login again.
 

Just a shot in the dark here, but I have experienced a similiar problem after setting up a second moodle install with the same sessioncookie in Moodle config. If you have installed a second copy of Moodle recently you may want to log in as the admin and go to configuration/variables and make sure you have different sessioncookie names in each install.

Again, just a long shot...

Steve

 
Average of ratings: -
Picture of Winn Griffin
Re: Your session has timed out. Please login again.
 
Thanks, but only one moodle install.
 
Average of ratings: -
Picture of Winn Griffin
Re: Your session has timed out. Please login again.
 
I have no idea how, but the CHMOD of the data file was not correct. I changed it to 777 and now I am able to log in.
 
Average of ratings: -
Picture of Janice Abernethy
Re: Your session has timed out. Please login again.
 
I am having the same problem!!!! I have wasted a day trying to figure it out. I only have one version running, my data file is set to 777, I have cleared cookies, I have tried it on several computers...Now what???? I haven't used the program in quite a while, but I never had this problem before. If I reinstall, will I lose my courses??? Please help.
 
Average of ratings: -
Picture of Sailaja Praharaju
Re: Your session has timed out. Please login again.
 
did anybody helped you in your case? I am also having the same issue. If you got the solution can you shre the same with me?
 
Average of ratings: -
Picture of Simon Bryan
Re: Your session has timed out. Please login again.
 
Have had the problem on a number of occassions, deleting cookies HAD always worked. Today it didn't, then I remembered that I had set the sessions to be in the database rather than as a cookie, so I made sure no one was actually logged in and then deleted all the records in the sessions table in the database, I could immediatley login again. What had been frustrating was that i could login as any user except Administrator in Firefox,  but in IE I could login as Administrator quite OK.
So some suggestions:
1. If you are using database sessions, use MySQL COntrol centre or some other utility and delete the records in the sessions table in the database, the worst that should happen is that logged in users would be logged out.
2. Try logging in with a different browser, if you can try changng the 'session' method. There may be a way to do this without logging in by going to the command line on the server, but I don't know it.
 
Average of ratings: -
Picture of matthew wykoff
Re: Your session has timed out. Please login again.
 
I have tried

1)deleting cookies
2)deleting sessions
3)restarting firefox browser
4)using another browser (safari)
5)checking server space (i have plenty left)

Nothing seems to work regarding , "Your session has timed out. Please login again."

Please offer guidance.
 
Average of ratings: -
Picture of Andrew Igbo
Re: Your session has timed out. Please login again.
 

I’ve been having this problem for a while and the only way I’m able to resolve it “temporarily” is to delete all the files in the Moddle “sessions” directory; needless to say, this has become a very frustrating situation. I have set the “sessions” directory permission to 777 as well as tried all the other suggestions in this forum and none seems to bring a permanent solution to this problem…anything else I should try?

Thanks

 
Average of ratings: -
Picture of Kevin Miller
Re: Your session has timed out. Please login again.
 
We just had the same problem and our solution was that the MoodleData directory was over the quota that was alotted. We are increasing the quota in hopes that it will work.

 
Average of ratings: -
Picture of Ashish Namdeo
Re: Your session has timed out. Please login again.
 

Same was the case with us after backup file filles the disk space... removed all unwanted files to have some space and things gets started working again.

Team EddyTools

http://www.eddytools.com

 

 
Average of ratings: -
Picture of Jennifer LaVoie Constant
Re: Your session has timed out. Please login again.
 

This JUST started happening to us about 2 weeks ago

sometimes deleting cookies helps, sometimes not...what's goig on?

my moodle data dir is set to 777...

this is making our school very unhappy and really messing with courses sad

 
Average of ratings: -
Picture of Deborah Bell
Re: Your session has timed out. Please login again.
 

Same problem here.... everything was working perfectly till last night.

We run:

  • Moodle 1.71
  • mysql version 5.0.24
  • php version 5.2.1
  • IE 6.0

Per the multiple emails in both this forum and the Bug Tracker, I followed all suggestions and sequentially:

  1. Navigated to a non-"My Moodle" site, then cleared all cookies from the browser
  2. Closed out the browser
  3. Ensured Moodledata permissions were 777
  4. Cleared all session data from my Moodledata file; and - just for good measure - cleared out the temp files
  5. PHPAdmin'd to my SQL dbase and changed my dbase sessions to yes (1)
  6. Opened my browser and navigated to my root; then chose "Login"

I can now login. All that being said, I'd really rather not make this a regular part of my unplanned maintenance activities.

To echo Ms. Constant, "What's going on?"

 
Average of ratings: -
Picture of Jari Järvelä
Re: Your session has timed out. Please login again.
 

Same problem here also. Started yesterday. I tried all the things Deborah suggested and still I cannot login. Firefox and Opera works fine, but IE 7 and 6 gives the error message in login. The version of the Moodle is 1.6.4.

 
Average of ratings: -
Picture of Ilídio Vicente
Re: Your session has timed out. Please login again.
 
Had the same problem after a server crash and restore.
Solved by changing ownership of the session directory to apache:

chown apache:apache /yourdir/moodledata/sessions

That's all it took and it looks like everything is working fine now. sorriso
 
Average of ratings:Useful (1)
Picture of Evan Whitaker
Re: Your session has timed out. Please login again.
 

This sounds promising.  I have to confess that I don't know how to change the session directory ownership as you described.  Could you please offer more detail on how to do that?

 
Average of ratings: -
Picture of Dave Kichler
Re: Your session has timed out. Please login again.
 
chown apache:apache /path/to/directory

you may want to include the -R option to recurse the directory as well (chown all dirs under that dir as well)
 
Average of ratings: -
Picture of Milan Antonijevic
Re: Your session has timed out. Please login again.
 

chown command is supposed to be issued from linux command line, aka console.
There is no way (that I'm aware of) to do it using FTP.
And another problem, if you are using windows hosting, then you can forget about file/folder ownership, and concentrate on read/write permissions.

 
Average of ratings: -
Picture of Raymond Wilhite
Re: Your session has timed out. Please login again.
 
THANK YOU, THANK YOU, THANK YOU!!!!!
We had the same problem (user received "Your session has timed out. Please login again." and when they logged in it asked to login again if incorrect password was used but was taken back to the "front page" with "you are not logged in" if correct pw was used) when we restored the moodle and moodledata files from a back up copy to a new install of RHEL5 64bit (we were on 32bit but had to install new drives for space so figured I would go 64bit while I was at it).
I spent the better part of the day (and now late evening) looking for this fix. I knew it was a file permissions issue but I did not know which file/s (I also had to change the ownership of the /usr/moodledata/moodle01/temp directory along with the 'sessions' directory). Once I chown'd the files for apache all appears well...
Running Moodle 1.9.8+ (Build: 20100407) from two (applications server and DB(Mysql)) servers.

Regards,
R. A. Wilhite
 
Average of ratings: -
Picture of Robert Killinger
Re: Your session has timed out. Please login again.
 
I had the same problem. For some reason when I copied over the Moodle data directory the permissions were changed from 777 to something else for the main Moodle data directory and for all the sub folders in that directory. It did not take that long but I had to change each folder to 777. You can do this in the command line, but I did it by using filezilla.
 
Average of ratings: -
Picture of theo pielage
Re: Your session has timed out. Please login again.
 

We were having the same problem "Your session has timed out. bla bla"

Write permissions of sessions-directory were OK, and each time someone tried to log in a file was written into this directory BUT the files were 0 bytes. Problem: disk quota on the server exceeded! Thrown away some files and now everything works fine again.

Theo Pielage

 
Average of ratings:Useful (1)
Picture of J m
Re: Your session has timed out. Please login again.
 
Can I delete the 0 kb sessions?
 
Average of ratings: -
Picture of prachi mozar
Re: Your session has timed out. Please login again.
 
yes but let it be...
 
Average of ratings: -
Picture of xavier colomes
Re: Your session has timed out. Please login again.
 

I had the same problem.... the problem was that the disk was full

Just check if you have enought space in the disc

 
Average of ratings: -
Me
Re: Your session has timed out. Please login again.
 
Two of us had been scratching our heads with this one this morning but we had the same problem as Xavier and Theo: disk was full. It's well worth checking this (because it isn't obvious) before starting to worry about permissions, &tc. - especially on a site that has been working perfectly happily previously.

Cheers,

Ian.
 
Average of ratings: -
Picture of Greg Baskind
Re: Your session has timed out. Please login again.
 

I had this problem multiple times on my first attempt at installing and configuring Moodle via Fanastico on Cpanel. Every navigation required re-login. So I wiped the install and started again. On my third install, I was able to get everything working just fine. I created a Course with one topic and a Powerpoint converted with PPT2Flash Wondershare works well, However..f

My second course has a Sessions problem. This course is a Topic list of 6 Links to Resources (media files wmv and jpgs)

Admin steps:
Added Course
    Topics Format
      6 Topics
Links to Resources
Pressed Upload File button.
Make Folder
FTP uploaded files into correct folder
Choose (chose) the specific file for each Topic.

User Steps:
User login ok. Enroll and view course ok.
User clicks on Linked Resource link,
User watches Resource view.php. User presses Jump to Next Topic arrow.

Your session has timed out. Please login again.

The user is forced to login again in order to continue to the next link.
Permissions are 777 for data folder and sessions folder.
Going to find the code behind Jump object and try to trace.
Here's a scrape of the code from Firebug inspect....
<html lang="en" xmlns="http://www.w3.org/1999/xhtml" dir="ltr" xml:lang="en">
<head>
</head>
<body id="mod-resource-view" class="mod-resource course-2 dir-ltr lang-en_utf8 notinpopup nolayouttable">
<div id="page">
<div id="header" class="wrap wraplevel1">
<div id="header-bt" class="bt">
</div>
<div id="header-i1" class="i1">
<div id="header-i2" class="i2">
<div id="header-i3" class="i3 clearfix">
<h1 class="headermain">6 ss Demonstration Videos </h1>
<div class="headermenu">
<div class="navigation">
<ul>
<li>
</li>
<li>
<form id="navmenupopup" class="popupform" method="get" action=http://theip/moodle/course/jumpto.php>
<div>
<select id="navmenupopup_jump" onchange="self.location=document.getElementById('navmenupopup').jump.options[document.getElementById('navmenupopup').jump.selectedIndex].value;" name="jump">
<optgroup label="Topic 1">
<option style="background-image: url(http://theip/moodle/mod/resource/icon.gif);" selected="selected" value="Jump">http://theipp/moodle/mod/resource/view.php?id=5 to...">Jump</option>
</optgroup>
<optgroup label="Topic 2">
</optgroup>
<optgroup label="Topic 3">
</optgroup>
<optgroup label="Topic 4">
</optgroup>
<optgroup label="Topic 5">
</optgroup>
<optgroup label="Topic 6">
</optgroup>
<optgroup label="Topic 7">
<option style="background-image: url(http://theip/moodle/mod/resource/icon.gif);" value="http://theip/moodle/mod/resource/view.php?id=18">TestImage</option>
</optgroup>
</select>
<input type="hidden" value="Ni8nKmOjhx" name="sesskey"/>
<div id="noscriptnavmenupopup" style="display: none;">
<input type="submit" value="Go"/>
</div>
<script type="text/javascript">
1
2//<![CDATA[f
3document.getElementById("noscriptnavmenupopup").style.display = "none";
4//]]>
5
</script>
</div>
</form>
</li>
<li>
</li>
</ul>
</div>
</div>
<div class="navbar clearfix">
</div>
</div>
</div>
</div>
<div id="header-bb" class="bb">
</div>
</div>
<div id="content" class="wrap wraplevel1">
<div id="content-bt" class="bt">
</div>
<div id="content-i1" class="i1">
<div id="content-i2" class="i2">
<div id="content-i3" class="i3">
<div class="resourcecontent resourcewmv">
</div>
<img class="spacer" width="20" height="20" alt="" src="http://theip/moodle/pix/spacer.gif"/>
<br/>
</div>
</div>
</div>
<div id="content-bb" class="bb">
</div>
</div>
<div id="footer" class="wrap wraplevel1">
</div>
</div>
<script type="text/javascript">
</script>
</body>
</html>
Note this piece of code in the bottom of the list of combobox elements(optgroup):
<input type="hidden" value="Ni8nKmOjhx" name="sesskey"/>
Form is sending sesskey: Ni8nKmOjhx
But if the browser queries my cookie on that page:
MoodleSession=3816a46496d8e36e3228341c1bc9c9ab; >>>>>>MoodleSessionTest=MGAGiJ8Zbj;
MOODLEID_=%25E4%25DE%251BK%25B1%257C"
User cookie is sending: MGAGiJ8Zbj
It's not the same.
Why?
 
Average of ratings: -
Picture of Rod Peters
Re: Your session has timed out. Please login again.
 
Our technician's best guess is.... I found a setting in PHP - session.gc_maxlifetime – which determines how long a session will last.

Worth a try.....
 
Average of ratings: -
Picture of HK Ra
Re: Your session has timed out. Please login again.
 

I had same problem. I had moodle site was running but all the courses were gone.

One thing I had to do was reboot the server and our school server admin ran the fsck(i think it stands for file system check?).  After that it some how fixed everything. Eventhough, I don't think disk fault would hve caused anything.

So try to reboot your server and if it asks to run the fsck do it so.

 
Average of ratings: -
Picture of Jesus Moreno
Re: Your session has timed out. Please login again.
 
I was able to evaluate the problem in my server and had to repair the sessions field in the database. Once I repaired the table I had no more problems loggin in. This, thankfully, saved me a complete re-install of my moodle instance. Hopefully this helps someone else.
 
Average of ratings: -
Picture of Stephen Raisz
Re: Your session has timed out. Please login again.
 
We just had similar problem after moving to a new server. Here's the steps that fixed it:

1) Deleted all files in moodledata/sessions
2) chmod 777 moodledata/sessions



 
Average of ratings: -
Dave T
Re: Your session has timed out. Please login again.
 
Seems this problem prevails in 1.98 as well. Getting pretty aggravating as nothing above seems to ever really fix the issue. Our site is intranet loaded but no one has access any longer. Dev.. please fix this bug, please.
 
Average of ratings: -
Picture of HJWUCGA INC.
Re: Your session has timed out. Please login again.
 

What were your settings for session timeouts?

Do you have a proxy/load balancer/cache server in front of moodle that may be overidding your moodle settings?

 
Average of ratings: -
Dave T
Re: Your session has timed out. Please login again.
 
It appears this was a space issue. Anything under 100MB of free space and it would choke and not accept log ins. Thank you to all who replied.
 
Average of ratings: -
Picture of HJWUCGA INC.
Re: Your session has timed out. Please login again.
 
That was going to be my next hunch .. space issues
 
Average of ratings: -
Picture of Rachna Pattnaik
Re: Your session has timed out. Please login again.
 

Hello everyone ! Hope I'm posting this msg in the correct forum,but I'm trying to install moodle using Rediff web hosting.Here goes the steps I followed while installing :

1. Dowloaded a standard package from downloads secn in moodle.org.

2. Extracted the moodle folder from it.

3. Uploaded the contents of the folder on the server.

4. Created a new database(My sql ofcourse !).

5. After all done, I tried opening the site,providing the URL :  http ://mydomain.com/moodle .

6. Everything was fine and I was redirected to get on with the installation.But.....

I got an error message that Data directory was not found(something like that...)

Tried solving that problem by manually creating a "moodledata" folder outside my website's folder,gave it all pemissions(777).Did a little bit changes in the config.php file:

 $CFG-> dataroot : 'moodledata'.

And tried installing again with the data directory path as "moodledata" only and nothing else. I think this is the point to be noted while finding what went wrong.

BUT I was allowed to continue with the installation,upto the step of agreeing with the Terms&conditions .

After this,I was expecting to be redirected to the page where I can Set-up the administrator's account.But instead I was taken to the "index.php" page with a message "Your session has timed out. Please login again". And I can do nothing further !!!!!

I'd tried installing the whole thing with new database and all. But nothing worked.I'm new to moodle.Can't figure out what created the mess... What went wrong? Kindly,someone help me out regarding this.

 
Average of ratings: -
Picture of Thomas Robb
Re: Your session has timed out. Please login again.
Group Developers
Hello Rachna,

To give you a concrete example, this is how my dataroot and dirroot are specified:

$CFG->dataroot = '/home1/langconc/moodledata'

$CFG->dirroot = '/home1/langconc/public_html/moodle


If your dirroot is specified correctly, then you should be able to set up your moodledata specification in a manner parallel to the above example.

This is probably the cause of your "timed out" message because data concerning current logins is kept within the moodledata folder and it was not accessible.

Hope this helps!

--Tom Robb
 
Average of ratings: -
Picture of Rachna Pattnaik
Re: Your session has timed out. Please login again.
 

Thanks for the quick response Thomas ! smile

 Moodledata folder was given full access permissions,as I'd mentioned.

My actual concern is about why i'm not given to create the admin account and instead redirected to the login page with a timed out message.

Doing the same thing locally,we generally create the admin account first,and then move on for further proceedings. Isn't the procedure same for installing moodle on web?

 
Average of ratings: -
Ralph
Svar: Re: Your session has timed out. Please login again.
 

I meet the same problem as  Rachna, But your tip did not help!

My datroot is: ' myurl_name'

And my dirrot is:'myurl.name/moodledata/moodle-weekly-19/moodle'.

Is ther annyone who can help?

I have tried to change permissions and lots of tips found here but not yet made it run.

Running on One.com webhost

 
Average of ratings: -
Banana!
Re: Svar: Re: Your session has timed out. Please login again.
 

I had a lot of cookie problems with my site because there was an underscore character in my subdomainname. This problem only manifested itself when trying to login with Internet Explorer 7, not in other browsers. The warning I got was "Unfortunately, cookies are currently not enabled in your browser".

So

test_test.example.com did not work

while

testtest.example.com did work

 

Pretty strange but I've pinned this down exactly, having two identical installs on two identically configured subdomains (except for the name ofcourse).

The problem I came across with the error "Your session has timed out. Please login again." I solved setting the permissions on the moodledata folder and all files in them to 777. There's probably a better setting for this, but in my case the moodledata folder was outside of the public folder, so there was no problem.

 
Average of ratings: -
Picture of Walter Horowitz
Re: Svar: Re: Your session has timed out. Please login again.
 

My understanding is that the underscore character is technically invalid for DNS based host names.

What are the valid characters for a domain name and how long can it be ?
When choosing the name for your domain, always remember that: - you *can't* use stressed vowels (such as à, é, ò, etc.); - you *can't* use symbols (such as ' + . , | ! " £ $ % & / ) ( = ? ^ * ç ° § ; : _ > ] [ @ ); - the name's length must range between 3 and 63 characters (excluding the extension); - the name can neither start nor end with the character "-", although the character "-" is allowed inside the name. So, to name your domain you can use any letter, numbers between 0 and 9, and the symbol "-". .

Length may vary, from 3 to 63 types.

For domain names registered under the geographical structure, the limit is between 1 and 63 types.

 
Average of ratings: -
Picture of Alexander Ufimtsev
Re: Your session has timed out. Please login again.
 

Got this error recently when migrating moodle to another machine. In my case the problem was solved by deleting 'sessions' directly completely and recreating it. Cleaning it of files & setting correct permissions didn't seem to help :-\

 
Average of ratings: -
Picture of David Rankin
Re: Your session has timed out. Please login again.
 

I had exactly the same thing. Was not able to create the sessionvariables

I was on a shared server - Said I ran out of disk space, but actually I had too many iNodes. 

All I did was delete my old files and folders

Here is the documentation from my isp

http://kb.siteground.com/how_to_reduce_the_number_of_inodes_my_account_uses/

Hope this helps someone else

 
Average of ratings: -