Time is an issue.
I installed another machine to work from and made a successful back-up of my server fully working DB and all.
I have Moodle 2.7.2 on an old server and am trying to upgrade to 3.10.
That is not even a problem because I cannot upgrade to Moodle 3.1 or 3.2.
#.2 demands php 5.6.5 when all I see to install is 5.5.41. It will not run on php7.07.
I built php 5.6.5 and php -v says it is there but it seems Apache does not know this as phpinfo says 5.5.41 also.
I went to Moodle 3.1. It demands: version 5.5.31 is required and you are running 18.104.22.168.0.35 <- A slightly new version kills it?
I am trying to find a way to downgrade mysql now to see if it will work.
What fun will I have moving from 3.1 or 3.2 to 3.5? Then to 3.10?
I have a new machine built with a newer version of OS ( opensuse 15.1 if it makes a difference )
I don't want to loose all of my data and work on my present server. If I have to manual re-enter content, courses and users .....
I love Moodle but I need help.
There has to be a better way to up-grade.
I don't mind setting up 2.7 -> 3.1 -> 3.5 -> 3.10 but the requirements seem like rare finds.