Problemas com a instalação do Moodle

Problemas no config.php

 
Fotografia de nadir afonso
Problemas no config.php
 

Estou com um problema. Instalei o moodle num pc da rede da escola que acede à internet via router. Como não possui IP público configurei o router para redireccionar os pedidos vindos do exterior para o pc em causa. Tudo funciona corectamente. Mas.... quando tento aceder de um outro pc da rede (interna) o Moodle aparece desconfigurado e nada funciona.

De outra forma...

se configurar    $CFG->wwwroot = 'http://nadir.gotdns.com/moodle';

funciona do exterior .

Para funcionar do interior  tenho de alterar para

$CFG->wwwroot = 'http://pc_x/moodle';

Não há maneira de ter a funcionar sem ter de alterar?

É importante que funcione das duas formas de acesso.

De um principiante com vontade de aprender

 
Nota média:  -
Fotografia de Alexandre Martins
Re: Problemas no config.php
 
Olá!

Na minha escola tive exactamente o mesmo problema.
Solução:
    configurou-se o router para reencaminhar todos os pedidos para torga.essr.net:8080 para a máquina onde estava instalado o moodle (chamada torga dentro da rede local). Este máquina tb tem o apache (servidor web)
Depois como me surgiu o problema que da rede local não dava, a solução foi configurar o apache para "escutar" na porta 8080. No ficheiro httpd.conf acrescentei:
    Listen 8080
e passou a funcionar direitinho.

Já agora: como o router foi a FCCN que instalou a configuração acima referida foi pedida à FCCN.

Espero ter ajudado.

Cumprimentos,
Alexandre Martins

--
Alexandre Martins
----------------------------------------------
Grupo Disciplinar de Informática
Departamento de Ciências Exactas
Escola Secundária Artística de Soares dos Reis
----------------------------------------------
http://www.essr.net/
Moodle: torga.essr.net:8080