Assistance technique

Problème d'Affichage avec adaptable et moodle 3.6

 
mon avatar
Problème d'Affichage avec adaptable et moodle 3.6
 

Bonsoir à tous

sur notre serveur de test on vient d'installer la version 3.6 de moodle et avons aussi installer le version 1.7.3 de Adaptable.

au niveau des blocs il y a un soucis d'affichage (voir images) avec des superpositions sur les boutons ou liste déroulante, toutes les sous fenêtre s'affiche au même moment d'ou chevauchement de celles ci.

Bloc chronologie

clcs1

Bloc vue d'ensemble

closn

j'ai tous simplement supprimer les deux blocs en attendant de trouver une solution.

Quelqu'un est déjà tombé sur ce cas ?

Merci à tous

 
Moyenne des évaluations  -
mon avatar
Re: Problème d'Affichage avec adaptable et moodle 3.6
 

Bonjour

Dans le forum Anglais des thèmes. ils m'ont proposé d'attendre la version de adaptable pour la 3.6 !

https://moodle.org/plugins/pluginversions.php?plugin=theme_adaptable


Merci à tous

 
Moyenne des évaluations  -
Avatar Pierre-Jean Chancellier
Re: Problème d'Affichage avec adaptable et moodle 3.6
 

Le problème a été corrigé il y a 24h suite à un ticket auquel j'avais apporté une réponse ;)
https://bitbucket.org/covuni/moodle-theme_adaptable/issues/968/fix-dropdowns-in-new-blocks-for-m36

 
Moyenne des évaluations Utile (1)
mon avatar
Re: Problème d'Affichage avec adaptable et moodle 3.6
 

merci

 
Moyenne des évaluations  -
mon avatar
Re: Problème d'Affichage avec adaptable et moodle 3.6
 
Je viens d’essayer d'appliquer le correctif indiqué dans le lien  a savoir :  .dropdown-menu { display:none; }

mais dans la pratique j'ai problème ! 

es qu'il faut ajouter la ligne  .dropdown-menu { display:none; } dans le fichier adaptable.css ?

la je viens de le faire mais il n' ya aucun changement !

je pense que je me trompe de fichier ou de procédure.

Pouvez vous m'aiguillez ?

Merci

 
Moyenne des évaluations  -
mon avatar
Re: Problème d'Affichage avec adaptable et moodle 3.6
 

finalement en cherchant je suis tombé sur le bon fichier : en l’occurrence menu.css :

j'ai juste ajouter display : none; à la fin.

.dropdown-menu {

    border: 1px solid #c0c0c0;

    border-radius: 0;

    font-size: setting:menufontsize;

    top: 40px;

    background-clip: padding-box;

    background-color: #fff;

    display: block;

    float: right;

    list-style: outside none none;

    margin: 2px 0;

    padding: 5px 0;

    position: absolute;

    right: 0;

    min-width: 250px;

    top: 26px;

    z-index: 1000;

    border-radius: setting:navbardropdownborderradius;

    display:none; 

}

Mais a la lecture du signalement du bug (anglais moyen), I've just fixed it in a way to make sure the dropdown CSS in Adaptable only applies within the navigation bar. 

je crois comprendre que le problème a été résolu plus proprement, reste peut être à télécharger la dernière version de menu.css ? (à confirmer)

Merci a tous

 
Moyenne des évaluations  -
Avatar Pierre-Jean Chancellier
Re: Problème d'Affichage avec adaptable et moodle 3.6
 

Oui tu peux télécharger la dernière version du menu.css. Sinon, tu aurais vu la correction précise en regardant dans l'avant-dernier commit ;)

 
Moyenne des évaluations Utile (1)
mon avatar
Re: Problème d'Affichage avec adaptable et moodle 3.6
 

Très intéressante et utile.

Merci

 
Moyenne des évaluations  -