Moodle for mobile

Link

 
Beat Ziörjen
Link
 

Hi

my installed moodle version is 3.5.2, the app is conected via sso which works fine.

if i enter in a moodlle course a link to youtube and watch this in the mobile app this works also fine.

now to the problem.

I have following link https://mediapool.coffeelinkng.schaerer.com/WMF/VideoHandler.View.php?ID=34008 

if I use moodle desktop, in crome and in a second browsertab i'm allready connected to the "Mediapool link" with User and password, then this work fine.

if i use the moodle mobile app  and in safari  on ios 12 and in a browsertab i'm allready connected to the "Mediapool link" with User and password, then the link out of moodle mobile opens a new safari tab were access is "not allowed".


any idea is welcome


best regards

beat


 
Average of ratings: -
Picture of Dani Palou
Re: Link
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

Hi Beat,

please try the following:

  • Copy the link in your OS device (you cannot copy it in the app, you'll have to copy it in browser).
  • Open a new Safari tab manually.
  • Paste the URL and open it. Check if you have access or not.

If you have access in this new tab, try again with the app. The app should do exactly the same as the process I explained above.

If you don't have access in this new tab then I guess it's a limitation of the page you're loading, maybe it is for security reasons.

Kind regards,

Dani

 
Average of ratings: -
Beat Ziörjen
Re: Link
 

Dear Dani,

Thanks for your answer.

I tested on the iPad the senario in Safari mobile as you described it, unfortunately it's not working.

but it works with google crome mobile.


so it has to be a setting in Safari, do you have any idea what setting could couse this?

and will it then also work out of the moodle app? then only this is the gool, if my studends cant use the links i put in for them - then it's useles.

looking forward to your answer,


best regards


beat

 
Average of ratings: -
Picture of Dani Palou
Re: Link
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

Hi Beat,

I don't know much about Safari iOS. I just did a couple of checks in iOS 12, maybe the settings are a bit different depending on your iOS version:

  1. In Safari, click a button with 2 squares (in iPad is in the top right, next to the button to open a new tab), it should display the tabs that you have opened. Check that the "Private" text is not selected.
  2. Go to device Settings and select the Safari option. Check that "Block all cookies" is disabled.

Kind regards,

Dani

 
Average of ratings: Useful (1)
Beat Ziörjen
Re: Link
 

Dear Dani,

thanks for your feedback, that's it.

best regards 

beat

 
Average of ratings: -