Security announcements

MSA-18-0018: QuickForm library remote code vulnerability (upstream)

 
Picture of Michael Hawkins
MSA-18-0018: QuickForm library remote code vulnerability (upstream)
 

A security vulnerability was reported against QuickForm, a third party library used by Moodle. Although no attack vector was identified within our software, Moodle has updated to patched versions of QuickForm as a precaution.


Severity/Risk: Minor
Versions affected: 3.5 to 3.5.1, 3.4 to 3.4.4, 3.3 to 3.3.7, 3.1 to 3.1.13 and earlier unsupported versions
Versions fixed: 3.5.2, 3.4.5, 3.3.8 and 3.1.14
Reported by: Dan Marsden
CVE identifier: CVE-2018-1999022 (PEAR HTML_QuickForm)
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-62947
Tracker issue: MDL-62947 QuickForm library remote code vulnerability (upstream)