Teaching with Moodle

Active Links in Test

 
Picture of Jamie Canterbury
Active Links in Test
 

I am new to this community, but am looking forward to getting some help and assistance from fellow Moodle users.   I am having trouble with active links appearing in my tests.  for Example, I posted a file called lobes on my course site and then when I was previewing my test, I noticed that the word lobes appears in blue and if the students click it, it takes them to the file during the test.  Any suggestions on what setting to check?   

 
Average of ratings: -
Picture of S. kavita
Re: Active Links in Test
Particularly helpful MoodlersTesters

Hi Jamie,

The words are auto linked with some features enabled in Moodle. Below is the more detailed about it:

Auto-linking can be managed at different levels:

  • Site wide: it can be switched on/off by going to Site administration > Plugins > Filters > Manage Filters.
  • Moodle courses: it can be managed within individual courses from Course Administration > Filters
  • Resources & activities within a Moodle course: it can also be managed from within an activity or resource from Settings > [Activity name] Administration > Filters. This is useful for turning off auto-linking to glossaries for example in a quiz, when you don't want the answer to be revealed to the student via an auto-linked glossary term being present in a question.
  • Specific text : Within activities and resources certain text can have the auto-linking disabled by switching to HTML view and adding ''<span class=nolink>...</span>'' with the relevant content replacing the .... If you are using TinyMCE editor, there is a Prevent auto-linking button.
Find the more details about it here in Moodle docs: https://docs.moodle.org/35/en/Auto-linking
 
Average of ratings: Useful (3)
Picture of Jamie Canterbury
Re: Active Links in Test
 

Fixed the issue!    Thank you!  So helpful!

 
Average of ratings: -