Moodle for mobile

Unable to see Auto assign course in Mobile after user login

 
Picture of Anup Srv
Unable to see Auto assign course in Mobile after user login
 

Hi,

I am Unable to see Auto assign course in Mobile App after user login but able to see through webpages.

Please help me.


Thanks

Anup 

 
Average of ratings: -
Picture of Dani Palou
Re: Unable to see Auto assign course in Mobile after user login
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

Hi Anup,

let's see if I understood you right. You have a course that you can view in the web page (browser) but not in the Mobile app, right?

Is the user you're using enrolled in the course? 

Cheers,

Dani

 
Average of ratings: -
Picture of Anup Srv
Re: Moodle in English: Re: Unable to see Auto assign course in Mobile after user login
 
Dani,



Thanks for your reply.

I am explaining you steps by steps:;-



1. I created one Demo course and add auto enrollment method (by installing

plugin) in Demo Course.

2. When user register first time using mobile app and login on there app.

he is not able to see the Demo course. (In my Course section)

3) after then , user login using web ...he is able to see  see the Demo

course. (In my Course section)

4. when user login through mobile app after login web , they are able to

see demo course    (In my Course section)



I am unable to identified the issue .....?



Thanks

Anup





On 20 August 2018 at 16:09, Dani Palou (via Moodle.org) <noreply@moodle.org>
 
Average of ratings: -
Picture of Dani Palou
Re: Moodle in English: Re: Unable to see Auto assign course in Mobile after user login
Core developersMoodle HQParticularly helpful MoodlersPlugin developers

Hi Anup,

for some reason when a user self enrols in a course it takes a while for that course to appear in the list of courses for the user in the app (we detected that it can take up to 20 seconds). That's something that's caused by Moodle web.

When self enrolling in the app (using the core method), we usually show a loading modal and wait for the course to be displayed in the list of courses of the user before letting him continue using the app. You say you're using a plugin for the enrolment, I guess with that plugin the enrolment process is different and doesn't trigger this loading modal. Can you please try to wait a few seconds and then do a Pull To Refresh in the list of courses to see if the course appears in there after the refresh?

Kind regards,

Dani

 
Average of ratings: -