Moodle for mobile

Moodle Desktop App v 3.5 MacOS - won't accept my SSO credentials

 
Picture of Brian Warling
Re: Moodle Desktop App v 3.5 MacOS - won't accept my SSO credentials
 

Under mobile settings, "Type of Login" was set to "via an embedded browser (for SSO plugins)". It has been set like this since we began using the mobile app in August 2017. Accessing our Moodle site has worked fine in iOS, both before and after the mobile app 3.5 upgrade. It also worked fine using the desktop app, prior to the 3.5 upgrade (as I noted earlier). But since upgrading the desktop app to 3.5 (along with our recent upgrade to Moodle 3.4), the desktop app gives the "username you entered cannot be identified" error. So, with the "login via embedded browser" setting, we can log in on iOS, but not the desktop app (again, version 3.5).

I changed the login type setting to "via a browser window (for SSO plugins)". With this setting, I AM now able to log into our Moodle site on the desktop app (it sends me to my web browser to log in, then passes me back to the desktop app). Logging in on iOS also continues to work.

So the question seems to be why does mobile desktop app authentication work with the "via a browser window" setting, but not with the "via an embedded browser" setting? Prior to the desktop app update to 3.5, we were able to login via an embedded browser. I imagine there could be something about the way our campus authentication is set up that (now) prohibits login via an app's embedded browser. But I'm also wondering if there might be something different in the desktop app (3.5)?

Thanks... Brian

 
Average of ratings: -