Instalación y Actualización

Dos moodle en un mismo servidor

 
Imagen de Cristian Sepulveda
Dos moodle en un mismo servidor
 

Estimados

Tengo un moodle instalado que me funciona muy bien 2.9, estoy en proceso de instalar la última versión de esta plataforma pero no quiero perjudicar a la anterior, pues tengo muchos cursos funcionando en esta.

Al instalar la nueva version moodle 3.4 me aparece el siguiente mensaje "Moodle 3.4 or later requires at least PHP 7.0.0 (currently using version 5.6.36). Some servers may have multiple PHP versions installed, are you using the correct executable?

Mi pregunta es si se actualiza la versión PHP no afectará a mi moodle antiguo?

Muchas gracias

Saludos

 
Promedio de calificaciones: -
FOTOCARNET
Re: Dos moodle en un mismo servidor
Moodlers de gran ayuda

Si que te afectara.


Para tener los 2 moodle funcionando estarias obligado a tener las 2 versiones de PHP requeridas, se puede hacer, pero hay que configurar correctamente el servidor para poder tener dos instancias PHP y que cada uno ejecute desde su PHP particular.



 
Promedio de calificaciones: -
Imagen de Juan Pablo Miranda Aguayo
Re: Dos moodle en un mismo servidor
Moodlers de gran ayuda

Hola Cristian,

No nos dices dónde tienes instalado tu Moodle 2.9. Si lo tienes en un servicio hosting contratado o en un VPS o un servidor dedicado. Dependiendo del caso, cambia mucho el cómo resolver el que puedas tener las dos versiones funcionando a la vez.

Para que tu Moodle 2.9 siga funcionando correctamente, debes mantener su versión de PHP actual.

Para que Moodle 3.4 funcione igual de bien, debes instalar y/o seleccionar (dependiendo si estás en un VPS o servidor dedicado o, por el contrario, con un servicio de hosting) la versión correspondiente de PHP, en este caso 7.x para su carpeta 'moodle'.

Deberás configurar, además de la base de datos del Moodle 2.9 otra nueva para el Moodle 3.4, la que deberás consignar durante la instalación de este último.

Así también, deberás tener una carpeta de datos diferente. El 'moodledata' del Moodle 2.9 deberá ser diferente del de la versión 3.4. Por ejemplo podría llamarse 'moodledata34'

También has de tener en cuenta cómo accederás a cada Moodle desde internet. Cada uno tendrá su propio dominio, utilizarás subdominios o el mismo dominio y la carpeta que le contenga. Es decir,

https://midominio1.com que apuntará a la carpeta 'moodle1' de Moodle 2.9

https://minominio2.com que apuntará a la carpeta 'moodle2' de Moodle 3.4

ó

https://mimoodle1.midominio.com que apuntará a la carpeta 'moodle1' de Moodle 2.9

https://mimoodle2.midominio.com que apuntará a la carpeta 'moodle2' de Moodle 3.4

ó

https://midominio.com/moodle1 con el que accederás a Moodle 2.9

https://midominio.com/moodle2 con el que accederás a Moodle 3.4

En el caso de un hosting, lo más normal es que debas escoger, desde su panel de control, la versión de PHP necesaria para 'moodle1' y la necesaria para 'moodle2'

En el caso de un VPS o un servidor dedicado, deberás instalar la versión 7 de PHP y configurar el servidor web para que la carpeta 'moodle2' utilice esa versión de PHP.

Siendo este el caso, podrías utilizar una herramienta gráfica como WEBMIN webmin.com o, en su caso, VIRTUALMIN virtualmin.com para hacer las configuraciones necesarias de una manera más sencilla.

Dependiendo de la forma de acceso para cada instancia de Moodle, y de si tienes alojamiento en un proveedor de hosting o tienes un VPS o servidor dedicado, habrás de actuar de una forma u otra. Cada una con sus facilidades y/o ventajas e inconvenientes.

Saludos,

JP

 
Promedio de calificaciones: -