Security announcements

MSA-18-0016: Quiz question bank import preview could execute JavaScript

 
Picture of Michael Hawkins
MSA-18-0016: Quiz question bank import preview could execute JavaScript
 

When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.


Severity/Risk: Minor
Versions affected: 3.5, 3.4 to 3.4.3, 3.3 to 3.3.6, 3.2 to 3.2.9, 3.1 to 3.1.12 and earlier unsupported versions
Versions fixed: 3.5.1, 3.4.4, 3.3.7, 3.1.13
Reported by: Les Bell
CVE identifier: CVE-2018-10891
Changes (master): http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-62820
Tracker issue: MDL-62820 Quiz question bank import preview could execute JavaScript