General developer forum

Lost course breadcrumb links

 
Picture of Rachel Martin
Lost course breadcrumb links
 

I have upgraded our development server from 3.1 to 3.5 and it has gone reasonably well, but I have lost the current course and activities from the breadcrumb.

If I navigate to a course, it never updates to include the course title/link nor will it add any normal activity to the breadcrumb.  The breadcrumb will add administrative tools and settings/reports to the breadcrumb.  Accessing a report within a course will still only show "My courses" and then the report link.

Small example of what I am talking about below.  This is the same location, but the 3.5 is our upgraded development server and the 3.1 is our test server.  Please ignore the home/dashboard as that does not factor into this issue, as it persisted no matter what the homepage was set to.

new breadcrumb

old breadcrumb

I have swapped themes around and they all do the same thing.  I've also disabled or removed any plugins that I though might conflict.  The plugin that adds the enrollment dates, for example, has been removed for testing.

I've been hunting through code, but so far I can't figure out the disconnect.

 
Average of ratings: -
Picture of Rachel Martin
Re: Lost course breadcrumb links
 
Well, no one has chimed in to help me on this and I'm still trying to track it down.  Can anyone tell me exactly where/when the "course" gets added to the breadcrumb?

I'm trying to find exactly where in the code that is so I can try to figure out how it is getting lost.

 
Average of ratings: -