Assistance technique

Problème de mise à jour par Git

 
Avatar Charlène Lemarchand
Re: Problème de mise à jour par Git
 

Bonjour,

J'ai été confrontée au même problème.

Celui-ci était lié au fait que j'avais récupéré lors de l'installation initiale les seules sources de Moodle 3.3 avec l'option --depth=1

Il faut donc élargir le champ d’investigation en ajoutant les autres branches.

Pour cela, il faut faire les commandes suivantes :
  • cd /mon/répertoire/du/noyau/de/moodle/
  • git config remote.origin.fetch "+refs/heads/*:refs/remotes/origin/*"
  • git fetch origin
  • git checkout MOODLE_35_STABLE
Ensuite, on peut lancer la commande de mise à jour de Moodle :
  • php admin/cli/upgrade.php
Bien entendu, il faut avoir au préalable, pour des raisons de sécurité, fait une sauvegarde du noyau de Moodle, de la base de données de l'application ainsi que des données de celle-ci (on ne sais jamais).

En espérant avoir été utile à la communauté de Moodle.

Charlène Lemarchand
 
Moyenne des évaluations  -