Instalación y Actualización

Problemas con instalación de theme, plugins y cache

 
Imagen de Florencia Praderio
Problemas con instalación de theme, plugins y cache
 

Hola a todos! Soy nueva en el mundo de Moodle y estoy teniendo algunos inconvenientes cuando quiero "diseñar" mi sitio.

Utilizo un hosting contratado que me permite instalar con sólo dos clicks todo el pack Moodle. Pero lo hace en Moodle 3.2 así que ese es el que tengo.


Me instala por defecto el theme Boost y quería cambiarlo por alguno disponible en la web de Moodle que sea un poco más amigable. Elijo bien la versión del theme para mi versión y en el panel de administración de Moodle me aparece pendiente la instalación. Hasta ahí todo perfecto. Pero cuando pongo a instalar el theme, se me pone en blanco la página y me sale error 500. Me pasó exactamente lo mismo cuando quise instalar un plugin.


Googleando, encontré que es un error de cache. Y cuando voy a la carpeta de cache en el administrador de archivos de mi hosting sólo encuentro un archivo core_component.php


Intenté copiar la carpeta caché desde el .zip de instalación de Moodle 3.2 y pude reingresar al panel de administración. Pero nuevamente cuando le doy a actualizar los plugins se vacía el caché. 

Volví a copiar la carpeta y cancelé la actualización. Me apareció un mensaje de que un archivo dataroots (no recuerdo exacto el nombre y la extensión) está mal ubicado en la carpeta de Moodle y expone toda la información privada de mi sitio. Al final tuve que desinstalar Moodle y volver a instalarlo desde cero.


Esto me pasa tanto cuando quiero instalar directo desde la página de Moodle como cuando quiero hacerlo manualmente desde el Cpanel de mi hosting.


La verdad es que lo del theme puedo llegar a obviarlo, pero mi Moodle va a quedar muy acotado si no puedo expandir opciones con plugins. 


¿Alguien tendrá una idea de cómo solucionarlo?

 
Promedio de calificaciones: -
Imagen de Fernando Acedo
Re: Problemas con instalación de theme, plugins y cache
Desarrolladores de pluginsMoodlers de gran ayudaTesters

Nunca usar un auto-instalador para instalar moodle, y mucho menos una versión antigua.

 

Además, por lo que indicas, la instalación no es correcta y es posible que ese sea el problema.

 

Cambia de hosting lo antes posible. Actualmente hay muchas opciones para contratar un VPS en lugar de un hosting que posiblemente sea compartido.

 
Promedio de calificaciones:Útil (1)