Nuevos Módulos, Apariencia y Personalización

Problema con plugin Cloze Atto 1.1 en Moodle 3.5

 
Imagen de José García
Problema con plugin Cloze Atto 1.1 en Moodle 3.5
 

Muy buenas.

He buscado en el foro y no he visto reporte alguno sobre lo que me ocurre con esta extensión.

Cuando creo una pregunta tipo Cloze, ya sea usando el plugin o escribiendo la pregunta "a mano" se me presenta el problema de que me fuerza un nuevo renglón tras cada cuadro que genera para escribir la respuesta.

Si la pregunta es:

Me presenta la pregunta como:

Cuando reviso el código de la pregunta no soy capaz de ver que fuerce el nuevo renglón y no sé cómo conseguir que la pregunta quede como estaba antes de la actualización a la versión 3.5 de Moodle. El código para esta pregunta es:

¿Algún alma caritativa que me pueda echar un cable?

Tanto con Firefox como con Chrome se visualiza la pregunta como he puesto.

Muchas gracias de antemano.

 
Promedio de calificaciones: -
Germán and temudgin
Re: Problema con plugin Cloze Atto 1.1 en Moodle 3.5
Desarrolladores de pluginsDocumentadoresMoodlers de gran ayudaTestersTraductores

Hola,

Tu problema ha sido descrito en el foro en idioma inglés sobre exámenes y afecta a varios tipos de preguntas.

Se debe al cambio en la versión de Bootstrap en Moodle 3.5.


Según el Moodle Tracker MDL-62594,  resolverá con la próxima sub-versión de Moodle a ser liberada prontamente.


Se puede parchar provisionalmente con código CSS:

The same problem exists for non-cloze "short answer" (qtype_shortanswer) question types (using Boost). MDL-59047" title="Boost short answer question doesn't show up correctly">MDL-59047

I fixed it on my site by adding the following to the "Raw SCSS" box in the Boost settings.

div.qtext > input.form-control {
display: inline;
}


 
Promedio de calificaciones: -
Imagen de José García
Re: Problema con plugin Cloze Atto 1.1 en Moodle 3.5
 

Muchísimas gracias por la información que me das, Germán.

Creo que esperaré a la sub-versión que me indicas, aunque me informa Moodle que ya hay una versión 3.5.1 (Build: 20180709) Versión 2018051701 Versión estable. ¿Puede ser que esta nueva versión corrija este inconveniente?

En la revisión de correciones me habla de Bootstrap 4 pero no sé si es el que estaba ya en la versión 3.5.

Edito para decir que sí, que efectivamente esta nueva versión del 9 de julio corrige este inconveniente:

Bug MDL-62594CLOZE questions have extra newline since upgr

 
Promedio de calificaciones:Útil (1)