Moodle for mobile

why moodle 3.5 can't be built?

 
Picture of behnaz ranjbar
Re: why moodle 3.5 can't be built?
 

hi,

thanks for your answering. i'm trying to build an moodle apk in android studio that i've cloned the 3.5 version from git. when i try to generate the apk, i get such a compiling error:

error: package android.support.v4.app does not exist

but i've added that library as you can see in this picture



because of that i've tryed the 3.4 version and it was built successfully

what is the problem with 3.5?

thanks

 
Average of ratings: -
Picture of behnaz ranjbar
Re: why moodle 3.5 can't be built?
 

any solution please?

 
Average of ratings: -
Picture of Dani Ureña
Re: why moodle 3.5 can't be built?
Core developers

Hello Behnaz,

You can follow this instructions for resolve your problem:

Open the file platforms/android/build.gradle and add these code at the end:

 configurations {
     all*.exclude group: 'com.android.support', module: 'support-v4'
 }
This and others usually problems was solved at:

https://docs.moodle.org/dev/Setting_up_your_development_environment_for_Moodle_Mobile_2_(Ionic_1)#Building_for_Android_and_iOS

Best regards

 
Average of ratings: -
Picture of behnaz ranjbar
Re: why moodle 3.5 can't be built?
 

yeah after the days i could solve that problem but again thank you so much for answering

 
Average of ratings: -