Dataform (plugin)

Error with question plugin

 
Picture of Ayeesha Clare
Error with question plugin
 

Hi Moodle community, (Moodle 3.5)

I have recently downloaded a plugin Qtype MFT, which is an add on multiple choice question plugin ('https://moodle.org/plugins/qtype_mtf'). When adding questions, there was an error so I decided to delete the plugin, but I have already created questions, so I have to delete them before uninstalling (the uninstall button won't be there until I delete them). However, when I tried to delete them, I get the same error: 

Table "qtype_mtf_options" does not exist

More information about this error

×Debug info: 
Error code: ddltablenotexist
×Stack trace:
  • line 665 of /lib/dml/moodle_database.php: dml_exception thrown
  • line 1521 of /lib/dml/moodle_database.php: call to moodle_database->where_clause()
  • line 106 of /question/type/mtf/questiontype.php: call to moodle_database->get_record()
  • line 910 of /lib/questionlib.php: call to qtype_mtf->get_question_options()
  • line 979 of /lib/questionlib.php: call to _tidy_question()
  • line 613 of /question/engine/bank.php: call to get_question_options()
  • line 392 of /cache/classes/loaders.php: call to question_finder->load_for_cache()
  • line 1456 of /cache/classes/loaders.php: call to cache->get()
  • line 494 of /question/engine/bank.php: call to cache_application->get()
  • line 255 of /question/engine/bank.php: call to question_finder->load_question_data()
  • line 1618 of /lib/questionlib.php: call to question_bank::load_question_data()
  • line 1649 of /lib/questionlib.php: call to question_has_capability_on()
  • line 932 of /question/classes/bank/view.php: call to question_require_capability_on()
  • line 467 of /question/classes/bank/view.php: call to core_question\bank\view->process_actions_needing_ui()
  • line 57 of /question/edit.php: call to core_question\bank\view->display()
Does any one know what I should do to fix this? Im really new to Moodle, and I have tried to fix myself, but I haven't found anyone with a similar error. I also don't know enough about coding to feel confident changing the HTML. 

If I can't fix, would you suggest to create a new Moodle account? I was just playing around with Moodle's possibilities, so I haven't really started my site yet anyway. 


Thanks so much, any help would be really, really appreciated. smile

Ayeesha

 
Average of ratings: -