Installing and upgrading help

Migrated to new host & now no images showing

 
Picture of Ken Task
Re: Migrated to new host & now no images showing
Particularly helpful Moodlers

Good!  Congrats!

To the moderators of this forum or whomever issues badges .... this user (Tina Smith) deserves a badge for something ... tenacity if nothing else ... got one of those Moodle Community Forums? smile

https://goo.gl/images/4ikMNs

'spirit of sharing', Ken


 
Average of ratings: -
Picture of Visvanath Ratnaweera
Re: Migrated to new host & now no images showing. Now they are showing.
Particularly helpful Moodlers
Let's create one. I propose "The Sunflower Mom Medal for resilience".

What about the 'spirit of sharing'? The Prof.? and the cat?
smile
 
Average of ratings: -
Picture of Tina Smith
Re: Migrated to new host & now no images showing
 
Lol!  :)



On Sat, Jul 14, 2018 at 6:54 AM Visvanath Ratnaweera (via Moodle.org) <
 
Average of ratings: -
Picture of Tina Smith
Re: Migrated to new host & now no images showing
 
Aww, thanks Ken! You were a big help! Giving me encouragement and info I

needed along the way to help dicypher things. I especially appreciate how

you didn’t talk down to me for the things I didn’t know. Thank you!



And not giving up on me! Thanks so much!



Thank you to everyone that contributed to helping me on this thread! I

really appreciate it!







On Fri, Jul 13, 2018 at 8:07 PM Ken Task (via Moodle.org) <
 
Average of ratings: -
Picture of Rick Jerz
Re: Migrated to new host & now no images showing
Particularly helpful Moodlers

Tina, no need to reply to me if you wish, but all of this got me wondering about where you started and where you are right now.

1. What is your running version of Moodle?

2. Where is your Moodle hosted?  (e.g., Host Gator?)

3. What did you succeed doing?  (e.g., Upgraded? Changed domain name?  Got old copy running? Moved old Moodle to new server company? Got Host Gater to restore old Moodle? etc.)

4. What would you like to do next?

It is really great that you got to the point where you are up and running?  (I am still planning to make the migrate video.)

 
Average of ratings: -
Picture of Tina Smith
Re: Migrated to new host & now no images showing
 
I don’t mind answering, Rick! :)



I’ll reply below...
 
Average of ratings: -
Picture of Tina Smith
Re: Migrated to new host & now no images showing
 

UGH! I replied in my email back, but apparently it stripped all my answers...ok, let's try this again....


1. What is your running version of Moodle?

The latest...3.5.1, I think?


2. Where is your Moodle hosted?  (e.g., Host Gator?)

The old (awful) host I moved away from was Host Gator. I am now with Siteground, and quite happy!


3. What did you succeed doing?  (e.g., Upgraded? Changed domain name?  Got old copy running? Moved old Moodle to new servercompany? Got Host Gater to restore old Moodle? etc.)

So, it actually ended up being very simple in the end...

I ended up just doing a fresh (manual) install on the new server (Siteground), and then deleted the entire new database it had populated in the install, and made a fresh one again...then imported my backup database. That got me all my content and users and format from the courses. But NOT my images. Still broken.

So then after much back and forth and round and round, we figured out this...

My old install was installed with Quickinstall installer. From what I can surmise, it appears it doesn't create a moodledata directory on install. All I can figure is that Moodle must automatically create that moodledata directory when it has stuff to put in it maybe? For whatever reason, the "filedir" directory with all my images wasn't saved IN the moodledata directory, but one level up.  So after we finally figured out that the "filedir" inside the moodledata was essentially empty, I noticed there was ANOTHER "filedir" in the level above it. Compressed and downloaded that and it was 1.6GB, SCORE!! Migrated that to my new server and VOILA! All images back in place!!

P.S. this is where Quickinstall put the moodledata directory: /home/tinamama/.cpanel/quickinstall/moodle-1422740527  So it took some digging just to find it even! And then to find out that it was essentially empty!  

So much around and around trying to figure all this out, but I did learn a LOT from all of this, so it was not time wasted! And I really appreciate everyone that contributed to helping me!


4. What would you like to do next?

Well now that it's all working properly, I have a lot of revamping to do, plus a ton of improvements. 

I let my Moodle install sit unused for far too long. I do innovative, interactive courses for fellow homeschool moms' children, and it had all been put on hold as I didn't have time for it recently. But now I'm fired up to get back to it. I currently sell a fun series of courses to go along with the Amazing Race, to learn about the countries the racers race through and after I get the whole of Moodle cleaned up and prettified (got my graphic artist daughter working on some new images for me!)...I'm going to start with completing my revamp of that series. I have an entire overhaul of that series I started after I figured out a better way to structure those classes that I never completed. So that's top of my list, after getting Moodle to look whiz bang.

But FIRST, I'm going to work today on getting fully GDPR compliant. I have some stuff to sort through for that. Making good progress. 

I also decided it was time to do some real step by step tutorials and started doing all the appropriate Moodle tutorials on Lynda.com, starting with the administrative one, which I finished over the weekend. It was a lot of stuff I already knew, but it did fill in a few gaps I had. And I'm moving on to the 3.5 tutorial next, which I think will be fun to learn all about features I am new to or not using to their fullest extent.

And I have a whole list of ideas for new courses...so there's a lot on the horizon for my "Noodle Homeschool" business! smile


It is really great that you got to the point where you are up and running?  (I am still planning to make the migrate video.)

Thanks! I'd love to see that video!
 
Average of ratings: -
Picture of Rick Jerz
Re: Migrated to new host & now no images showing
Particularly helpful Moodlers

Okay Tina, I feel good with where you are.

For Question #1. Go to Site Administration, Notifications.  Your Moodle version should look something like: Moodle 3.5+ (Build: 20180531). Post what you see.

For Question #2. Great!

For Question #3.  I was puzzled by the small size of your moodledata folder, which was in the KBs.  This meant to me that you had essentially nothing in your course.  There has to always be a moodledata folder, somewhere, unless you have a really odd install.  Look at your config.php file (in the moodle folder) and you will see where your moodledata folder is. Out of curiosity, where is your new moodledata folder?

For Question #4. I don't do GDPR (yet) so I can't help with that.  Yep, lots of great Moodle resources.  I have an old book titled "Moodle Security" which I found helpful.

Well, you succeeded with the migration!  Pretty soon, you will be able to make that video!

For what it is worth, here are the videos that I provide my students in order for them to learn my system.  Also, you might browse (you have probably done this many times) Site Admin, Server, Environment.  This too provides some good information about your server and your Moodle.



 
Average of ratings: -